ARGH! All data in 2 files replaced with # signs!!!

Discuss setup / installation issues - Add a spell checker, Language pack?

ARGH! All data in 2 files replaced with # signs!!!

Postby fig4159 » Tue Apr 09, 2019 9:39 pm

I've been using OpenOffice for a long time - but this seems to be the only forum I can post in without choosing a specific program.

A few minutes ago, something VERY strange happened: the program turned 2 of my files (1 Writer, 1 Calc) and turned the ENTIRE CONTENTS into #' signs! I'm in full freak out mode, because that Calc file holds (and I HOPE it still does!) ALL my personal financial data.

I'm not sure what caused it. My PC was lagging but I properly and successfully shut Office down BEFORE I rebooted my computer. When it restarted, I opened Office, and it asked me for my name! That was confusing, but since it wouldn't let me ignore it, I re-entered it. But, when I re-opened the fles, ALL DATA in both files has been changed to POUND (#) signs!, and the spreadsheet, which had multiple pages, looks like a text document!

HOW CAN I FIX THIS? I didn't save the new documents, but I also wasn't given an option to.

Thank you SO MUCH in advance!

OpenOffice 4.1.6 on Windows 10 Home V1709 Build 16299.1029
Posts: 1
Joined: Tue Apr 09, 2019 8:42 pm

Re: ARGH! All data in 2 files replaced with # signs!!!

Postby Hagar Delest » Tue Apr 09, 2019 10:02 pm

Hi and welcome to the forum!

Sorry, see: [Tutorial] The Dreaded Pound Signs: file reduced to ####.
Good luck.

I hope you had backups.
LibreOffice 7.0.3 on Xubuntu 20.10 and LibreOffice 6.4.6 (portable) on Windows 10.
User avatar
Hagar Delest
Posts: 29288
Joined: Sun Oct 07, 2007 9:07 pm
Location: France

Re: ARGH! All data in 2 files replaced with # signs!!!

Postby RoryOF » Tue Apr 09, 2019 10:42 pm

You may have been over hasty between the close down of OpenOffice and the reboot, not leaving sufficient time for the files to be flushed to disk from the internal budffering of the hard drive; or perhaps the lag of the computer abnormally slowed up the disk writing, leading to the files not being fully written. The process of writing the files is complex and the archive that is the OO file is built, with space reserved for the actual content, which is last to be written - hence the ### placeholders.

Look at [Tutorial] How to find and un-delete AOO temporary files
for methods of recovering deleted anbd temporary copies of your files. Do this soonest. You may, or may not, find such files containig some, all, or none of your data.
Apache OpenOffice 4.1.8 on Xubuntu 20.04.1 (mostly 64 bit version) and very infrequently on Win2K/XP
User avatar
Posts: 32038
Joined: Sat Jan 31, 2009 9:30 pm
Location: Ireland

Re: ARGH! All data in 2 files replaced with # signs!!!

Postby Zizi64 » Wed Apr 10, 2019 6:55 am


There is not any way.

But you must ask this - for your future works:
HOW CAN I prevent THIS?

The answer:
Make often backup files with timestamped file name. Then you will able get the last working version from the backup directory.
You can use the timeStamp Backup extension: ... amp-backup.
Tibor Kovacs, Hungary; LO6.1.6, 6.2.8 /Win7-10 x64Prof.
PortableApps/winPenPack: LO3.3.0-6.4.5;AOO4.1.7
Please, edit the initial post in the topic: add the word [Solved] at the beginning of the subject line - if your problem has been solved.
User avatar
Posts: 9704
Joined: Wed May 26, 2010 7:55 am
Location: Budapest, Hungary

Return to Install, Setup and Troubleshooting

Who is online

Users browsing this forum: No registered users and 5 guests