[Solved] Unrecognised font

Issues installing under the Mac OSX - X11 - Aqua

[Solved] Unrecognised font

Postby mwatkins » Mon Feb 11, 2019 4:17 pm

I've been cutting and pasting text from a Scribus document into an OpenOffice document (I need something in .doc format for an EBook conversion). The bulk of the text is in Athelas font, which is installed as Athelas.ttc in my /Library/Fonts folder as usual. However, when pasted into Open Office the text comes out looking like it's in an Arial-type font. This appears to be some kind of default due to the fact that OpenOffice isn't recognising Athelas (I was puzzled to find that it's not in the font dropdown list).

I believe this has something to do with 'native' vs. 'non-native' fonts - am I right? Is there an easy fix for this?

Thanks in advance for any help!
MW
Last edited by mwatkins on Mon Feb 11, 2019 5:35 pm, edited 2 times in total.
Open Office 4.1.3 on Mac OS 10.11.6
mwatkins
 
Posts: 2
Joined: Mon Feb 11, 2019 4:09 pm

Re: unrecognised font

Postby John_Ha » Mon Feb 11, 2019 4:42 pm

It sounds like the font is not installed properly. Google install font mac. Restart Writer.

The reason it looks like Arial is because the font showing in the Writer font drop-down selection box is the font the document is asking for.

If the font being asked for is not installed on the PC, Windows (or other operating system) will silently substitute a different font which is available, and use that substitute font to display the text.

The TestFonts add-on is invaluable for finding missing fonts which the document is asking for, but which are not installed on the PC.

You can see which fonts are installed on a Windows PC by Start > Control Panel > Fonts or by clicking C:\Windows\Fonts.

You will find much useful information in the User Guides, the Writer, Base and Calc Tutorials and the AOO Frequently Asked Questions. May I suggest you bookmark the pages. There is also a Mac FAQ which has "Q32: I think I have a problem with fonts. What can I do?" - I suggest you read it.

Showing that a problem has been solved helps others searching so, if your problem is now solved, please view your first post in this thread and click the Edit button (top right in the post) and add [Solved] in front of the subject.
AOO 4.1.6, Windows 7 Home 64 bit

See the Writer Manual, the Writer FAQ, the Writer Tutorials and the Writer guide.

Remember: Always save your Writer files as .odt files. - see here for the many reasons why.
John_Ha
Volunteer
 
Posts: 6592
Joined: Fri Sep 18, 2009 5:51 pm
Location: UK

Re: unrecognised font

Postby mwatkins » Mon Feb 11, 2019 5:35 pm

I'm confused...surely the font must have been installed if Scribus can recognise and display it?

but I read a description of how to install fonts on a Mac, downloaded Athelas (even though I already appear to have it installed) and followed the instructions. Everything did what it should have. I restarted OpenOffice, and YES it recognises Athelas and appropriately displays it.

Thanks!
Open Office 4.1.3 on Mac OS 10.11.6
mwatkins
 
Posts: 2
Joined: Mon Feb 11, 2019 4:09 pm


Return to Mac OSX

Who is online

Users browsing this forum: No registered users and 2 guests