UNI:PasteSpecial-Format1 forces me to click OK?

Creating a macro - Writing a Script - Using the API

UNI:PasteSpecial-Format1 forces me to click OK?

Postby alf50 » Fri Feb 01, 2019 9:14 am

UNI:PasteSpecial-Format1 forces me to click OK?
Using an Apple Script, I copy a full Apple Mac Safari Web Page that contains a table having 5 columns and 160 Rows.
I then try to past the entire web page to an Open Office Calc Sheet, and extract the table from the sheet.
The problem is, with a regular past, the table is 320 rows deep because the html code probably includes a chr Return and a line feed.
I then try a UNI:PasteSpecial-Format1 to remove the embedded blank rows but the macro will not run without my intervening "OK" Click.

How can I get the Format 1 (i.e.: unformatted text PasteSpecial) to work without my having to click the OK button manually?

Using Format 10 (i.e.: Rich Text Format PastSpecial) works without the dialog box being displayed, but the blank rows are not removed.

any suggestions would be greatly appreciated.
OpenOffice 4.1.5 on Mac El Capitan(10.11.6) and MS Windows10
alf50
 
Posts: 97
Joined: Sun Jun 13, 2010 2:55 pm

Re: UNI:PasteSpecial-Format1 forces me to click OK?

Postby JeJe » Fri Feb 01, 2019 11:44 am

There's a long similar thread, in case you haven't seen it.

viewtopic.php?f=20&t=10706
Openoffice 4.1.2
Windows 8
JeJe
Volunteer
 
Posts: 508
Joined: Wed Mar 09, 2016 2:40 pm


Return to Macros and UNO API

Who is online

Users browsing this forum: No registered users and 6 guests