Prevent automatic Doc Locking

Discuss setup / installation issues - Add a spell checker, Language pack?

Prevent automatic Doc Locking

Postby THEBookMan » Fri Jan 18, 2019 7:10 pm

Have been using OO for quite sometime, now. LOVE IT!!

Problem surfaced a short while ago:
All OO documents are automatically lock and I can only open them for "read Only"
Although i can see that this is important for multi users networks, I am the only one using this computer.

How do I prevent/turn off "Automatic Doc Lock"?

Must I unlock each one?
I would prefer to unlock all at once.

Have hunted for & not found ".~lock" anywhere on my 'puter.

Thanks for your time,
⌡im [THE BookMan]
920.265.5966
Open Office 4.1.3 Win 10
THEBookMan
 
Posts: 80
Joined: Wed Sep 30, 2015 10:03 pm
Location: GB, WI (some sort of sport team lives around here)

Re: Prevent automatic Doc Locking

Postby John_Ha » Fri Jan 18, 2019 7:36 pm

AOO does not do that so there is a problem on your PC. Check your Windows Defender settings.

Download this file and place on the desktop. Can you open, edit and save it?
Attachments
test.odt
(11.71 KiB) Downloaded 11 times
AOO 4.1.6, Windows 7 Home 64 bit

See the Writer Manual, the Writer FAQ, the Writer Tutorials and the Writer guide.

Remember: Always save your Writer files as .odt files. - see here for the many reasons why.
John_Ha
Volunteer
 
Posts: 6611
Joined: Fri Sep 18, 2009 5:51 pm
Location: UK

Re: Prevent automatic Doc Locking

Postby RoryOF » Fri Jan 18, 2019 7:51 pm

Have you enabled "viewing of hidden and Archive files" (words to that effect) on the directories in which reside your files? You must do this to see the lock files. Also, in the root of your OO User profile, check that there is not a hidden Lock file.

I do not advise turning off the lock files - if you were, for example, to open a file twice - once (say) at beginning, once at end, to transfer text, or to enter notes for which you needed access to the early part of the file, it is very easy to get confused as to which file has been updated - one might in fact update both, and lose the updates. Better to establish why the lock files are remaining and cure that problem..

Were the files brought forward from another computer, or a backup disk (after a system restore, perhaps)? If so, the lock files may have been copied as part of the backup or the restore.
Apache OpenOffice 4.1.6 on Xubuntu 18.04.2 (mostly 64 bit version) and very infrequently on Win2K/XP
User avatar
RoryOF
Moderator
 
Posts: 28918
Joined: Sat Jan 31, 2009 9:30 pm
Location: Ireland

Re: Prevent automatic Doc Locking

Postby keme » Sun Jan 20, 2019 8:59 am

John_Ha wrote:AOO does not do that ...

Oh, well ... it might.

See menu item File - Properties, the Security tab.
Is there a tick mark to save as write protected?

This setting is sometimes "enabled by default". It's been a few years since I last heard about it, so I thought it was a fixed glitch.

If this is your culprit, I present to you good and bad news:
The bad news is that the cause is not in the file system, so you can't reset it for all your documents in one go.
The good news is that the cause is not in the file system, so it is easily fixed inside Writer/Calc/etc.: To edit, click the "Edit file" icon on the toolbar (the one to the left of the PDF export icon). You may also want to untick that security setting, so your file is editable by default next time you open it.
User avatar
keme
Volunteer
 
Posts: 3156
Joined: Wed Nov 28, 2007 10:27 am
Location: Egersund, Norway

Re: Prevent automatic Doc Locking

Postby RoryOF » Sun Jan 20, 2019 10:52 am

Good catch, keme. There are almost always a number of ways of achieving a desired aim in OpenOffice, and we each use a limited number of these in daily work, forgetting that there may be other ways we have forgotten about.
Apache OpenOffice 4.1.6 on Xubuntu 18.04.2 (mostly 64 bit version) and very infrequently on Win2K/XP
User avatar
RoryOF
Moderator
 
Posts: 28918
Joined: Sat Jan 31, 2009 9:30 pm
Location: Ireland

Re: Prevent automatic Doc Locking

Postby John_Ha » Sun Jan 20, 2019 5:49 pm

keme wrote:Oh, well ... it might.

See menu item File - Properties, the Security tab.
Is there a tick mark to save as write protected?

Good catch!

May I defend my comment "AOO does not do that ..." because any earlier documents will not be so locked. The poster said "All documents ..." - perhaps he means "All newly saved documents ..."
AOO 4.1.6, Windows 7 Home 64 bit

See the Writer Manual, the Writer FAQ, the Writer Tutorials and the Writer guide.

Remember: Always save your Writer files as .odt files. - see here for the many reasons why.
John_Ha
Volunteer
 
Posts: 6611
Joined: Fri Sep 18, 2009 5:51 pm
Location: UK

Re: Prevent automatic Doc Locking

Postby RoryOF » Sun Jan 20, 2019 5:52 pm

But if the locking is not caused by the method keme has pointed to, we need to find what the OP is doing that causes the documents to be locked.
Apache OpenOffice 4.1.6 on Xubuntu 18.04.2 (mostly 64 bit version) and very infrequently on Win2K/XP
User avatar
RoryOF
Moderator
 
Posts: 28918
Joined: Sat Jan 31, 2009 9:30 pm
Location: Ireland

Re: Prevent automatic Doc Locking

Postby John_Ha » Sun Jan 20, 2019 10:18 pm

The File > Properties > Security ..., applies only to the file being edited.

It isn't sticky so it has to be applied when required in any file making it unlikely that multiple files would be affected.
AOO 4.1.6, Windows 7 Home 64 bit

See the Writer Manual, the Writer FAQ, the Writer Tutorials and the Writer guide.

Remember: Always save your Writer files as .odt files. - see here for the many reasons why.
John_Ha
Volunteer
 
Posts: 6611
Joined: Fri Sep 18, 2009 5:51 pm
Location: UK


Return to Install, Setup and Troubleshooting

Who is online

Users browsing this forum: No registered users and 2 guests