[Solved] How to disable word completion in text documents

Discuss the word processor

[Solved] How to disable word completion in text documents

Postby ellsl » Fri Jan 18, 2019 1:45 am

I cannot disable word completion. I have unticked "enable word completion," I have set the minimum word length to 100, and I have unticked "Autocorrect While Typing." And still the program suggest word completions. This is very annoying, and I can't find any other suggestions of how to fix this in this forum. Any ideas?
Last edited by robleyd on Sat Jan 19, 2019 12:47 am, edited 1 time in total.
Reason: Tagged [Solved] [robleyd, Moderator]
OpenOffice 4.1.6 on Windows 10
ellsl
 
Posts: 5
Joined: Fri Jan 18, 2019 1:35 am

Re: how to disable word completion in text documents

Postby robleyd » Fri Jan 18, 2019 3:31 am

Cheers
David
Apache OpenOffice 420m2(Build:9821) - Slackware 14.2 - 64 bit
LibreOffice 6.0.7.3 - Slackware 14.2 - 64 bit
Apache OpenOffice 4.1.4 - Windows 7 Virtual machine
User avatar
robleyd
Moderator
 
Posts: 3035
Joined: Mon Aug 19, 2013 3:47 am
Location: Murbko, Australia

Re: how to disable word completion in text documents

Postby ellsl » Fri Jan 18, 2019 5:06 am

Yes, I read this. I've unticked just about everything I thought might be relevant, and no luck. I'm typing Japanese and English in the same document, in case that might be relevant.
OpenOffice 4.1.6 on Windows 10
ellsl
 
Posts: 5
Joined: Fri Jan 18, 2019 1:35 am

Re: how to disable word completion in text documents

Postby Zizi64 » Fri Jan 18, 2019 8:32 am

What AOO component are you using? Writer or the Calc?
The Writer has Auto Complete function, but the Calc has Auto Input function.
Which one did you meant?




If the setting seems not to work, then try to reset (delete or rename) your AOO user profile and then repeat the relevant settings in the new profile.
Tibor Kovacs, Hungary; LO6.1.6 on Win7-10 x64Prof.
PortableApps, winPenPack: LO3.3.0-6.3.2; AOO4.1.6
Please, edit the initial post in the topic: add the word [Solved] at the beginning of the subject line - if your problem has been solved.
User avatar
Zizi64
Volunteer
 
Posts: 8476
Joined: Wed May 26, 2010 7:55 am
Location: Budapest, Hungary

Re: How to disable word completion in text documents

Postby keme » Fri Jan 18, 2019 12:21 pm

Windows 10/1803 update added the autocomplete option also for hardware keyboards. This page states that it is an opt-in feature, but for me it was enabled immediately after update, and the suggestions were worse than useless (far worse than I have seen on Android/iOS). Might this be your culprit?
(Click the link above to get a page describing how to enable it, which is also the path to disabling it.)
User avatar
keme
Volunteer
 
Posts: 3268
Joined: Wed Nov 28, 2007 10:27 am
Location: Egersund, Norway

Re: How to disable word completion in text documents

Postby John_Ha » Fri Jan 18, 2019 1:08 pm

keme wrote:Windows 10/1803 update added the autocomplete option also for hardware keyboards.

Windows 10 updates seem to be a complete nightmare. I staying on W7 until the very last day of support.
AOO 4.1.6, Windows 7 Home 64 bit

See the Writer Guide, the Writer FAQ, the Writer Tutorials and Writer for students.

Remember: Always save your Writer files as .odt files. - see here for the many reasons why.
John_Ha
Volunteer
 
Posts: 6870
Joined: Fri Sep 18, 2009 5:51 pm
Location: UK

Re: How to disable word completion in text documents

Postby RoryOF » Fri Jan 18, 2019 1:26 pm

I moved away to linux, apart from one old machine (not turned on in years) in case access is needed to historical files.
Apache OpenOffice 4.1.7 on Xubuntu 18.04.3 (mostly 64 bit version) and very infrequently on Win2K/XP
User avatar
RoryOF
Moderator
 
Posts: 29767
Joined: Sat Jan 31, 2009 9:30 pm
Location: Ireland

Re: How to disable word completion in text documents

Postby John_Ha » Fri Jan 18, 2019 2:32 pm

keme wrote:Windows 10/1803 update added the autocomplete option also for hardware keyboards. This page states that it is an opt-in feature, but for me it was enabled immediately after update, and the suggestions were worse than useless (far worse than I have seen on Android/iOS).

I guess this is another example of Microsoft playing catch-up with Android and moving Windows away from being an OS for PCs to being an OS for mobile phones.

And there you - I have revealed my age. No-one under the age of 30 knows what a mobile phone is. It's a phone - what's mobile got to do with it?
AOO 4.1.6, Windows 7 Home 64 bit

See the Writer Guide, the Writer FAQ, the Writer Tutorials and Writer for students.

Remember: Always save your Writer files as .odt files. - see here for the many reasons why.
John_Ha
Volunteer
 
Posts: 6870
Joined: Fri Sep 18, 2009 5:51 pm
Location: UK

Re: How to disable word completion in text documents

Postby RoryOF » Fri Jan 18, 2019 2:41 pm

Both John and I remember when they were as big as a building brick. John, do you remember Maxwell Smart's shoe phone? (and Agent 99, the delectable Barbara Feldon)?
Apache OpenOffice 4.1.7 on Xubuntu 18.04.3 (mostly 64 bit version) and very infrequently on Win2K/XP
User avatar
RoryOF
Moderator
 
Posts: 29767
Joined: Sat Jan 31, 2009 9:30 pm
Location: Ireland

Re: How to disable word completion in text documents

Postby John_Ha » Fri Jan 18, 2019 2:53 pm

RoryOF wrote:Both John and I remember when they were as big as a building brick. John, do you remember Maxwell Smart's shoe phone? (and Agent 99, the delectable Barbara Feldon)?

I don't recall those.

My first (company) mobile phone was like a small suitcase with a carrying handle. It doubled as a car phone and had a special carrier in the boot into which it slid. The battery was about 6" x 9" x 1". It looked a bit like this.

There was a story about Lew Grade, who had a mobile phone in his Rolls Royce back in the 60s or 70s when car phones were extremely rare and fabulously expensive. The phone rang and his secretary, who was in the car, answered. When she said it was his brother, he told her to tell him he was busy on the other line ...
Attachments
Clipboard01.jpg
AOO 4.1.6, Windows 7 Home 64 bit

See the Writer Guide, the Writer FAQ, the Writer Tutorials and Writer for students.

Remember: Always save your Writer files as .odt files. - see here for the many reasons why.
John_Ha
Volunteer
 
Posts: 6870
Joined: Fri Sep 18, 2009 5:51 pm
Location: UK

Re: How to disable word completion in text documents

Postby robleyd » Fri Jan 18, 2019 2:58 pm

Cheers
David
Apache OpenOffice 420m2(Build:9821) - Slackware 14.2 - 64 bit
LibreOffice 6.0.7.3 - Slackware 14.2 - 64 bit
Apache OpenOffice 4.1.4 - Windows 7 Virtual machine
User avatar
robleyd
Moderator
 
Posts: 3035
Joined: Mon Aug 19, 2013 3:47 am
Location: Murbko, Australia

Re: How to disable word completion in text documents

Postby RoryOF » Fri Jan 18, 2019 3:02 pm

But no one has ever improved on "The Cone of Silence".

https://en.wikipedia.org/wiki/Cone_of_Silence_(Get_Smart)
Apache OpenOffice 4.1.7 on Xubuntu 18.04.3 (mostly 64 bit version) and very infrequently on Win2K/XP
User avatar
RoryOF
Moderator
 
Posts: 29767
Joined: Sat Jan 31, 2009 9:30 pm
Location: Ireland

Re: How to disable word completion in text documents

Postby ellsl » Fri Jan 18, 2019 7:47 pm

keme wrote:Windows 10/1803 update added the autocomplete option also for hardware keyboards. This page states that it is an opt-in feature, but for me it was enabled immediately after update, and the suggestions were worse than useless (far worse than I have seen on Android/iOS). Might this be your culprit?
(Click the link above to get a page describing how to enable it, which is also the path to disabling it.)


I was hoping this was the answer, but, alas, it isn't. In checking this out, though, I noticed that the word completion suggestions are only provided when I type in Japanese; there are none when I type in English. The is probably the key to the answer, which still escapes me. Any ideas?
OpenOffice 4.1.6 on Windows 10
ellsl
 
Posts: 5
Joined: Fri Jan 18, 2019 1:35 am

Re: how to disable word completion in text documents

Postby ellsl » Fri Jan 18, 2019 7:52 pm

Zizi64 wrote:What AOO component are you using? Writer or the Calc?
The Writer has Auto Complete function, but the Calc has Auto Input function.
Which one did you meant?




If the setting seems not to work, then try to reset (delete or rename) your AOO user profile and then repeat the relevant settings in the new profile.


I mean auto complete in the writer. I managed to turn off auto input in calc.

What is the AOO user profile? I don't see anything in the help file.
OpenOffice 4.1.6 on Windows 10
ellsl
 
Posts: 5
Joined: Fri Jan 18, 2019 1:35 am

Re: How to disable word completion in text documents

Postby ellsl » Fri Jan 18, 2019 9:05 pm

I finally solved it! The problem was in the settings for the Microsoft IME that I use to type in both English and Japanese. Find Tools on the language bar, click on properties. I unticked "Use Input History Data" under Predictive Input. Then I clicked on Advanced, and then on the tab "Predictive Input." Then I unticked "Use predictive input system." Problem solved!
OpenOffice 4.1.6 on Windows 10
ellsl
 
Posts: 5
Joined: Fri Jan 18, 2019 1:35 am

Re: How to disable word completion in text documents

Postby John_Ha » Fri Jan 18, 2019 9:14 pm

ellsl wrote:I cannot disable word completion. I have unticked "enable word completion," I have set the minimum word length to 100, and I have unticked "Autocorrect While Typing." And still the program suggest word completions.

There are only three ways AOO can "autocomplete" something you type.

1 Tools > Autocorrect options > Replace ...

2 Tools > Autocorrect options > Word completion. This can also be disabled at Format > AutoCorerct ... untick While typing.

3 AutoText - search Help with Using AutoText. You need to save what you want it to do.

Does it do it in other programs? If so you might be be using something like AutoHotKey which can convert what you type (eg thnak) into thank.
AOO 4.1.6, Windows 7 Home 64 bit

See the Writer Guide, the Writer FAQ, the Writer Tutorials and Writer for students.

Remember: Always save your Writer files as .odt files. - see here for the many reasons why.
John_Ha
Volunteer
 
Posts: 6870
Joined: Fri Sep 18, 2009 5:51 pm
Location: UK


Return to Writer

Who is online

Users browsing this forum: robleyd and 29 guests