Text in "File Name" field doesn't disappear when erased

Issues with installing under all Linux Distributions

Text in "File Name" field doesn't disappear when erased

Postby stoatmax » Thu Nov 08, 2018 10:55 pm

Hi all,

I'm installing AOO on a number of PCs for a client of mine. I've already installed Linux Mint 19 on all of them, and replaced the included LibreOffice with AOO per his request.

On all of the machines, without fail, I have an issue in the "Save as" window. In the "File name" field, any text I backspace will not go away. Essentially, the letters are layered on top of eachother. I tried updating from 4.1.1 to 4.1.5, as well as removing OpenJDK and installing Oracle JRE 8, all to no avail.

Any ideas as to what could be causing this problem? Thank you in advance.
OpenOffice 4.1.5 on Linux Mint 19
stoatmax
 
Posts: 4
Joined: Thu Nov 08, 2018 10:46 pm

Re: Text in "File Name" field doesn't disappear when erased

Postby RoryOF » Thu Nov 08, 2018 11:21 pm

As a diagnostic, what happens if you select the text, then press Delete?

On my computers, running OO 4.1.x on Xubuntu 18.04.1 I have no problem such as you report.
Apache OpenOffice 4.1.6 on Xubuntu 18.04 (mostly 64 bit version) and infrequently on Win2K/XP
User avatar
RoryOF
Moderator
 
Posts: 27654
Joined: Sat Jan 31, 2009 9:30 pm
Location: Ireland

Re: Text in "File Name" field doesn't disappear when erased

Postby stoatmax » Thu Nov 08, 2018 11:29 pm

The issue remains the same whether I use the delete key or backspace.

As well, I should note that some of the machines are running 64bit Cinnamon, while others are running 32bit XFCE, and the problem is the same with both.
OpenOffice 4.1.5 on Linux Mint 19
stoatmax
 
Posts: 4
Joined: Thu Nov 08, 2018 10:46 pm

Re: Text in "File Name" field doesn't disappear when erased

Postby RoryOF » Thu Nov 08, 2018 11:32 pm

If you start a plain text editor, do the delete and backspace keys work correctly?
Apache OpenOffice 4.1.6 on Xubuntu 18.04 (mostly 64 bit version) and infrequently on Win2K/XP
User avatar
RoryOF
Moderator
 
Posts: 27654
Joined: Sat Jan 31, 2009 9:30 pm
Location: Ireland

Re: Text in "File Name" field doesn't disappear when erased

Postby stoatmax » Thu Nov 08, 2018 11:34 pm

Yes. The only instance of this issue occurring is in the "save as" window of AOO. I can't replicate it anywhere else.
OpenOffice 4.1.5 on Linux Mint 19
stoatmax
 
Posts: 4
Joined: Thu Nov 08, 2018 10:46 pm

Re: Text in "File Name" field doesn't disappear when erased

Postby RoryOF » Thu Nov 08, 2018 11:38 pm

A longer diagnostic: I suggest making a live DVD/USB of Xubuntu 18/04/1 and booting a machine from it. Then remove LibreOffice (sudo apt purge libreoffice*) and install OpenOffice 4.1.5; does the problem then exist?
Apache OpenOffice 4.1.6 on Xubuntu 18.04 (mostly 64 bit version) and infrequently on Win2K/XP
User avatar
RoryOF
Moderator
 
Posts: 27654
Joined: Sat Jan 31, 2009 9:30 pm
Location: Ireland

Re: Text in "File Name" field doesn't disappear when erased

Postby Bill » Fri Nov 09, 2018 3:09 am

This is probably the same problem discussed in Over-written menu responses .

It also affects 64-bit LM 19 Mate, 64-bit LM 19 XFCE and possibly Manjaro Cinnamon (I switched to Manjaro Mate after seeing the problem on Manjaro Cinnamon). Ubuntu Mate 18.04 and Manjaro Mate are OK.
AOO 4.1.5 and LO 6.0.3.2 on Manjaro MATE
Bill
Volunteer
 
Posts: 6940
Joined: Sat Nov 24, 2007 6:48 am

Re: Text in "File Name" field doesn't disappear when erased

Postby Bill » Fri Nov 09, 2018 4:06 am

Try changing from the default Mint-Y theme in LM 19 to a different theme. The problem disappeared after I changed from the Mint-Y theme to the Mint-X theme in both LM 19 Mate and LM 19 XFCE. The problem reappeared when I switched back to the Mint-Y theme. Unfortunately, I don't have a copy of LM 19 Cinnamon to test.
AOO 4.1.5 and LO 6.0.3.2 on Manjaro MATE
Bill
Volunteer
 
Posts: 6940
Joined: Sat Nov 24, 2007 6:48 am

Re: Text in "File Name" field doesn't disappear when erased

Postby Bill » Fri Nov 09, 2018 4:26 pm

I've now had a chance to test LM 19 Cinnamon and found the same behavior. The problem occurs when Controls is set to Mint-Y in the LM 19 theme settings. Changing the Controls setting to Mint-X solves the problem. Mint-X was the default setting in LM 18. The default was changed to Mint-Y in LM 19.
AOO 4.1.5 and LO 6.0.3.2 on Manjaro MATE
Bill
Volunteer
 
Posts: 6940
Joined: Sat Nov 24, 2007 6:48 am

Re: Text in "File Name" field doesn't disappear when erased

Postby stoatmax » Fri Nov 09, 2018 9:35 pm

Hi Bill,

I saw your topic when researching the issue and figured it was somehow related. I'll definitely try changing to Mint-X next time I am working on my client's systems. I am impressed by your troubleshooting abilities, and appreciate your help.

I'll mark the topic "solved" once I verify that the issue is fixed.
OpenOffice 4.1.5 on Linux Mint 19
stoatmax
 
Posts: 4
Joined: Thu Nov 08, 2018 10:46 pm


Return to Linux

Who is online

Users browsing this forum: No registered users and 4 guests