Extension AltSearch is broken

Writing a book, Automating Document Production - Discuss your special needs here

Extension AltSearch is broken

Postby franc » Sun May 06, 2018 8:25 pm

Hallo

I am on Mac OS 10.11.6 with a MacBook Pro mid 2009. I use OpenOffice 4.1.5 and have the Extension AltSearch 1.4.2 (from 3/2017) installed.
But this aint work correct, this is how the AltSearch Dialog looks like:

Bildschirmfoto 2018-05-03 um 08.56.23.png
Extension AltSearch is broken


All DropDown Boxes are empty, so I cannot use this extension.

I tried several times to re-install it, but no change.
Is there any log file where I could check what is wrong?

Thank

frank
OpenOffice 3.3
franc
 
Posts: 21
Joined: Sat Oct 08, 2011 2:12 pm

Re: Extension AltSearch is broken

Postby RoryOF » Sun May 06, 2018 8:55 pm

There are threads on the Forum about Mac installations of OO not having any visible characters. Perhaps one of these will be helpful in solving your problem.
Apache OpenOffice 4.1.6 on Xubuntu 18.04.2 (mostly 64 bit version) and very infrequently on Win2K/XP
User avatar
RoryOF
Moderator
 
Posts: 28738
Joined: Sat Jan 31, 2009 9:30 pm
Location: Ireland

Re: Extension AltSearch is broken

Postby franc » Fri Oct 19, 2018 9:12 am

Problem never solved, asked in german forum now:
http://www.oooforum.de/viewtopic.php?f=1&t=70797
OpenOffice 3.3
franc
 
Posts: 21
Joined: Sat Oct 08, 2011 2:12 pm

Re: Extension AltSearch is broken

Postby RoryOF » Fri Oct 19, 2018 9:39 am

AltSearch certainly works on Xubuntu 18.04.1 I think this is a Mac problem.
Apache OpenOffice 4.1.6 on Xubuntu 18.04.2 (mostly 64 bit version) and very infrequently on Win2K/XP
User avatar
RoryOF
Moderator
 
Posts: 28738
Joined: Sat Jan 31, 2009 9:30 pm
Location: Ireland

Re: Extension AltSearch is broken

Postby franc » Fri Oct 19, 2018 10:08 am

Maybe related that OO is very unstable on Mac and crashes often.
OpenOffice 3.3
franc
 
Posts: 21
Joined: Sat Oct 08, 2011 2:12 pm

Re: Extension AltSearch is broken

Postby Zizi64 » Fri Oct 19, 2018 10:15 am

Try the LibreOffice.
Tibor Kovacs, Hungary; LO4.4.7, LO6.1.5 on Win7-10 x64Prof.
PortableApps, winPenPack: LO3.3.0-6.2.2; AOO4.1.5
Please, edit the initial post in the topic: add the word [Solved] at the beginning of the subject line - if your problem has been solved.
User avatar
Zizi64
Volunteer
 
Posts: 7900
Joined: Wed May 26, 2010 7:55 am
Location: Budapest, Hungary

Re: Extension AltSearch is broken

Postby franc » Fri Oct 19, 2018 10:17 am

Is that more stable? Has it the Extension AltSearch working on Mac?
OpenOffice 3.3
franc
 
Posts: 21
Joined: Sat Oct 08, 2011 2:12 pm

Re: Extension AltSearch is broken

Postby Zizi64 » Fri Oct 19, 2018 10:26 am

I have not MAC, but my LibreOffice is very stable on Windows 7, and the AltSearch works fine.

Otherwise most of the extensions are "third party softwares", created by the users, or independent teams - and they are not related to te job of main developers of the office suites. You can ask the author of the extension.
Tibor Kovacs, Hungary; LO4.4.7, LO6.1.5 on Win7-10 x64Prof.
PortableApps, winPenPack: LO3.3.0-6.2.2; AOO4.1.5
Please, edit the initial post in the topic: add the word [Solved] at the beginning of the subject line - if your problem has been solved.
User avatar
Zizi64
Volunteer
 
Posts: 7900
Joined: Wed May 26, 2010 7:55 am
Location: Budapest, Hungary

Re: Extension AltSearch is broken

Postby franc » Fri Oct 19, 2018 10:30 am

Yes, I have running OpenOffice on PC, and this is stable and AltSearch is working.
But I am asking about MAC, not PC.
OpenOffice 3.3
franc
 
Posts: 21
Joined: Sat Oct 08, 2011 2:12 pm

Re: Extension AltSearch is broken

Postby John_Ha » Fri Oct 19, 2018 12:22 pm

Works fine on W7 for me.

Uninstall it. Download and re-install it.
AOO 4.1.6, Windows 7 Home 64 bit

See the Writer Manual, the Writer FAQ, the Writer Tutorials and the Writer guide.

Remember: Always save your Writer files as .odt files. - see here for the many reasons why.
John_Ha
Volunteer
 
Posts: 6592
Joined: Fri Sep 18, 2009 5:51 pm
Location: UK

Re: Extension AltSearch is broken

Postby franc » Fri Oct 19, 2018 12:53 pm

I have done that several times. But here I need the advice of a Mac-user and not from an only-PC user.
OpenOffice 3.3
franc
 
Posts: 21
Joined: Sat Oct 08, 2011 2:12 pm

Re: Extension AltSearch is broken

Postby RoryOF » Sat Oct 20, 2018 9:19 am

Try the methods suggested in this post
https://forum.openoffice.org/en/forum/viewtopic.php?f=17&t=95582#p456200

Your problem is almost certainly a Mac configuration problem.
Apache OpenOffice 4.1.6 on Xubuntu 18.04.2 (mostly 64 bit version) and very infrequently on Win2K/XP
User avatar
RoryOF
Moderator
 
Posts: 28738
Joined: Sat Jan 31, 2009 9:30 pm
Location: Ireland

Re: Extension AltSearch is broken

Postby franc » Tue Oct 30, 2018 2:25 pm

After deleting the Extension, then my profile (/Users/f/Library/Application Support/OpenOffice/4/user) and reinstall AltSearch, the problem is still the same. No dropdown content.
Not working AltSearch.
Nothing to do with the profile I guess.
OpenOffice 3.3
franc
 
Posts: 21
Joined: Sat Oct 08, 2011 2:12 pm

Re: Extension AltSearch is broken

Postby floris v » Wed Oct 31, 2018 12:34 am

Please read Rory's reply. I just downloaded the latest version of AltSearch and it displays the dropdown lists fine in Windows 10, in the Dutch interface. That means that all the data for those dropdown lists is in the extension. Therefore it must be something wrong on the Mac.
AOO 4.1.6 op Linux Mint
If your problem has been solved or your question has been answered, please edit the first post in this thread and add [Solved] to the title bar.
Nederlandstalig forum
User avatar
floris v
Moderator
 
Posts: 4041
Joined: Wed Nov 28, 2007 1:21 pm
Location: Netherlands

Re: Extension AltSearch is broken

Postby MrProgrammer » Wed Oct 31, 2018 4:19 am

franc wrote:I am on Mac OS 10.11.6 with a MacBook Pro mid 2009. I use OpenOffice 4.1.5 and have the Extension AltSearch 1.4.2 (from 3/2017) installed.
But this aint work correct, this is how the AltSearch Dialog looks like:
I don't use AltSearch but do run MacOS 10.11.6 on a 2009 machine. I suggest you read [Tutorial] Mac FAQ, especially Q15/A15, Q28/A28, Q32/A32, and Q39/A39. Since you are the one experiencing the symptoms, I recommend that you review all the FAQ.

franc wrote:Maybe related that OO is very unstable on Mac and crashes often.
Something is wrong with your system. OpenOffice has been very stable for me on MacOS for nine years and hardly ever crashes. I installed 4.1.5 in June and I don't think I've had any problems since then even though I use the software every single day. I do not run LibreOffice.
Mr. Programmer
AOO 4.1.5 Build 9789 on MacOS 10.11.6.   The locale for any menus or Calc formulas in my posts is English (USA).
User avatar
MrProgrammer
Volunteer
 
Posts: 3676
Joined: Fri Jun 04, 2010 7:57 pm
Location: Wisconsin, USA

Re: Extension AltSearch is broken

Postby pietvo » Thu Nov 22, 2018 4:34 pm

I have hacked AltSearch to get the list boxes working on MacOS. At least on LibreOffice, but as the problem looks the same as in the OP for OpenOffice, I guess my solution would work also on OO. See the screen shot below. Send me a PM if you want a copy.

AltSearch.png
OpenOffice 4.0.1 on MacOS X 10.10
pietvo
 
Posts: 3
Joined: Sun Mar 15, 2015 8:30 pm
Location: Utrecht


Return to Advanced Uses

Who is online

Users browsing this forum: No registered users and 0 guests