[Solved] After update spelling correction not working.

Writing a book, Automating Document Production - Discuss your special needs here

[Solved] After update spelling correction not working.

Postby Sea Skimmer » Sat Aug 04, 2018 7:28 pm

I have been using Open Office 4.1.3 for ages now and the little icon in the top right has been popping up bugging me to update and so today i did. Wish i hadn't bothered. Now the spell checker will not work no matter what i try. Uninstalled and re-installed. Removed user file and created new one. Been on the forums and tried a few different things which worked for other people but not me.

Now here's the strange thing. When i removed the user folder and created a new one the spell correction worked BUT only if I started typing on a fresh new page as it were. But if i copy and pasted my writing from a previous ODT file it does not recognise any spelling mistakes,see pick below.

Image

What the hell am i doing wrong here,apart from spelling mistakes :P
Last edited by RoryOF on Sun Aug 05, 2018 1:37 pm, edited 1 time in total.
Reason: Added [Solved] and green tick [RoryOF, Moderator]
Open Office version 4.1.5 on windows 10 OS
Sea Skimmer
 
Posts: 2
Joined: Sat Aug 04, 2018 7:13 pm

Re: After update spelling correction not working.

Postby RoryOF » Sat Aug 04, 2018 7:31 pm

That suggests that the language set in your older files differs from that set in your current version of OpenOffice. On your example page the language used is English (UK) - see middle of status bar . Perhaps in the newer version, English (US) (or similar) is set.
Apache OpenOffice 4.1.6 on Xubuntu 18.04.2 (mostly 64 bit version) and very infrequently on Win2K/XP
User avatar
RoryOF
Moderator
 
Posts: 28412
Joined: Sat Jan 31, 2009 9:30 pm
Location: Ireland

Re: After update spelling correction not working.

Postby Bill » Sun Aug 05, 2018 8:57 am

None of the misspelled words have been selected in the screen shot, so it's impossible to determine from the screen shot what the language setting is for those misspelled words. We only know that English (UK) is the setting for the point where the vertical bar appears below the text. Presumably, that vertical bar is in a new paragraph. In that case, the language setting for the misspelled words may or may not be English (UK), but I'd guess that it is not English (UK).
AOO 4.1.6 and LO 6.2.0.3 on Manjaro MATE
Bill
Volunteer
 
Posts: 7148
Joined: Sat Nov 24, 2007 6:48 am

Re: After update spelling correction not working.

Postby Sea Skimmer » Sun Aug 05, 2018 12:08 pm

Thank you RoryOF. I did not notice that when i copied the old ODT file to the newly installed version of open office it said in the status bar 'unknown' for the language even though the i had gone through and made sure everything was set to English UK. All i had to do was left click unknown and then click English UK and start typing for the spelling correction to work again.
Thanks for the info. :D
Open Office version 4.1.5 on windows 10 OS
Sea Skimmer
 
Posts: 2
Joined: Sat Aug 04, 2018 7:13 pm

Re: [Solved] After update spelling correction not working.

Postby Hagar Delest » Mon Aug 06, 2018 12:24 pm

That's a direct formatting. I think that you should check the styles used, see: [Troubleshooting] Spell check in OpenOffice.
AOO 4.1.6 on Xubuntu 18.10 and 4.1.5 on Windows 7 (with winPenPack port).
User avatar
Hagar Delest
Moderator
 
Posts: 28387
Joined: Sun Oct 07, 2007 9:07 pm
Location: France


Return to Advanced Uses

Who is online

Users browsing this forum: No registered users and 0 guests