[Solved] Starting OO without JRE

Issues with installing under all Linux Distributions

[Solved] Starting OO without JRE

Postby UnclePa » Wed May 09, 2018 3:41 pm

Like several others, I'm getting this message "javaldx: Could not find a Java Runtime Environment". According to http://www.openoffice.org/download/common/java.html, Java is optional but their instructions for turning it off require you to be in the program. Is there a way to start the program without it requiring a JRE? FWIW, I have both JDK and JRE installed and don't know why it isn't working. Scala, Kotlin, IntelliJ Idea, and Eclipse are all working fine.
Last edited by UnclePa on Thu May 10, 2018 4:48 pm, edited 1 time in total.
OpenOffice 4.1.5 on Artix Linux
UnclePa
 
Posts: 3
Joined: Wed May 09, 2018 3:24 pm

Re: Starting OO without JRE

Postby Zizi64 » Wed May 09, 2018 6:20 pm

I have both JDK and JRE installed and don't know why it isn't working. Scala, Kotlin, IntelliJ Idea, and Eclipse are all working fine.

The AOO is a 32 bit application. You must install a 32 bit JRE for it.
The LibreOffice has 32 and 64 bit versions too.
Tibor Kovacs, Hungary; LO6.1.6 on Win7-10 x64Prof.
PortableApps, winPenPack: LO3.3.0-6.3.2; AOO4.1.6
Please, edit the initial post in the topic: add the word [Solved] at the beginning of the subject line - if your problem has been solved.
User avatar
Zizi64
Volunteer
 
Posts: 8476
Joined: Wed May 26, 2010 7:55 am
Location: Budapest, Hungary

Re: Starting OO without JRE

Postby Hagar Delest » Wed May 09, 2018 6:28 pm

AOO 4.1.7 on Xubuntu 19.10 and 4.1.5 on Windows 10 (with winPenPack port).
User avatar
Hagar Delest
Moderator
 
Posts: 28592
Joined: Sun Oct 07, 2007 9:07 pm
Location: France

Re: Starting OO without JRE

Postby Bill » Wed May 09, 2018 7:00 pm

Did you install AOO 4.1.5 from the Arch User Repository? I have AOO 4.1.5 and jre8-openjdk on Manjaro and AOO starts with or without JRE.
AOO 4.1.6 and LO 6.2.0.3 on Manjaro MATE
Bill
Volunteer
 
Posts: 7392
Joined: Sat Nov 24, 2007 6:48 am

Re: Starting OO without JRE

Postby UnclePa » Thu May 10, 2018 12:32 am

Thanks for the replies everyone! Perhaps I'm mistaken, but my understanding of the page I linked to seems to be saying that JRE is not required. As best I can tell, I don't need any of the things that it is required for, so my immediate need is to start it without JRE. Surely JRE is not required to turn off JRE?

Zizi64 wrote:The AOO is a 32 bit application. You must install a 32 bit JRE for it.
The LibreOffice has 32 and 64 bit versions too.

I'm pretty sure this is not correct. Surely Apache_OpenOffice_4.1.5_Linux_x86_64_install-deb_en-US.tar.gz is not a 32 bit app.

Hagar Delest wrote:It may be similar to that one: [Solved] New AOO install will not load in Ubuntu 16.04.

It wasn't clear to me what the OP did to solve the problem. I thought it was that he had an old LO config file. Anyway, looking at the thread again, I get the same result after setting "enabled" to false in the .xml config file. It also seems kind of weird to edit a file that says "Do not alter this file!"

Bill wrote:... A...U...R

No. I have a very slow internet connection and it kept timing out on the download. So I used wget to get the file listed above and installed it using dpkg. This is the same procedure I used on my other laptop which is running Void Linux and I don't have any problems with it. Edit: How do you tell it to start without JRE?
OpenOffice 4.1.5 on Artix Linux
UnclePa
 
Posts: 3
Joined: Wed May 09, 2018 3:24 pm

Re: Starting OO without JRE

Postby Zizi64 » Thu May 10, 2018 6:44 am

Zizi64 wrote:
The AOO is a 32 bit application. You must install a 32 bit JRE for it.
The LibreOffice has 32 and 64 bit versions too.



I'm pretty sure this is not correct. Surely Apache_OpenOffice_4.1.5_Linux_x86_64_install-deb_en-US.tar.gz is not a 32 bit app.


Sorry. I missed your signature, and I always thinking "in Windows environment".

https://www.openoffice.org/download/common/java.html
Tibor Kovacs, Hungary; LO6.1.6 on Win7-10 x64Prof.
PortableApps, winPenPack: LO3.3.0-6.3.2; AOO4.1.6
Please, edit the initial post in the topic: add the word [Solved] at the beginning of the subject line - if your problem has been solved.
User avatar
Zizi64
Volunteer
 
Posts: 8476
Joined: Wed May 26, 2010 7:55 am
Location: Budapest, Hungary

Re: Starting OO without JRE

Postby Bill » Thu May 10, 2018 10:19 am

UnclePa wrote:...I used wget to get the file listed above and installed it using dpkg. This is the same procedure I used on my other laptop which is running Void Linux and I don't have any problems with it. Edit: How do you tell it to start without JRE?

I've never used dpkg on Manjaro and don't know if using dpkg to install the deb packages might be causing the problem. I found dpkg in the AUR, but the description says "Don't use it instead of Arch's 'pacman'". I did notice that the JRE on Manjaro is not installed in the same location as on Ubuntu MATE 18.04, so if you used dpkg to install the JRE, that might also be a factor.

Nothing special is required to start without JRE. The first time AOO is installed, the JRE is not enabled.
AOO 4.1.6 and LO 6.2.0.3 on Manjaro MATE
Bill
Volunteer
 
Posts: 7392
Joined: Sat Nov 24, 2007 6:48 am

Re: Starting OO without JRE

Postby RoryOF » Thu May 10, 2018 10:35 am

It may be that there is some cross-talk from traces of a distro LibreOffice installation. I have no need to run LO in parallel with OO so always purge libreoffice* before installing OO (running on Xubuntu); however, I have Java running on my standard machine so cannot say if my usual OO installation process relies on that (that process uses dpkg).

I am currently running openjdk 1.8.0_162 (64 bit)

As a workaround I'd suggest installing Java, then installing OO, and subsequently removing Java if that is what you desire.
Apache OpenOffice 4.1.7 on Xubuntu 18.04.3 (mostly 64 bit version) and very infrequently on Win2K/XP
User avatar
RoryOF
Moderator
 
Posts: 29767
Joined: Sat Jan 31, 2009 9:30 pm
Location: Ireland

Re: Starting OO without JRE

Postby UnclePa » Thu May 10, 2018 4:47 pm

Bill wrote:Nothing special is required to start without JRE. The first time AOO is installed, the JRE is not enabled.

Hmm, then why am I getting the error about Java? Anyway, I just wanted a quick look at a spreadsheet file (and there are other ways to do that) and even if a solution to this problem is found, that goal has failed. I'll remove OO and next time I have a decent Internet connection install OO or LO with yaourt or pacman.

Thanks again, everyone. Seems a bit misleading to mark this "Solved" but a reinstall using a different method might solve it.

@RoryOF: It is OO that is optional, not Java. The list I gave of working apps (all of which require and are working with Java) is almost everything I have installed on this box. There shouldn't be any LO remnants as it's never been installed. As I mentioned in my last post, if Java is optional, I don't want to spend any time trying to get OO working with Java.
OpenOffice 4.1.5 on Artix Linux
UnclePa
 
Posts: 3
Joined: Wed May 09, 2018 3:24 pm


Return to Linux

Who is online

Users browsing this forum: No registered users and 1 guest