Trying to run a query crashes Base program

Discuss the database features

Trying to run a query crashes Base program

Postby mrfixit » Sun Dec 10, 2017 8:11 pm

Running OpenOffice 4.1.3 in macOS 10.13.1

When I try to create a Query in BASE with Wizard it will not save when I hit Finish.
When I do create it in Design it does save BUT it crashes the program the instant I try to run it.
When I hit recover the program recovers well BUT WITHOUT the Query listed.

IS THERE A COMPATIBILITY ISSUE BETWEEN OFFICE 4.1.3 AND macOS 10.13.1?
OpenOffice 4.1.3 macOS 10.13.1
mrfixit
 
Posts: 1
Joined: Sun Dec 10, 2017 7:35 pm

Re: Trying to run a query crashes Base program

Postby eremmel » Mon Dec 11, 2017 10:15 am

Hard to say. If your base document does not contain confidential info (or you can remove it), please upload it so that other can test it as well. You can post your query in the document or separated in this thread.
Is your question answered: edit your initial post add "[Solved]" to the subject and check V
LO4.2.8 for work with ORB; AOO4.1.4,LO5.2.5/6.0.5 on W7E SP1 64bit
It's Microsoft marketing that tells you computers are qualified for non-technicians
User avatar
eremmel
Volunteer
 
Posts: 1033
Joined: Tue Dec 30, 2008 1:15 am
Location: Barneveld, Netherlands

Re: Trying to run a query crashes Base program

Postby luisEA » Tue Dec 12, 2017 12:24 pm

I'm having the same problem with my mac (10.11.5), my openoffice version is the 4.1.4 and when i try to run the query
Code: Select all   Expand viewCollapse view
SELECT "Type", "Name" FROM "features" GROUP BY "features"."Type"
the openoffice crashes....

Just by removing the Group by the query works.. so not sure why is that happening... The table features has 3 fields, ID, type and name....
MAC El Capitan - 10.11.5 - OpenOffice 4.1.4
luisEA
 
Posts: 5
Joined: Tue Dec 12, 2017 12:16 pm

Re: Trying to run a query crashes Base program

Postby eremmel » Wed Dec 13, 2017 12:19 pm

Your query is wrong. You GROUP BY on "Type", but did not apply a aggregate on "Name". When you e.g. replace "Name" by COUNT(*) AS "Occurrences" your query is OK and should work.

So it looks like there is a stability issue when you have an erroneously query with a GROUP BY.

You might test more queries with errors: E.g use non-existing column name or table name and see it that brings Base down as well.
Is your question answered: edit your initial post add "[Solved]" to the subject and check V
LO4.2.8 for work with ORB; AOO4.1.4,LO5.2.5/6.0.5 on W7E SP1 64bit
It's Microsoft marketing that tells you computers are qualified for non-technicians
User avatar
eremmel
Volunteer
 
Posts: 1033
Joined: Tue Dec 30, 2008 1:15 am
Location: Barneveld, Netherlands

Re: Trying to run a query crashes Base program

Postby Komalpriya » Wed Jan 02, 2019 9:50 am

I'm having the same problem with my macOS 10.12.2
Every time I try to run the query the programme crashes and then I have to recover the programme with query not listed their!.. pls reply as soon you can
OpenOffice 4.1.6 AOO416m1(Build:9790)
MacOS Sierra version 10.12.2
Komalpriya
 
Posts: 1
Joined: Wed Jan 02, 2019 9:43 am

Re: Trying to run a query crashes Base program

Postby Villeroy » Wed Jan 02, 2019 7:40 pm

Replace OpenOffice with https://libreoffice.org/download
Please, edit this topic's initial post and add "[Solved]" to the subject line if your problem has been solved.
Ubuntu 18.04, OpenOffice 4.x & LibreOffice 6.x
User avatar
Villeroy
Volunteer
 
Posts: 26635
Joined: Mon Oct 08, 2007 1:35 am
Location: Germany


Return to Base

Who is online

Users browsing this forum: No registered users and 4 guests