[Solved] Language switches by itself

Writing a book, Automating Document Production - Discuss your special needs here

[Solved] Language switches by itself

Postby Dmitri » Thu Nov 30, 2017 12:26 am

Hello everyone,

I tried my best to search this forum and it seems no-one encountered this problem before, which is a little bit surprising. However, this is how it is.

As an interpreter, I often switch between two scripts, Latin and Cyrillic; as I normally write in standard British English, I want my default setting be English (UK). And so it is, when I open a new ODT document. When I start typing in a new document, I can switch to Cyrillic and then, when I change the keyboard back to English, it's not English (UK) anymore, it's English (USA). And there's nothing I can do about it. Each time I go back to the default language settings menu, there is English (UK) - with the box "for the current document only" ticked. I remove the tick each time, and each time it is back.

The things are worse if I open an MS Word document in Apache - it's never English (UK), however hard I try. First it has [None] at the bottom, and if I change it to English (UK) it will switch to English (USA) without asking me. The same happens if I have a Word document open in Apache and then a new document, either a Word or ODT - it will not stay English (UK) for long.

Will be terribly grateful for any suggestions.
Last edited by Dmitri on Thu Nov 30, 2017 1:53 pm, edited 1 time in total.
OpenOffice 4.1.3 on Windows 10
Dmitri
 
Posts: 7
Joined: Thu Nov 30, 2017 12:10 am

Re: Language switches by itself

Postby RusselB » Thu Nov 30, 2017 1:41 am

First off, Welcome to the Forums.
As to your problem, the first thing I would suggest that you consider is your actual location.
This is used by Windows to generate your Locale settings. In general, if you are in the US, Windows will generate a US locale and use that information by default.
I'm going to suggest that you check the settings at Tools -> Options -> Language settings.
OpenOffice 4.1.7 and LibreOffice 6.0.6.2 on Windows 7 Pro & Ultimate
If you believe your problem has been resolved, please go to your first post in this topic, click the Edit button and add [Solved] to the beginning of the Subject line.
User avatar
RusselB
Moderator
 
Posts: 5488
Joined: Fri Jan 03, 2014 7:31 am
Location: Sarnia, ON

Re: Language switches by itself

Postby Dmitri » Thu Nov 30, 2017 1:51 am

Thanks, RusselB.
Following your advice, changed the Locale to English (UK). It didn't help. :(
OpenOffice 4.1.3 on Windows 10
Dmitri
 
Posts: 7
Joined: Thu Nov 30, 2017 12:10 am

Re: Language switches by itself

Postby Villeroy » Thu Nov 30, 2017 2:59 am

1) The user interface language (1st language setting) is for the GUI and the help files.

2) The locale setting (2nd language) is for numbers only. By default it uses the same locale as the operating system. The locale controls the date formats, the names of months and weekdays and if 1.234 is interpreted as one thousand two hundred and thirty four or one point two three four. OpenOffice Writer, Calc and Base support hundreds of different numeric systems. This locale setting is the one that is used by default in all kinds of table cells, fields and form controls.
The "decimal separator key" refers to the decimal key the number keypad only. The decimal key should always(?) type the decimal separator (comma or point) according to the locale setting.

3) The language options are for human language (words). This part of the GUI is designed very badly because the checkbox labeled "current document only" does not turn a specific setting on and off. This checkbox switches between two rather different things:
3a) If "current document only" is OFF and you start a blank new document that is not derived from any prepared template, the new, blank document starts with the specified language in all paragraph styles and character styles. This does not affect any existing document nor template.
3b) If "current document only" is ON and you confirm the dialog with [OK], the current document's paragtraph styles and character styles are changed together with all hard formattings. This does not affect new documents.
Please, edit this topic's initial post and add "[Solved]" to the subject line if your problem has been solved.
Ubuntu 18.04, no OpenOffice, LibreOffice 6.x
User avatar
Villeroy
Volunteer
 
Posts: 27207
Joined: Mon Oct 08, 2007 1:35 am
Location: Germany

Re: Language switches by itself

Postby Bill » Thu Nov 30, 2017 5:10 am

Dmitri wrote:... when I change the keyboard back to English, it's not English (UK) anymore, it's English (USA). And there's nothing I can do about it.

Press Windows Key + Spacebar to display the Windows 10 language options. If you see English (USA) and not English (UK), then you need to install the English (UK) language pack and set it as the default language in Windows 10. When you want to switch to English (UK), you have to select the English (UK) language, not an "English" keyboard. The default keyboard layout for English (USA) is US Keyboard and the default keyboard layout for English (UK) is United Kingdom Keyboard.
AOO 4.1.6 and LO 6.2.0.3 on Manjaro MATE
Bill
Volunteer
 
Posts: 7372
Joined: Sat Nov 24, 2007 6:48 am

Re: Language switches by itself

Postby John_Ha » Thu Nov 30, 2017 1:20 pm

All text in Writer carries a flag which specifies which language the text is and which dictionary should be used to spell check it. You can set the language for text yourself if you have that language dictionary. If you copy text and paste it to Writer it brings its language tag with it.
 Edit: See later post about setting language with Format > Character > Font ... 


Clipboard01.png
Clipboard01.png (4.77 KiB) Viewed 5094 times

Read Chapter 2 and Chapter 3 in the Writer Manual for a detailed explanation.

As a new poster you will find much useful information in the Writer FAQ, the Writer Tutorials, the up to date Writer guide and the Writer Manual. When a pop-up window opens, click the Help button for extensive help on that function - it is often more comprehensive than the manual.

Search the forum with language - there are many posts about it. See [Tutorial] Spell check and Language configuration

Search Help with language for more information.

If your problem is solved, please view your first post in this thread and click the Edit button (top right in the post) and add [Solved] in front of the subject.
Last edited by John_Ha on Thu Nov 30, 2017 3:06 pm, edited 1 time in total.
AOO 4.1.6, Windows 7 Home 64 bit

See the Writer Guide, the Writer FAQ, the Writer Tutorials and Writer for students.

Remember: Always save your Writer files as .odt files. - see here for the many reasons why.
John_Ha
Volunteer
 
Posts: 6800
Joined: Fri Sep 18, 2009 5:51 pm
Location: UK

Re: Language switches by itself

Postby Dmitri » Thu Nov 30, 2017 1:50 pm

Bill wrote:Press Windows Key + Spacebar to display the Windows 10 language options. If you see English (USA) and not English (UK), then you need to install the English (UK) language pack and set it as the default language in Windows 10. When you want to switch to English (UK), you have to select the English (UK) language, not an "English" keyboard. The default keyboard layout for English (USA) is US Keyboard and the default keyboard layout for English (UK) is United Kingdom Keyboard.


Thanks Bill! I set my default Windows language as English UK and it worked! Thank you!

I thank everyone who sent their replies and tried to be helpful.

...However, I'm not quite completely satisfied. The MS Word will follow your orders without looking over the shoulder to the Windows default settings. If you set the document language you need, it will be the document language and no second thoughts. What I feel kind of annoyed about is that the Apache OpenOffice seems to have a similar feature which doesn't seem to work. I work inside the text programme, I want the setting of the text programme be as I want them to be, not what the programme thinks should be my choice. See my point?
OpenOffice 4.1.3 on Windows 10
Dmitri
 
Posts: 7
Joined: Thu Nov 30, 2017 12:10 am

Re: [Solved]Language switches by itself

Postby jrkrideau » Thu Nov 30, 2017 2:59 pm

I may be missing the issue but why not have either two templates one Cyrillic and one Latin or else if you are mixing Cyrillic and Latin texts in the same document ?
OpenOffice 4.1.6; Ubuntu 18.04
jrkrideau
Volunteer
 
Posts: 3696
Joined: Sun Dec 30, 2007 10:00 pm
Location: Kingston Ontario Canada

Re: [Solved]Language switches by itself

Postby John_Ha » Thu Nov 30, 2017 3:02 pm

Dmitri wrote:The things are worse if I open an MS Word document in Apache - it's never English (UK)

Correct. The text is flagged as being in US English in the file irrespective of what application you use to open it - it will be US English in AOO and in Word.

If you highlight some text, Format > Character > Font ..., tells you which language it is and allows you to set it to another language (as does Tools > Language > For selection ...)

Clipboard01.png

NB See [Tutorial] Differences between Writer and MS Word files for why you should always work in and save files as .odt.
AOO 4.1.6, Windows 7 Home 64 bit

See the Writer Guide, the Writer FAQ, the Writer Tutorials and Writer for students.

Remember: Always save your Writer files as .odt files. - see here for the many reasons why.
John_Ha
Volunteer
 
Posts: 6800
Joined: Fri Sep 18, 2009 5:51 pm
Location: UK

Re: [Solved]Language switches by itself

Postby Dmitri » Thu Nov 30, 2017 9:31 pm

John_Ha, the problem is the Windows setting. I tried to switch the language both ways, through the Format and the Tools menu; no matter what I do it will switch back to the default Windows language. At the moment it is English (UK) and it helps a little, but, as I'm explaining above, it's not quite the thing, as I might want to type a text in American spelling, or in Polish or German - and it will /switch anyway as the Windows commands. I don't quite like it, that AOO dictates what language should there be in the text. AOO seems quite ok with the customised language settings until I switch languages, accidentally as may be.

jrkrideau, I can type Cyrillic in an English document, template or no template, quite accidentally, and then this starts.

I still think this is some AOO bug that might not have been considered a bug until now. I'm a bit surprised that I'm the first one to speak about it here.
OpenOffice 4.1.3 on Windows 10
Dmitri
 
Posts: 7
Joined: Thu Nov 30, 2017 12:10 am

Re: [Solved]Language switches by itself

Postby jrkrideau » Fri Dec 01, 2017 8:00 pm

jrkrideau, I can type Cyrillic in an English document, template or no template, quite accidentally, and then this starts.


Very strange indeed. It may be a bug but I am inclined to either blame Windows (of course) or wonder if it is something specific to your set-up.

Is this only when you switch alphabets, that is, where you describing switching from German > Cyrillic > English or German > English. I am not sure how to read your description of language switching.

I have, very, very occasionally, changed languages from Canadian English to Russian and back to Canadian English and quite often switched from Canadian English to Canadian French and back with no problem but I am running Linux.
OpenOffice 4.1.6; Ubuntu 18.04
jrkrideau
Volunteer
 
Posts: 3696
Joined: Sun Dec 30, 2007 10:00 pm
Location: Kingston Ontario Canada

Re: [Solved]Language switches by itself

Postby Dmitri » Fri Dec 01, 2017 10:46 pm

jrkrideau, thank you for your reply.

Unfortunately, I don't remember how it was when I used Ubuntu - I had to skip it because it was terribly slow on the computer I had then. At the moment I'm using Windows only because my job requires it; I've got to have MS Office with all its newest features.

As far as I remember, each time I ran AOO on Windows (and I have been doing it for about 10 years now) I encountered this problem: switching the keyboard from Russian to English made the language of the document as it was (I understand it now) in the Windows setting, not as I wanted it to be in the OO settings. So, just to make it absolutely clear: supposing I opened a new document in OO with the English (UK) as the default language in the OO; and it shows English (UK) at the bottom. I start typing (and it keeps being English (UK) all the time), then I may need to type a bit in Russian - and when I switch back to Latin the language of the document becomes English (USA) however hard I try to persuade it to be reasonable. Switching back to Latin in OO on Windows means switching to the Windows default language. I already have experimented: at the moment it is English (UK) on my Windows, and OO will switch to English (UK) even if I want it to be some other. Hope that clarifies the situation.
OpenOffice 4.1.3 on Windows 10
Dmitri
 
Posts: 7
Joined: Thu Nov 30, 2017 12:10 am

Re: [Solved] Language switches by itself

Postby jrkrideau » Sat Dec 02, 2017 8:30 pm

That makes it very clear. It is what I thought but I was not sure.

How are you changing languages? I always set up character and paragraph Styles for each language that I am using.

I don't remember if I ever used Russian with OpenOffice back in the bad old days when I was running Windows but I commonly switched from English to French to English with no problem.

You might want to have a look at LibreOffice.
OpenOffice 4.1.6; Ubuntu 18.04
jrkrideau
Volunteer
 
Posts: 3696
Joined: Sun Dec 30, 2007 10:00 pm
Location: Kingston Ontario Canada

Re: [Solved] Language switches by itself

Postby Dmitri » Sun Dec 03, 2017 8:22 am

jrkrideau, I think you're right. Perhaps how I switch lettering is the reason why. You see, in Windows you've got to switch the Windows-run keyboard; it won't help if you just switch Character Styles in the OO menu. I guess this is it that plays the dirty trick.

Thanks for pointing at LibreOffice; I need to try that one.
OpenOffice 4.1.3 on Windows 10
Dmitri
 
Posts: 7
Joined: Thu Nov 30, 2017 12:10 am

Re: [Solved] Language switches by itself

Postby Bill » Sun Dec 03, 2017 12:25 pm

Dmitri wrote:jrkrideau, I think you're right. Perhaps how I switch lettering is the reason why. You see, in Windows you've got to switch the Windows-run keyboard; it won't help if you just switch Character Styles in the OO menu. I guess this is it that plays the dirty trick.

Thanks for pointing at LibreOffice; I need to try that one.

When you change the input language setting on the Windows Taskbar, you're actually switching the language/keyboard combo, not just the keyboard. You can set up any keyboard for use with any language. I suspect that you were selecting an English (US)/UK keyboard combo instead of an English (UK)/UK keyboard combo when the language was "switching by itself". I set up English (US), English (UK) and Russian in Windows 10 and tried to duplicate the problem. The only time when the language switched to English (US) after typing Russian was when I selected an English (US) combo instead of an English (UK) combo.
AOO 4.1.6 and LO 6.2.0.3 on Manjaro MATE
Bill
Volunteer
 
Posts: 7372
Joined: Sat Nov 24, 2007 6:48 am

Re: [Solved] Language switches by itself

Postby jrkrideau » Sun Dec 03, 2017 12:27 pm

Dmitri wrote:jrkrideau, I think you're right. Perhaps how I switch lettering is the reason why. You see, in Windows you've got to switch the Windows-run keyboard; it won't help if you just switch Character Styles in the OO menu. I guess this is it that plays the dirty trick.

Thanks for pointing at LibreOffice; I need to try that one.


One needs to change keyboards in Linux as well though it is just an option on the toolbar. I just checked ano currently I have four keyboard layouts installed but changing keyboards has no effect on language. I can type using a Russian keyboard layout but, in my case, LO still treats the text as Canadian English until I change the Style.
OpenOffice 4.1.6; Ubuntu 18.04
jrkrideau
Volunteer
 
Posts: 3696
Joined: Sun Dec 30, 2007 10:00 pm
Location: Kingston Ontario Canada

Re: [Solved] Language switches by itself

Postby Bill » Sun Dec 03, 2017 3:14 pm

jrkrideau wrote:One needs to change keyboards in Linux as well though it is just an option on the toolbar. I just checked ano currently I have four keyboard layouts installed but changing keyboards has no effect on language. I can type using a Russian keyboard layout but, in my case, LO still treats the text as Canadian English until I change the Style.

Windows is different. There isn't a keyboard layout setting in Windows like there is in Linux. Instead, Windows has an input language setting which Linux doesn't have. Each input language has a default keyboard layout associated with it and the user can add more keyboard layouts for each input language. To change the language, the user selects an option that includes both the language and the keyboard layout. There is no independent keyboard layout option that doesn't include a language.
AOO 4.1.6 and LO 6.2.0.3 on Manjaro MATE
Bill
Volunteer
 
Posts: 7372
Joined: Sat Nov 24, 2007 6:48 am

Re: [Solved] Language switches by itself

Postby jrkrideau » Sun Dec 03, 2017 5:07 pm

I knew there were reasons I moved to Linux.
OpenOffice 4.1.6; Ubuntu 18.04
jrkrideau
Volunteer
 
Posts: 3696
Joined: Sun Dec 30, 2007 10:00 pm
Location: Kingston Ontario Canada

Re: [Solved] Language switches by itself

Postby Dmitri » Sun Dec 03, 2017 6:02 pm

Bill wrote:
jrkrideau wrote:One needs to change keyboards in Linux as well though it is just an option on the toolbar. I just checked ano currently I have four keyboard layouts installed but changing keyboards has no effect on language. I can type using a Russian keyboard layout but, in my case, LO still treats the text as Canadian English until I change the Style.

Windows is different. There isn't a keyboard layout setting in Windows like there is in Linux. Instead, Windows has an input language setting which Linux doesn't have. Each input language has a default keyboard layout associated with it and the user can add more keyboard layouts for each input language. To change the language, the user selects an option that includes both the language and the keyboard layout. There is no independent keyboard layout option that doesn't include a language.


Yes Bill, that's what I meant.
OpenOffice 4.1.3 on Windows 10
Dmitri
 
Posts: 7
Joined: Thu Nov 30, 2017 12:10 am


Return to Advanced Uses

Who is online

Users browsing this forum: No registered users and 2 guests