PDF Importer requires OO reference version 4

Discussions about using 3rd party extension with OpenOffice.org

PDF Importer requires OO reference version 4

Postby jhogarth » Wed Jun 10, 2015 3:56 pm

I'm trying to install the OO PDF Import utility and get this error from the Extension Manager:

Extension requires at least OpenOffice.org reference version 4.0

I'm running OO 4.1.1 on CentOS 7, 64-bit.

The extension was downloaded from here: http://extensions.openoffice.org/en/pro ... openoffice

Is the extension not ready for 4.1?

Thanks
Jim
OpenOffice 4.1.1 on CentOS 7
jhogarth
 
Posts: 2
Joined: Wed Jun 10, 2015 3:43 pm

Re: PDF Importer requires OO reference version 4

Postby RoryOF » Wed Jun 10, 2015 4:49 pm

Apache OpenOffice 4.1.7 on Xubuntu 18.04.3 (mostly 64 bit version) and very infrequently on Win2K/XP
User avatar
RoryOF
Moderator
 
Posts: 29605
Joined: Sat Jan 31, 2009 9:30 pm
Location: Ireland

Re: PDF Importer requires OO reference version 4

Postby jhogarth » Wed Jun 10, 2015 6:58 pm

I get the same error message with this version.

Thanks
Jim
OpenOffice 4.1.1 on CentOS 7
jhogarth
 
Posts: 2
Joined: Wed Jun 10, 2015 3:43 pm

Re: PDF Importer requires OO reference version 4

Postby RusselB » Thu Jun 11, 2015 5:13 am

If you look and read the information given, it is stated that the extension is compatible with 4.0
User voting regarding compatibility with other 4.x versions is almost 2:1 indicating it is not compatible.
Additionally, since the last post was almost 2 years ago, I wouldn't hold my breath that a 4.1+ compatible version will be coming out.
OpenOffice 4.1.7 and LibreOffice 6.0.6.2 on Windows 7 Pro & Ultimate
If you believe your problem has been resolved, please go to your first post in this topic, click the Edit button and add [Solved] to the beginning of the Subject line.
User avatar
RusselB
Moderator
 
Posts: 5521
Joined: Fri Jan 03, 2014 7:31 am
Location: Sarnia, ON

Re: PDF Importer requires OO reference version 4

Postby B Marcelly » Thu Jun 11, 2015 9:01 am

Reading AOO 4.1 Release Notes, section Known Issues I notice this:
For the MacOSX version only, any extensions that are written in C++ will no longer work and be marked as disabled in the AOO extensions manager. This is because of the change of AOO from a 32-bit to a 64-bit application on MacOSX. Please report the problem to the developer of the extension.

Since you are using CentOS 7, 64-bit, this may be an explanation.
Bernard

OpenOffice.org 1.1.5 / Apache OpenOffice 4.1.1 / LibreOffice 5.0.5
MS-Windows 7 Home SP1
B Marcelly
Volunteer
 
Posts: 1160
Joined: Mon Oct 08, 2007 1:26 am
Location: France, Paris area

Re: PDF Importer requires OO reference version 4

Postby Zizi64 » Thu Jun 11, 2015 9:20 am

Or you can try the LibreOffice. It have PDF import feature as a built-in function.
Tibor Kovacs, Hungary; LO6.1.6 on Win7-10 x64Prof.
PortableApps, winPenPack: LO3.3.0-6.2.8; AOO4.1.6
Please, edit the initial post in the topic: add the word [Solved] at the beginning of the subject line - if your problem has been solved.
User avatar
Zizi64
Volunteer
 
Posts: 8377
Joined: Wed May 26, 2010 7:55 am
Location: Budapest, Hungary

Re: PDF Importer requires OO reference version 4

Postby DamVan » Sun Jun 21, 2015 9:17 am

i get the same question! thanks you! :D
OpenOffice 2.4 on Ubuntu 9.04
User avatar
DamVan
Banned
 
Posts: 1
Joined: Sun Jun 21, 2015 9:12 am

Re: PDF Importer requires OO reference version 4

Postby Zizi64 » Sun Jun 21, 2015 7:05 pm

DamVan:
OpenOffice 2.4 on Ubuntu 9.04


Do you use the OpenOffice.org 2.4, really???? It is a very, very old version.
Please upgrade your software and/or update your signature in this Forum.
Tibor Kovacs, Hungary; LO6.1.6 on Win7-10 x64Prof.
PortableApps, winPenPack: LO3.3.0-6.2.8; AOO4.1.6
Please, edit the initial post in the topic: add the word [Solved] at the beginning of the subject line - if your problem has been solved.
User avatar
Zizi64
Volunteer
 
Posts: 8377
Joined: Wed May 26, 2010 7:55 am
Location: Budapest, Hungary

Re: PDF Importer requires OO reference version 4

Postby RoryOF » Sun Jun 21, 2015 7:17 pm

DamVan wrote:i get the same question! thanks you! :D


Ubuntu 9.04 is an extremely old version and long out of support. The OO PDFImporter certainly works on OO 4.1.1 on Xubuntu 14.10 and 15.04; I am certain that it (or the earlier version) worked correctly on older versions of Xubuntu, but I cannot recollect with certainty just which version of PDFImporter worked on which earlier version of Xubuntu.

PDFImporter is not designed to permit editing to the level of reconstruction/re-layout of a PDF file using OpenOffice; it is capable of minor changes. Major changes to the structure of a PDF file require a specialised editor.
Apache OpenOffice 4.1.7 on Xubuntu 18.04.3 (mostly 64 bit version) and very infrequently on Win2K/XP
User avatar
RoryOF
Moderator
 
Posts: 29605
Joined: Sat Jan 31, 2009 9:30 pm
Location: Ireland

Re: PDF Importer requires OO reference version 4

Postby sergey113 » Thu Sep 17, 2015 10:38 pm

2015-09-17 - ubuntu 14.04 - openoffice 4.1.1 - PDF Import for Apache OpenOffice
install and works
openoffice 4.1.1 - ubuntu 14.04 - dell 1220
sergey113
 
Posts: 14
Joined: Wed May 13, 2015 12:03 am


Return to Extensions

Who is online

Users browsing this forum: No registered users and 0 guests