Problem with some operators aligning to the left

Discuss the formula editor

Problem with some operators aligning to the left

Postby andrenicolaysen » Thu Aug 14, 2014 4:19 pm

Hi. I've got this weird problem where some operators align to the left.'

If i write x-y it will display as x- y, and if I write x cdot y, the cdot is almost invisible because it it's so close to the x.

x times y and x + y works perfectly.

I've tried to reinstall and using ( ) and { }.

Can someone help me?
Openoffice 4.10 on Windows 8.1
andrenicolaysen
 
Posts: 3
Joined: Thu Aug 14, 2014 4:14 pm

Re: Problem with some operators aligning to the left

Postby acknak » Thu Aug 14, 2014 5:35 pm

Greetings and welcome to the community forum!

That is strange. My first thought is a font problem of some kind--maybe your OpenSymbol font is not installed or has a problem? I think OO Math expects OpenSymbol to be available.

Other than that, you might check the settings under Format > Alignment/Spacing

If none of that leads anywhere, it might be helpful if you could attach a sample document that shows the problem, so we could do some testing.
AOO4/LO5 • Linux • Fedora 23
User avatar
acknak
Moderator
 
Posts: 22756
Joined: Mon Oct 08, 2007 1:25 am
Location: USA:NJ:E3

Re: Problem with some operators aligning to the left

Postby andrenicolaysen » Thu Aug 14, 2014 5:57 pm

I tried restoring my fonts, didn't work. I found the opensymbol font and it seems like it's installed, don't know if it's broken though. I tried restoring back to default fonts, but that didn't work. I also made a new user, but that wasn't the problem either. Changing formating settings also didn't work.

In the zip file attached there's one .odt file and one .png file to show the problem.
Attachments
help.zip
(5.1 KiB) Downloaded 301 times
Openoffice 4.10 on Windows 8.1
andrenicolaysen
 
Posts: 3
Joined: Thu Aug 14, 2014 4:14 pm

Re: Problem with some operators aligning to the left

Postby acknak » Thu Aug 14, 2014 6:06 pm

I'm still thinking it's a font problem of some kind.

Your .odf file displays properly for me, so I don't think it's a settings problem. But the operator symbols in your screen capture are not only misaligned, they also look slightly different--at least the plus and minus do.

Could you attach an export to pdf? That might tell us exactly which fonts are being used.

Sometimes people report that rebooting somehow cleared up a font issue--maybe worth a try if you haven't already.
AOO4/LO5 • Linux • Fedora 23
User avatar
acknak
Moderator
 
Posts: 22756
Joined: Mon Oct 08, 2007 1:25 am
Location: USA:NJ:E3

Re: Problem with some operators aligning to the left

Postby andrenicolaysen » Thu Aug 14, 2014 6:14 pm

Ok, so I exported to pdf and in the pdf the operators are aligned properly!

I'll be exporting everything to pdf so the problem is kind of solved.

Thank you for the help! I don't know that the real issue is, but it doesn't matter any more.
Thank you for responding so fast and thank you for welcoming me!
Attachments
test.pdf
(25.43 KiB) Downloaded 308 times
Openoffice 4.10 on Windows 8.1
andrenicolaysen
 
Posts: 3
Joined: Thu Aug 14, 2014 4:14 pm

Re: Problem with some operators aligning to the left

Postby acknak » Thu Aug 14, 2014 9:11 pm

Opening the pdf with OO Draw (using the pdf import extension) shows that all the formulas are using Times New Roman and Open Symbol, so that looks ok.

The spacing in your pdf still looks slightly off but better than shown in the screen capture.

Sorry, not sure what's going on ....
AOO4/LO5 • Linux • Fedora 23
User avatar
acknak
Moderator
 
Posts: 22756
Joined: Mon Oct 08, 2007 1:25 am
Location: USA:NJ:E3

Re: Problem with some operators aligning to the left

Postby martin_g » Mon Sep 14, 2015 10:59 pm

I'm almost sure that this is the same problem as described (and solved) here: https://forum.openoffice.org/en/forum/viewtopic.php?f=12&t=67772#p360385
OpenOffice 4.1 on Windows 8
User avatar
martin_g
 
Posts: 28
Joined: Tue Oct 21, 2014 8:48 pm
Location: Germany


Return to Math

Who is online

Users browsing this forum: No registered users and 0 guests