[Solved] Saved documents are only in machine language

Issues with installing under all versions of MS Windows

[Solved] Saved documents are only in machine language

Postby 75FXE » Fri Oct 12, 2012 3:53 am

When I retrieve a document I have saved, it comes up only in machine language. How do I restore it to readable text? Only save as option offered is .txt. OO v 3.4.1 Win 7 o/s
Last edited by Hagar Delest on Wed Oct 24, 2012 11:51 am, edited 2 times in total.
Reason: Mark thread [Solved] and add green checkmark (thomasjk), tweaked title (Hagar)
Open Office 3.4.1 on Windows 7
75FXE
 
Posts: 24
Joined: Wed Aug 29, 2012 5:00 am

Re: Saved documents are only in machine language, not text

Postby RoryOF » Fri Oct 12, 2012 6:59 am

As a first step towards solving this problem you should delete or rename your User profile
Tutorial: the User Profile
as it can sometimes happen that an installation of OpenOffice generates a faulty initial User Profile. Restarting OpenOffice then generates a new, hopefully (usually) correct profile..

if that does not work, look at the file sizes, as set out in my posting
http://forum.openoffice.org/en/forum/viewtopic.php?f=15&t=56719&p=249639
to be sure you are trying to open the correct file, not a lock file.

Copy a faulty file, rename the copy to type .zip (not always necessary - depends on the archive manager) and attempt to open it with an archive manager such as winzip or 7zip. If it doesn't open then the file is corrupted; if it opens then we have to look further for your problem. If it opens under protest you may have unformatted content in content.xml

 Edit: There is a similar problem in this thread
http://en.libreofficeforum.org/node/4521
which may offer a solution but not a reason. 
Apache OpenOffice 4.1.8 on Xubuntu 20.04.1 (mostly 64 bit version) and very infrequently on Win2K/XP
User avatar
RoryOF
Moderator
 
Posts: 31722
Joined: Sat Jan 31, 2009 9:30 pm
Location: Ireland

Re: Saved documents are only in machine language, not text

Postby kingfisher » Fri Oct 12, 2012 7:00 am

Is this the same as the previous thread where documents were transferred to an external hard drive so that the computer hard drive could be reformatted?

Is there a document which you would feel comfortable to attach to a post in this thread? Failing that, can you provide a file name or, at least, the file name extensions?

EDIT: Written while Rory was posting.
Apache OpenOffice 4.1.6 on PCLinuxOS
User avatar
kingfisher
Volunteer
 
Posts: 2120
Joined: Tue Nov 20, 2007 10:53 am

Re: Saved documents are only in machine language, not text

Postby 75FXE » Sat Oct 13, 2012 2:03 am

Thank-you for the responses. The procedure that triggered this was: writing the document...working with it to place data in order by copying and deleting paragraphs (mailing list)....saving to a folder. Problem surfaced following day on first retrieval. I am posting the document. Speaking of locked files, when I transferred my old files to this new system, they were all locked and occasionally new files in calc have also been locked....related? This had happened once before on my old system quite a while ago and was solved by saving the file with a different extension as I recall. I had made notes, but that file was lost in the old system failure. Thanks again for your "hand-holding". I'm now going to examine user profile to see what's up there, but since the error is only on one document, I feel like I'm risking catastrophe by messing with it.
Open Office 3.4.1 on Windows 7
75FXE
 
Posts: 24
Joined: Wed Aug 29, 2012 5:00 am

Re: Saved documents are only in machine language, not text

Postby RoryOF » Sat Oct 13, 2012 6:19 am

On transfer to a new system, depending on the mode of transfer, it can happen that transferred files acquire Read-only attributes. There are several causes of this, and hence several cures, each specific to the exact symptoms. A simple solution is often to save a read-only file to another name, not necessarily a different file type; so, e.g., Fred.odt => Fred1.odt might well be sufficient. A single file refusing to open or asking for ASCII filter choices is often a sign of a corrupt file. This can be caused by a system or program crash, or frequently by an over speedy shut down of the computer before file or disk buffers have flushed. In the case of a single file refusing to open or prompting for ASCII filters the file may be damaged beyond repair; a backup policy should be in place for important files.
Apache OpenOffice 4.1.8 on Xubuntu 20.04.1 (mostly 64 bit version) and very infrequently on Win2K/XP
User avatar
RoryOF
Moderator
 
Posts: 31722
Joined: Sat Jan 31, 2009 9:30 pm
Location: Ireland

Re: Saved documents are only in machine language, not text

Postby 75FXE » Sat Oct 13, 2012 6:30 pm

Thank-you again. The transfer was by saving files to a thumb drive when my problems started developing and retrieving in the new machine when acquired. I solved the problem by copy/paste each file into new file - laborious but workable. Just seems as though there ought to be a way to change the default to read-only on all the transferred material.
Open Office 3.4.1 on Windows 7
75FXE
 
Posts: 24
Joined: Wed Aug 29, 2012 5:00 am

Re: Saved documents are only in machine language, not text

Postby RoryOF » Sat Oct 13, 2012 6:37 pm

If the thumb drive is marked as read-only on the new machine, then the files acquire that attribute (similarly if transfer is by CD/DVD). Sometimes the read-only attribute is not applied if the computer is booted with the thumb drive in position. Such a problem (read-only drive and/or files) really needs hands on access to the computer to determine why it happens.
Apache OpenOffice 4.1.8 on Xubuntu 20.04.1 (mostly 64 bit version) and very infrequently on Win2K/XP
User avatar
RoryOF
Moderator
 
Posts: 31722
Joined: Sat Jan 31, 2009 9:30 pm
Location: Ireland

Re: Saved documents are only in machine language, not text

Postby 75FXE » Sat Oct 13, 2012 7:41 pm

Thank-you again , but the read-only applied to only some doc's, not all, and was a carry-around additional b/u both before & after my machine replacement. If any attributes were set it was not by conscious effort and would have had to be inadvertent keystrokes while using default save, save as commands on Vista o/s or clicking to open in WIN7. I seem to recall this happening sporadically, but rarely on my old machine, but at the transfer, it was prevalent on calc files, don't recall any text files so encumbered.
Open Office 3.4.1 on Windows 7
75FXE
 
Posts: 24
Joined: Wed Aug 29, 2012 5:00 am

Re: Saved documents are only in machine language, not text

Postby RoryOF » Sat Oct 13, 2012 8:16 pm

You need to enable Viewing of Hidden files, and look to see are there lock files of related name being transferred with the main files. Such lock files will cause the main file to be read-only.
Apache OpenOffice 4.1.8 on Xubuntu 20.04.1 (mostly 64 bit version) and very infrequently on Win2K/XP
User avatar
RoryOF
Moderator
 
Posts: 31722
Joined: Sat Jan 31, 2009 9:30 pm
Location: Ireland

Re: Saved documents are only in machine language, not text

Postby 75FXE » Sun Oct 14, 2012 12:06 am

I enabled Hidden and find a mirrored name for each of my calc files in this form: ~lock.FILENAME.ODS#. I do not know what you mean by "being transferred with the main files" As I wrote, I resolved the problem by recreating the file under a new name, but for future occurrences, do I just delete the lock file or what to lift the restriction?
Last edited by 75FXE on Sun Oct 14, 2012 12:11 am, edited 1 time in total.
Open Office 3.4.1 on Windows 7
75FXE
 
Posts: 24
Joined: Wed Aug 29, 2012 5:00 am

Re: Saved documents are only in machine language, not text

Postby FJCC » Sun Oct 14, 2012 12:11 am

Yes, just delete the ~lock file.
Windows 10 and Linux Mint, since 2017
If your question is answered, please go to your first post, select the Edit button, and add [Solved] to the beginning of the title.
FJCC
Moderator
 
Posts: 7833
Joined: Sat Nov 08, 2008 8:08 pm
Location: Colorado, USA

Re: Saved documents are only in machine language, not text

Postby 75FXE » Sun Oct 14, 2012 12:30 am

A-h-h-h-h the learning process plods on...Thank-you both. curious, is this a typical Windows problem or something in OO? This was not the problem that brought me here, I mentioned it as an aside later in the thread in case it had relevance. The original problem was that a new document (.txt) I saved is retrievable only in machine language. No hidden files evident here. Again, in case it's relevant, my system identifier on posts lists 3.3 on Vista. Although I downloaded via Vista, I currently have WIN7 as the o/s. I know the o/s is claimed to be forwardly compatible, but there might be some idiosyncrasy I'm not aware of.
Open Office 3.4.1 on Windows 7
75FXE
 
Posts: 24
Joined: Wed Aug 29, 2012 5:00 am

Re: Saved documents are only in machine language, not text

Postby RoryOF » Sun Oct 14, 2012 8:50 am

The lock files should normally be deleted when a main file is closed. After a program or system crash they may remain and because normally invisible can be transferred to a new machine in course of a global transfer, causing read-only flags to be set when trying to edit their owning files on a new system. With OpenOffice closed (note: closed, not simply minimised) they should be deleted to prevent this unwanted read-only side effect. But care is needed to ensure the correct files are deleted; typically they are of some few hundred bytes in size and their owning files are a minimum of about 7.5kB - a very distinct difference in size.

The existence of unwanted lock files is indicative of either program/computer instability or of bad User practice; if they show up regularly one needs to find why, but that may be subject for a separate thread, if necessary.

It is possible that the .txt file of which you write is corrupt. How did you save as a text file? Did you drop the type selector on the Save As window to select a text file type, or did you manually change the file extension to text on an existing file?
Apache OpenOffice 4.1.8 on Xubuntu 20.04.1 (mostly 64 bit version) and very infrequently on Win2K/XP
User avatar
RoryOF
Moderator
 
Posts: 31722
Joined: Sat Jan 31, 2009 9:30 pm
Location: Ireland

Re: Saved documents are only in machine language, not text

Postby 75FXE » Mon Oct 15, 2012 5:15 pm

I customarily use SAVE AS [alt/f/a] to save new work as a means to select folder in which to file, and save it in its' default file type, not changing the extension, in this case .txt. When I next open to modify, I save via alt/f/s.
Open Office 3.4.1 on Windows 7
75FXE
 
Posts: 24
Joined: Wed Aug 29, 2012 5:00 am

Re: Saved documents are only in machine language, not text

Postby Bill » Mon Oct 15, 2012 8:53 pm

"Text" is not the default "save as type" for any module in AOO. The default "save as type" for Writer is "ODF text document" with an .odt file name extension. The "save as type" can be changed by the user in Tools > Optios > Load/Save > General > Default file format and ODF settings.

The setting is stored in the user profile. After resetting the user profile, "Text" should no longer appear as the default "save as type".
Bill
Volunteer
 
Posts: 8002
Joined: Sat Nov 24, 2007 6:48 am

Re: Saved documents are only in machine language, not text

Postby 75FXE » Wed Oct 17, 2012 3:23 am

Thanks for the handholding. Followed your Tools pathway and found the default already set on .odt. I tried re-saving the document with both the odt and odf extensions without seeing the machine language convert. This may be a clue - each time I open the corrupted document, I get a menu asking me which language, character set, and fonts to specify.
Open Office 3.4.1 on Windows 7
75FXE
 
Posts: 24
Joined: Wed Aug 29, 2012 5:00 am

Re: Saved documents are only in machine language, not text

Postby 75FXE » Wed Oct 17, 2012 5:54 pm

I opened up a new document today after an overnight dormancy: my save as choices have returned to only .txt or All Files. Lock files have returned in my cal;c files. I checked my thumb drives and none are marked read only. No matter what your system has decided to specify at the base of my postings, I am using AOO 3.4.1 on WIN7, not 3.3 on Vista, The machine language problem seems to be isolated to one document. Any ideas on how to ressurect it - saving as odt or odf have been worthless,
Open Office 3.4.1 on Windows 7
75FXE
 
Posts: 24
Joined: Wed Aug 29, 2012 5:00 am

Re: Saved documents are only in machine language, not text

Postby RoryOF » Wed Oct 17, 2012 6:01 pm

We need to be exact about this: please confirm the site from which you downloaded the OpenOffice. The exact filename and exact size would also be helpful.
Apache OpenOffice 4.1.8 on Xubuntu 20.04.1 (mostly 64 bit version) and very infrequently on Win2K/XP
User avatar
RoryOF
Moderator
 
Posts: 31722
Joined: Sat Jan 31, 2009 9:30 pm
Location: Ireland

Re: Saved documents are only in machine language, not text

Postby Bill » Wed Oct 17, 2012 6:17 pm

75FXE wrote:I opened up a new document today after an overnight dormancy: my save as choices have returned to only .txt or All Files. Lock files have returned in my cal;c files. I checked my thumb drives and none are marked read only. No matter what your system has decided to specify at the base of my postings, I am using AOO 3.4.1 on WIN7, not 3.3 on Vista, The machine language problem seems to be isolated to one document. Any ideas on how to ressurect it - saving as odt or odf have been worthless,

You should check your system for malware. "All Files" is not a valid file type and should not appear on a Save As dialog. It's an option only for opening files.
Bill
Volunteer
 
Posts: 8002
Joined: Sat Nov 24, 2007 6:48 am

Re: Saved documents are only in machine language, not text

Postby 75FXE » Wed Oct 17, 2012 9:23 pm

I've been shielded by Norton I S since machine set up, and on expiration, switched immediately to MSE. I'll run scans with MBAM and ASC just to be sure, This just doesn't add up - randomly picking old files shows many with the .txt extension. and I've been using OO since 2007, no other office suite. I just followed again the pathway above mentioned: options>....load/save>general.....and again got the same AOO list of about 10 extensions including .txt, .odt, .odf, .rtf various MS office versions, text template, html, text encoded, rtf encoded.
Open Office 3.4.1 on Windows 7
75FXE
 
Posts: 24
Joined: Wed Aug 29, 2012 5:00 am

Re: Saved documents are only in machine language, not text

Postby peterroots » Wed Oct 17, 2012 9:41 pm

I tried re-saving the document with both the odt and odf extensions
How did you do this? There is no odf file extension. ODF is the generic OpenDocumentFormat that covers .odt .ods etc. it is not a file type
LibreOffice 4.0.3 OpenSUSE 12.3 : OpenOffice 4 Linux Mint 15
User avatar
peterroots
Volunteer
 
Posts: 299
Joined: Mon Mar 03, 2008 6:33 pm
Location: UK

Re: Saved documents are only in machine language, not text

Postby Bill » Wed Oct 17, 2012 11:53 pm

75FXE wrote:I've been shielded by Norton I S since machine set up, and on expiration, switched immediately to MSE. I'll run scans with MBAM and ASC just to be sure, This just doesn't add up - randomly picking old files shows many with the .txt extension. and I've been using OO since 2007, no other office suite.

You're right. It doesn't add up. I've been using OOo since 2005 and have never seen file extensions change spontaneously. Maybe you should look for a problem with System Restore.

75FXE wrote:I just followed again the pathway above mentioned: options>....load/save>general.....and again got the same AOO list of about 10 extensions including .txt, .odt, .odf, .rtf various MS office versions, text template, html, text encoded, rtf encoded.

I followed the same path and saw no file extensions. There is only a description of the file types, and none match the list you posted.
Bill
Volunteer
 
Posts: 8002
Joined: Sat Nov 24, 2007 6:48 am

Re: Saved documents are only in machine language, not text

Postby 75FXE » Thu Oct 18, 2012 12:21 am

I just went back that path again and now find the same as you - 5 or 6 file types listed but by name only, not showing extensions. The lengthy list I previously had possibly leftover from previous version (v1, 2, 3.3)? I ran MBAM, ASC, CCleaner without finding malware, only some cookies. Suggestions?
Open Office 3.4.1 on Windows 7
75FXE
 
Posts: 24
Joined: Wed Aug 29, 2012 5:00 am

Re: Saved documents are only in machine language, not text

Postby RoryOF » Thu Oct 18, 2012 7:52 am

Please let us know the filename and size you installed, also the URL from which you downloaded, which should show up in your brower's downloads history. At this stage everything needs to be checked, rather than relying on possibly faulty memory.
Apache OpenOffice 4.1.8 on Xubuntu 20.04.1 (mostly 64 bit version) and very infrequently on Win2K/XP
User avatar
RoryOF
Moderator
 
Posts: 31722
Joined: Sat Jan 31, 2009 9:30 pm
Location: Ireland

Re: Saved documents are only in machine language, not text

Postby 75FXE » Thu Oct 18, 2012 4:00 pm

I'm not sure to which d/l you refer. The corrupted document was not a download, but a series of pastes into notepad (OO text doc) using ctrl>c to assemble a mailing list from various online published address lists. Were you able to determine anything when I attached the document here a few days ago in response to your request? I note this AM when saving a new text document that I was again offered only the choices of .txt or All Files in the Save As pop-up, even though followiong the options>load/save etc path shows half a dozen or so choices.
Open Office 3.4.1 on Windows 7
75FXE
 
Posts: 24
Joined: Wed Aug 29, 2012 5:00 am

Re: Saved documents are only in machine language, not text

Postby RoryOF » Thu Oct 18, 2012 4:07 pm

I was referring to the d/l of OpenOffice; it can happen, and has happened as evidenced quite recently on this Forum, that Users download OpenOffice from a rogue site. Such Downloads may be altered to include (for example) a trojan toolbar or other nasties, which they don't tell you about. That's why I ask about your original download of OpenOffice and the information in OpenOffice /Help /About. We always recommend downloading only from the official site, linked from the bottom right hand corner of the Forum window.

I've just checked through the listings in this thread and do not see any attached document.
Apache OpenOffice 4.1.8 on Xubuntu 20.04.1 (mostly 64 bit version) and very infrequently on Win2K/XP
User avatar
RoryOF
Moderator
 
Posts: 31722
Joined: Sat Jan 31, 2009 9:30 pm
Location: Ireland

Re: Saved documents are only in machine language, not text

Postby Bill » Thu Oct 18, 2012 4:52 pm

75FXE wrote:...The corrupted document was not a download, but a series of pastes into notepad (OO text doc) using ctrl>c to assemble a mailing list from various online published address lists...

You're pasting in Notepad?
Bill
Volunteer
 
Posts: 8002
Joined: Sat Nov 24, 2007 6:48 am

Re: Saved documents are only in machine language, not text

Postby kingfisher » Thu Oct 18, 2012 11:28 pm

It sounds to me as though you are trying to save a plain text document rather than a Writer document. The options you are seeing are probably those offered by some text editor (Notepad, for example). If you want a Writer document, open Writer and create a new document with it.
Apache OpenOffice 4.1.6 on PCLinuxOS
User avatar
kingfisher
Volunteer
 
Posts: 2120
Joined: Tue Nov 20, 2007 10:53 am

Re: Saved documents are only in machine language, not text

Postby 75FXE » Sat Oct 20, 2012 2:48 am

Thank-you all for responses. I don't recall source of d/l but my habit is to go to the source on any software. I would expect a return to home base from my v3.3 for the update.

I guess this is where I say, "OOPS"
Yes I was using notepad to assemble the document. Can you offer a suggestion on how to convert to writer other than copy/paste into AOO New Text Document which hasn't worked? I've tried saving with different extension without success.

I'm going to again try the uploading process for the document. A=h-h-h-h.....a message: "extension .txt is not allowed". Solution, save it as .odt and attach.
Attachments
Ranges.odt
(20.46 KiB) Downloaded 138 times
Open Office 3.4.1 on Windows 7
75FXE
 
Posts: 24
Joined: Wed Aug 29, 2012 5:00 am

Re: Saved documents are only in machine language, not text

Postby kingfisher » Sat Oct 20, 2012 7:34 am

What happens when you try to copy and paste to a Writer document? I can copy and paste from a text editor to a Writer document without any trouble.

You could try pasting to WordPad (? name) and copying from there to Writer.
Apache OpenOffice 4.1.6 on PCLinuxOS
User avatar
kingfisher
Volunteer
 
Posts: 2120
Joined: Tue Nov 20, 2007 10:53 am

Next

Return to MS Windows

Who is online

Users browsing this forum: No registered users and 7 guests