[Solved] Master Documents - Page Breaks before Subdocuments

Writing a book, Automating Document Production - Discuss your special needs here

[Solved] Master Documents - Page Breaks before Subdocuments

Postby Barry Say » Thu Feb 04, 2010 12:17 pm

Hi All,

I am typsetting a series of publications which have been scanned and OCRed. I want to store individual articles separately so they can be mounted individually on the web. I thought it would be a good idea to set it up as a master document with each article in a sub-document. Most articles start at the top of a page so I reckoned that including a page break before each article in the general case would be useful and remove the page break where it was not wanted.

Once I started down this road I found I couldn't get rid of the page break. Examining the content.XML file for a subdocument I found an autostyles section which had paragraph style named P2 which had the page break style, but I can find no way of deleting this except by using a text editor on the content.XML file.

Is this a known issue? Have I missed some documentation?

Barry

I am sorry to leap into the advanced group, but this looks like an advanced topic
Last edited by Barry Say on Wed Jan 18, 2012 4:07 pm, edited 1 time in total.
OpenOffice.org.3.1.1
OOO310m19(Build:9420)
openoffice.org.core 1:3.1.1-5ubuntu1
Ubuntu Linux Karmic Koala
Barry Say
 
Posts: 5
Joined: Thu Feb 04, 2010 11:52 am

Re: Master Documents - Page Breaks before Subdocuments

Postby RoryOF » Thu Feb 04, 2010 12:24 pm

This is not an answer to your question, but ancilliary information:
You might find it of interest to look at
http://www.scribd.com/doc/18188542/Creating-large-documents-with-OpenOfficeorg-Writer
which can be quite helpful on the use of Master Documents.
Apache OpenOffice 4.1.6 on Xubuntu 18.04.2 (mostly 64 bit version) and very infrequently on Win2K/XP
User avatar
RoryOF
Moderator
 
Posts: 28569
Joined: Sat Jan 31, 2009 9:30 pm
Location: Ireland

Re: Master Documents - Page Breaks before Subdocuments

Postby samanarayan » Sun Feb 07, 2010 2:22 am

I am using Master document facility for a while now, and this is what I have learned- All the sub-documents of a master document are automatically rendered in a new page. You do not have to insert a manual page break ever. When i want two such sub-documents on the same page, then i make them into one sub-document before creating a master- this may sound a bit silly, but i guess this is a tweak that works.
samanarayan
 
Posts: 3
Joined: Wed Jan 27, 2010 5:15 pm

Re: Master Documents - Page Breaks before Subdocuments

Postby Hagar Delest » Sun Feb 07, 2010 10:47 pm

samanarayan wrote:this is what I have learned- All the sub-documents of a master document are automatically rendered in a new page.

:shock:
Never seen that. I just made a quick experiment with 3.2 (RC2) on xubuntu 9.10 and the subdocs flow without page break.
AOO 4.1.6 on Xubuntu 18.10 and 4.1.5 on Windows 7 (with winPenPack port).
User avatar
Hagar Delest
Moderator
 
Posts: 28433
Joined: Sun Oct 07, 2007 9:07 pm
Location: France

Re: Master Documents - Page Breaks before Subdocuments

Postby wbk » Mon May 24, 2010 9:45 pm

Sorry for getting this old thread all the way to the top again. I think samanarayan is refering to "print pages", while hagar is referring to "OOo pages".

In my experience, a newly inserted section in a master document starts at the top of a new "print page", while continuing the page style from the previous page.

Rereading the opening post, I can't clearly state whether the issue is with "print pages" or "OOo pages". There's not been a follow up anymore, so maybe the issue is solved or, anyway, not an issue anymore.
OOo 3.2.0 build 9483 on Kubuntu 10.04 x86-64
wbk
 
Posts: 42
Joined: Wed May 19, 2010 12:13 pm

Re: Master Documents - Page Breaks before Subdocuments

Postby Barry Say » Wed Jan 18, 2012 11:30 am

Apologies to all for not posting sooner on this one. I found the fix for the problem.

When one sets up a master document to have each sub-document on a separate page, a "custom-style" is introduced into the subdocuments. If one then reverts to documents flowing irrespective of page breaks, this "custom-style" remains in the document but does not appear in any menus that I can find. The problem can be cured by a hand-edit of the content.xml.

This is a poisonous problem. If a sub-document with this feature is used as a template for a subsequent document this custom-style appears in the new document. If this article starts off naturally at the top of a page, no problem. If, as the master document develops, it is required that the article starts half-way down the page, it obstinately appears at the top of the next page.

I now have a work-around but if time allows I will set up a demonstration and register it as a bug.

B
OpenOffice.org.3.1.1
OOO310m19(Build:9420)
openoffice.org.core 1:3.1.1-5ubuntu1
Ubuntu Linux Karmic Koala
Barry Say
 
Posts: 5
Joined: Thu Feb 04, 2010 11:52 am

Re: [Solved] Master Documents - Page Breaks before Subdocume

Postby ningappak » Fri Jul 24, 2015 2:19 pm

Even I faced the same problem while creating master document.

For section break between sub-documents to be continuous, but in one place it is showing section break (Next page). It solved by following below steps

- Place your mouse point on heading of the master page
- go to page layout
- In layout it is showing next page/ continuous
- below it showing "This Section"
- Change "This Section" option to "whole document".

I think my comment will help you to solve your problem.
OpenOffice 2.4 on Ubuntu 9.04
ningappak
 
Posts: 1
Joined: Fri Jul 24, 2015 2:11 pm


Return to Advanced Uses

Who is online

Users browsing this forum: No registered users and 0 guests