Page 1 of 1

[Solved] Show Comment On Screen, But Don't Print

PostPosted: Thu May 23, 2019 2:52 am
by Longspeak
This is the first time I haven't been able to find an answer just by searching.

I am converting a sheet from excel to OpenOffice. We use comments to instruct users. In Excel, the comments can show, but be set to not print.

In OpenOffice, even though the "comment" box is unchecked in the Format Page dialogue, when I print, any visible comment also prints.

Is there a way to have a comment be visible on the screen, but still not print?

I can adjust the sheet if I have to, but we have a LOT of sheets set up this way.

Re: Show Comment On Screen, But Don't Print

PostPosted: Thu May 23, 2019 6:32 am
by RusselB
Welcome to the Forums.
I don't use comments often, and when I do, I usually want them printed.
That said, it appears that you have to uncheck Drawing Objects on the Format page dialog (sheet tab) in order for displayed comments to actually not print.
I have no idea why this is, but my quick check shows that is what you need to do....either that or uncheck Show Comment for the comments...though I suspect the first option would be the easiest.

Re: Show Comment On Screen, But Don't Print

PostPosted: Thu May 23, 2019 10:03 pm
by Longspeak
Ah. Thank you. That answers the question, though it creates a new question. I can't disable Drawings/Objects, because the form also uses those. :p

I will probably have to rework all the sheets which use comments for instructions, but this did answer the question.

I suppose I can very carefully place the comment and set the print area, so all that's visible it the line from the comment to the box. If I get creative, I can even make the line look like it's part of the form...

Re: Show Comment On Screen, But Don't Print

PostPosted: Thu May 23, 2019 11:08 pm
by RoryOF
RusselB wrote:Welcome to the Forums.
I don't use comments often, and when I do, I usually want them printed.
That said, it appears that you have to uncheck Drawing Objects on the Format page dialog (sheet tab) in order for displayed comments to actually not print.
I have no idea why this is, but my quick check shows that is what you need to do....either that or uncheck Show Comment for the comments...though I suspect the first option would be the easiest.


I think this is because the comment box is fundamentally a drawing object.