Copying cells implicitly turns them into bitmaps!

Discuss the spreadsheet application

Copying cells implicitly turns them into bitmaps!

Postby FrustratedUser » Thu May 16, 2019 11:42 pm

Today, I opened an OpenOffice spreadsheet like I have many times in the past. I needed to move some cells around, so I tried using the copy/paste feature, which has always worked in the past.

But this time, when I pasted, the data I copied appeared above the intended cell, and a little anchor icon appeared. The text appeared in a box with green squares on the edges. Moving the green dots scaled the text as an image!

Image

So I copied the cell again, and this time tried using Paste Special. The options I got were:

  • PNG Bitmap
  • Bitmap

Was Calc converting the cells into a bitmap upon copying?!

Next, I opened up mate-terminal, copied the cell again, and tried pasting it into the terminal. Nothing.

Then I opened up GIMP and tried pasting into that. The cell appeared, rendered as an image.

Was it an X11 problem? I tried copying some text around within mate-terminal, and that still worked, so nope. Calc must be the thing that's deciding to copy cells as an image.

Then I went back to Calc and tried copying through the menu: Edit -> Copy (Ctrl+C). The cell was still converted into an image upon copying.

Apparently, something has snapped, and as a result, Calc has decided that "Copy" means render the cells as an image and then copy the image. That leaves me with no way to work with formulas.

I haven't changed the installation of OpenOffice at all. It's manually installed at /opt/openoffice4, because Debian only includes LibreOffice, which
has introduced some horrible bugs into their implementation of formulas.

I tried Googling the problem, which led to some pages on how to paste images into OpenOffice calc, which I have already accidentally discovered how to do.

How do I get normal copying behavior back?
OpenOffice 4.1.6 / Debian Unstable
FrustratedUser
 
Posts: 1
Joined: Thu May 16, 2019 11:26 pm

Re: Copying cells implicitly turns them into bitmaps!

Postby FJCC » Fri May 17, 2019 2:39 am

When something completely weird happens, it is a good idea to try resetting you user profile. You can find that in the folder /home/YourUserName/.openoffice/4. It is the folder called user. Shutdown OpenOffice and rename that to user_old. When you start OpenOffice, you should get the registration screen. After filling that out, try a copy and paste.
Windows 10 and Linux Mint, since 2017
If your question is answered, please go to your first post, select the Edit button, and add [Solved] to the beginning of the title.
FJCC
Moderator
 
Posts: 7396
Joined: Sat Nov 08, 2008 8:08 pm
Location: Colorado, USA

Re: Copying cells implicitly turns them into bitmaps!

Postby keme » Tue May 21, 2019 3:23 pm

Your signature indicates that you live on the bleeding edge of Debian. I'd ask them too. If that constitutes crossposting, make sure you include cross-links.
The clipboard takes care of cut/paste transfers.
While I am not aware of any work being done on the clipboard side of things, there is e.g. the new WebP graphics format which may need a handler for some contexts.
User avatar
keme
Volunteer
 
Posts: 3287
Joined: Wed Nov 28, 2007 10:27 am
Location: Egersund, Norway


Return to Calc

Who is online

Users browsing this forum: No registered users and 14 guests