[Solved] How to turn off spellcheck (or capitalization)?

Discuss the spreadsheet application

[Solved] How to turn off spellcheck (or capitalization)?

Postby Jeff Root » Sun Apr 07, 2019 12:20 pm

I used Open Office Writer for several months to edit a book.
It was published in December. At the start of that project I
must have turned off the spelling checker because I do not
recall being annoyed by it.

Now I am attempting to use Open Office Calc for the first time.
I used MS Excel many years ago and remember a little bit about
how it worked. But the very first thing I tried to do in Calc failed.

I want to put the letter "i" in the second cell of the first row.
Calc won't let me do it. It thinks I meant the word "I", so as soon
as I go to another cell, or type a space, it capitalizes the letter.

How do I turn off the spelling checker in Calc?

Edit: Okay, I just tested Writer, and find that even though the
spelling checker seems to be turned off, it changes lower-case
i into capital I, as well. I didn't run into that problem while
editing the book, naturally enough.

So, what do I need to turn off?

-- Jeff, in Minneapolis

.
Last edited by Jeff Root on Mon Apr 08, 2019 6:28 am, edited 2 times in total.
Open Office 4.1.5 Windows 10
Jeff Root
 
Posts: 23
Joined: Thu May 17, 2018 7:23 pm

Re: How to turn off spellcheck?

Postby RusselB » Sun Apr 07, 2019 1:03 pm

I'm going to suggest Tools -> Options -> Language Settings -> Writing Aids -> Options -> Check Capitalization
OpenOffice 4.1.6 and LibreOffice 6.0.6.2 on Windows 7 Pro & Ultimate
If you believe your problem has been resolved, please go to your first post in this topic, click the Edit button and add [Solved] to the beginning of the Subject line.
User avatar
RusselB
Moderator
 
Posts: 5398
Joined: Fri Jan 03, 2014 7:31 am
Location: Sarnia, ON

Re: How to turn off spellcheck?

Postby Jeff Root » Sun Apr 07, 2019 1:51 pm

That sure seems like the logical place, but I find that I had already
unchecked all of the checkboxes in the "Options" window, including
"Check capitalization".

-- Jeff, in Minneapolis
Open Office 4.1.5 Windows 10
Jeff Root
 
Posts: 23
Joined: Thu May 17, 2018 7:23 pm

Re: How to turn off spellcheck?

Postby MrProgrammer » Sun Apr 07, 2019 4:34 pm

Jeff Root wrote:I want to put the letter "i" in the second cell of the first row. Calc won't let me do it. It thinks I meant the word "I", so as soon as I go to another cell, or type a space, it capitalizes the letter.
Uncheck Tools → Cell Contents → AutoInput
Uncheck Tools → Autocorrect options → Options → Capitalize first letter of every sentence
While you're there, review and uncheck any other options you don't want. Use the Help button to learn what they do.

Jeff Root wrote:Now I am attempting to use Open Office Calc for the first time.
[Tutorial] Ten concepts that every Calc user should know

If this solved your problem please go to your first post use the Edit button and add [Solved] to the start of the title. You can select the green checkmark icon at the same time.
Mr. Programmer
AOO 4.1.5 Build 9789 on MacOS 10.11.6.   The locale for any menus or Calc formulas in my posts is English (USA).
User avatar
MrProgrammer
Moderator
 
Posts: 3811
Joined: Fri Jun 04, 2010 7:57 pm
Location: Wisconsin, USA

Re: How to turn off spellcheck?

Postby Villeroy » Sun Apr 07, 2019 6:11 pm

Tools>Contents>AutoInput is a global option for all spreadsheets.
The AutoCorrect options apply to all components of the entire suite.
Every snippet of document text has a language attribute so you can edit multi-lingual documents. There is also a language named "[None]".

If you want to turn off most AutoCorrect options and spell checking for all spreadsheet document while using the features in Writer & Co:
Create a new spreadsheet
Tools>Options>LanguageSettings>Languages: Set Western Language to [None] and check "Current Document Only".
Without text language, most of the AutoCorrect options do not apply anymore.

menu:File>Templates>Save... and save it under some name in the templates repository.
menu:File>Templates>Organize... select the new template and make it the default template using the [Command] drop down.
Now you get a new document from this instance whenever you create a new spreadsheet.
Please, edit this topic's initial post and add "[Solved]" to the subject line if your problem has been solved.
Ubuntu 18.04, no OpenOffice, LibreOffice 6.x
User avatar
Villeroy
Volunteer
 
Posts: 27098
Joined: Mon Oct 08, 2007 1:35 am
Location: Germany

Re: How to turn off spellcheck?

Postby Jeff Root » Mon Apr 08, 2019 6:16 am

MrProgrammer wrote:Uncheck Tools → Cell Contents → AutoInput
Uncheck Tools → Autocorrect options → Options → Capitalize first letter of every sentence

The second line doesn't do it. I found that I need to uncheck:

Tools → Autocorrect Options → Options → Use replacement table

I could instead remove the i/I pair from the replacement table.

While editing the book I did find it a nice feature that two hyphens
were replaced by a long dash. Otherwise, I don't think I got any
use out of it. So far, the author, his wife, and I haven't found any
typos, so not using the spelling checker seems to have worked ok.


Good stuff.

Thanks, everyone.

-- Jeff, in Minneapolis
.
Open Office 4.1.5 Windows 10
Jeff Root
 
Posts: 23
Joined: Thu May 17, 2018 7:23 pm


Return to Calc

Who is online

Users browsing this forum: No registered users and 18 guests