Document opened in read-only mode

Discuss the spreadsheet application

Document opened in read-only mode

Postby Wabbit » Tue Dec 18, 2007 7:28 pm

"Document opened in read-only mode"
The "document" is a 65 page workbook which is my weekly accounts, I'm on page 38 and it was fine when I used it the other day. now it's telling me that I've opened it in read only mode. It's not a protected document as this is my home PC and I'm the only one that uses it (I live alone). I've found that if I open the workbook and "save as", the new saved document is fine. But there must be a simple way of correcting this.

Win xp pro
Open office version 221

Thanks in advance
Wabbit
 
Posts: 2
Joined: Tue Dec 18, 2007 6:46 pm

Re: Document opened in read-only mode

Postby RogerGaunt » Thu Dec 20, 2007 5:16 pm

Navigate to the file in Explorer.
Right click the file name, then Properties.
There should be a check box showing "Read Only" on the General tab, along with Hidden and Archive.
Uncheck this, and (hopefully) your problem has gone.
Don't ask me how it got set as Read Only, I've no idea
RogerGaunt
 
Posts: 2
Joined: Tue Dec 18, 2007 2:56 pm

Re: Document opened in read-only mode

Postby Wabbit » Thu Dec 20, 2007 8:11 pm

The document attribute is not set to read only (that was the first thing I checked). But thanks for replying :) The problem seems to be with OpenOffice, Anyone else go a clue?
Wabbit
 
Posts: 2
Joined: Tue Dec 18, 2007 6:46 pm

Re: Document opened in read-only mode

Postby Hagar Delest » Thu Dec 20, 2007 10:43 pm

Could you have clicked by error on the Edit button in the toolbar just before saving ? Personally, I remove that button to avoid such inconvenience.
AOO 4.0.1 on Windows 7 and Xubuntu 14.04 (Trusty Tahr)
User avatar
Hagar Delest
Moderator
 
Posts: 25090
Joined: Sun Oct 07, 2007 9:07 pm
Location: France

Re: Document opened in read-only mode

Postby AndrewZ » Sun Dec 23, 2007 4:46 pm

I've seen this happen on an office network. What I do (in a file browser such as Windows Explorer) is copy the file to a new name, delete the old file, and rename the new file to the old name.

Alternatively, you could try clicking the Edit button on the toolbar.

Another option is to try File->Save As and see what happens.
<signature>
* Did you solve your problem? Do others a favor: Post the solution
* Visit OpenOffice.org Ninja (blog) and OpenOffice.org Ninja Wiki for news, previews, troubleshooting, etc.
</signature>
OOo 3.0.X on Fedora 9 + XP
User avatar
AndrewZ
Volunteer
 
Posts: 633
Joined: Mon Oct 08, 2007 1:25 am
Location: Colorado, USA

Re: Document opened in read-only mode

Postby luc53 » Wed Dec 26, 2007 8:00 pm

I think it's a problem not coming from open office. If you click right on file name, than property, than protection you see how your file has been closed for ever by someone that is not you. If you try to change the general protection you need an expert. It is easyer for me to copy in new file, but it is rally time wasting .
Can anyone help ?
luc53
 
Posts: 2
Joined: Wed Dec 26, 2007 7:48 pm

Re: Document opened in read-only mode

Postby luc53 » Wed Dec 26, 2007 8:50 pm

In other forum I have found the solution.
Open a folder/click once on the file you like/click organize (top left)/click property/click protection/click users/click modify/click to allow complete control/ok/ok/ fonoshed. On the file the icon is changed and now it is easy to change the file (also for viruses I think).
luc53
 
Posts: 2
Joined: Wed Dec 26, 2007 7:48 pm

Re: Document opened in read-only mode

Postby Rands » Sun Mar 23, 2008 12:37 am

How do I open OpenOffice 2.3 without it being read-only mode? (I'm unable to enter any data) I don't even know what a read-only mode is? Hopefullly, I don't need to understand it to correct this problem.----Rands
Rands
 
Posts: 1
Joined: Sun Mar 23, 2008 12:11 am

Re: Document opened in read-only mode

Postby kingfisher » Sun Mar 23, 2008 5:29 am

Read-only mode means that you cannot save any changes to the document. If you open a file from a cd or dvd, it will be read-only because OO cannot write to such media. What is your situation?
OpenOffice 3.3 on PCLinuxOS. There are 3 kinds of people: those who can count and those who can't.
User avatar
kingfisher
Volunteer
 
Posts: 1861
Joined: Tue Nov 20, 2007 10:53 am

Re: Document opened in read-only mode

Postby Boatman189 » Mon Mar 24, 2008 1:46 pm

Read only usually occurs when more than one instance of a file is open at the same time.
OOo 3.0.X on Ms Windows XP
Boatman189
 
Posts: 22
Joined: Sun Mar 23, 2008 4:57 pm
Location: Sw Florida

Re: Document opened in read-only mode

Postby baffoni » Sat Dec 27, 2008 1:36 am

I just upgraded OO from 2.2 to 3.0. Now, every time I open a file, it is automatically in READ ONLY mode. I have a workaround, but this REALLY needs to be fixed.

I'm running OO 3.0 on Vista SP1. If I create a new file, I can't save it, it is immediately in read only mode (same for opening older files). Currently seeing this in the spreadsheet app. This is caused because OO doesn't correctly handle it's lock files!

When you open or create a file name "test.ods", it creates the lock file ".~lock.test.ods#". If I create this file, then immediately delete this lock file, I can now save my document (once; it recreates the file on save). I have full permissions on this file, I can delete it at any time, even while the file it locks is open. When I close the ods file, the lock file is left behind, preventing edits in the future without pre-deleting the lock file.

This really REALLY is a showstopper for most people, we really need a point update to fix this.
OOo 3.0.X on MS Windows Vista + XP
baffoni
 
Posts: 2
Joined: Sat Dec 27, 2008 1:17 am

Re: Document opened in read-only mode

Postby baffoni » Sat Dec 27, 2008 1:38 am

Is there a better place to post bug reports (e.g. like bugzilla for mozilla products), or does this forum function in this capacity?
OOo 3.0.X on MS Windows Vista + XP
baffoni
 
Posts: 2
Joined: Sat Dec 27, 2008 1:17 am

Re: Document opened in read-only mode

Postby acknak » Sat Dec 27, 2008 2:45 am

The bug is already fixed and due for release in 3.0.1 next month.

The problem can be triggered when you include a comma or semicolon in your user information (Tools > Options > OO.org > User Information > Name). Just remove the problem characters and you should be able to edit your files normally.

Have you read the Forum Survival Guide? This is not the place to report bugs, although you can discuss them here.

See [Tutorial] Reporting bugs or suggestions
AOO 4 • Linux • Fedora 17
User avatar
acknak
Moderator
 
Posts: 17403
Joined: Mon Oct 08, 2007 1:25 am
Location: USA:NJ:E3

Re: Document opened in read-only mode

Postby c1p1 » Thu Apr 21, 2011 3:50 am

solved.... here ---> http://c1p1.wordpress.com/2011/04/21/solved-document-opened-in-read-only-mode/ :D
Wabbit wrote:"Document opened in read-only mode"
The "document" is a 65 page workbook which is my weekly accounts, I'm on page 38 and it was fine when I used it the other day. now it's telling me that I've opened it in read only mode. It's not a protected document as this is my home PC and I'm the only one that uses it (I live alone). I've found that if I open the workbook and "save as", the new saved document is fine. But there must be a simple way of correcting this.

Win xp pro
Open office version 221

Thanks in advance
OpenOffice 3.1 on Windows 7
User avatar
c1p1
 
Posts: 1
Joined: Thu Apr 21, 2011 3:33 am

Re: Document opened in read-only mode

Postby doug0909 » Tue Jan 17, 2012 4:47 am

could you explain in English how to solve this problem with the current version of OpenOffice in Windows 7? Thanks...
Open Office 3.3 on Windows 7
doug0909
 
Posts: 9
Joined: Tue Jan 17, 2012 3:16 am

Re: Document opened in read-only mode

Postby kingfisher » Tue Jan 17, 2012 12:23 pm

Over some 7 years I have never experienced this problem. When a document is opened a 'lock' file is created. If the lock file is still there after you close the file, delete it.

You can also check the menu selection (for Calc, other apps probably the same) File > Properties > [tab] Security > 'Open file read-only' which should NOT be selected if you want to edit the file.

Another possibility is to change the file permissions using your file manager or some such tool. I am not familiar with Windows 7.
OpenOffice 3.3 on PCLinuxOS. There are 3 kinds of people: those who can count and those who can't.
User avatar
kingfisher
Volunteer
 
Posts: 1861
Joined: Tue Nov 20, 2007 10:53 am

Re: Document opened in read-only mode

Postby Hagar Delest » Tue Jan 17, 2012 1:54 pm

For the record, double posting with: [Issue] 3.3.0 - "Read-only" when saved in .doc + password. Please don't multi-post, especially if your problem is not exactly the same (for the other topic for example, except if you're talking about password protected files exported in .doc).
AOO 4.0.1 on Windows 7 and Xubuntu 14.04 (Trusty Tahr)
User avatar
Hagar Delest
Moderator
 
Posts: 25090
Joined: Sun Oct 07, 2007 9:07 pm
Location: France


Return to Calc

Who is online

Users browsing this forum: No registered users and 29 guests