[Solved] At long last "Locked by Unknown User"

Discuss the spreadsheet application

[Solved] At long last "Locked by Unknown User"

Postby THEBookMan » Fri Nov 23, 2018 9:01 pm

Just before TG, I upgraded to OO 4.1.6.
Since then I have tried to open writer, calc and base docs that are on my 'puter.
All open w/ message "Locked be Unknown User" and options to open copy, cancel or open, read only.
Files will open, but all attempts to unlock using my PW, copy and paste,rename, delete, reboot, & etc result in another file that is "LOCKED by Unknown User".
As suggested, I looked for ".lock"in that directory and did not find one.

I will do an antivirus scan right now, but doubt that it will find anything.

Please help as I have many large files that are critical to my education.

Thanks in advance,
⌡im
Last edited by THEBookMan on Thu Feb 28, 2019 10:53 pm, edited 6 times in total.
Open Office 4.1.3 Win 10
THEBookMan
 
Posts: 79
Joined: Wed Sep 30, 2015 10:03 pm
Location: GB, WI (some sort of sport team lives around here)

Re: "Locked by Unknown User" after upgrade to 4.1.6

Postby RoryOF » Fri Nov 23, 2018 9:21 pm

When you looked for the .lock file, had you enabled "viewing of system and hidden files" (words to that effect)?

 Edit: Almost certainly the problem is due to a (hidden) lock file not yet found 
Apache OpenOffice 4.1.6 on Xubuntu 18.04.2 (mostly 64 bit version) and very infrequently on Win2K/XP
User avatar
RoryOF
Moderator
 
Posts: 28402
Joined: Sat Jan 31, 2009 9:30 pm
Location: Ireland

Re: "Locked by Unknown User" after upgrade to 4.1.6

Postby THEBookMan » Sat Nov 24, 2018 8:01 pm

Whole folder was affected.
Created new folder.
Moved everything to new folder.
Deleted the original folder

FIXED!
(Never did find ".lock" file anywhere?)

TNX
Open Office 4.1.3 Win 10
THEBookMan
 
Posts: 79
Joined: Wed Sep 30, 2015 10:03 pm
Location: GB, WI (some sort of sport team lives around here)

Re: [SOLVED] "Locked by Unknown User" after upgrade to 4.1.6

Postby THEBookMan » Sat Nov 24, 2018 8:09 pm

Here is the file that showed up in the new folder:
.~lock (file name) .ods#

Was not active (?) in new folder.
Deleted and everything is back to normal

TNX Rory!
Open Office 4.1.3 Win 10
THEBookMan
 
Posts: 79
Joined: Wed Sep 30, 2015 10:03 pm
Location: GB, WI (some sort of sport team lives around here)

Re: [SOLVED] "Locked by Unknown User" after upgrade to 4.1.6

Postby RoryOF » Sat Nov 24, 2018 10:33 pm

In any folder from which one opens an OpenOffice file, there will be generated such a lock file. These are hidden housekeeping files; their purpose is to prevent multiple write accesses to the file, as can sometimes happen in environments where there is shared access to the file. Normally these lock files are deleted when a file is closed, but can remain after an abnormal closure, such as a program or computer crash. In the event that such a file remains, it will only permit the main file be opened "read-only"; They can be deleted without problem _ONLY_ when OpenOffice is closed, to restore full read/write access to the main file. There can also be another lock file - for purposes I have not enquired into - in the root of the OO User Profile.
Apache OpenOffice 4.1.6 on Xubuntu 18.04.2 (mostly 64 bit version) and very infrequently on Win2K/XP
User avatar
RoryOF
Moderator
 
Posts: 28402
Joined: Sat Jan 31, 2009 9:30 pm
Location: Ireland

Re: [SOLVED] "Locked by Unknown User" after upgrade to 4.1.6

Postby Villeroy » Sat Nov 24, 2018 11:05 pm

This happens when you don't save your work and shut down the program before upgrading.
Please, edit this topic's initial post and add "[Solved]" to the subject line if your problem has been solved.
Ubuntu 18.04, OpenOffice 4.x & LibreOffice 6.x
User avatar
Villeroy
Volunteer
 
Posts: 26392
Joined: Mon Oct 08, 2007 1:35 am
Location: Germany

Re: [Partially SOLVED] "Locked by Unknown User"

Postby THEBookMan » Thu Nov 29, 2018 3:54 pm

RoryOF wrote:In any folder from which one opens an OpenOffice file, there will be generated such a lock file. These are hidden housekeeping files; their purpose is to prevent multiple write accesses to the file, as can sometimes happen in environments where there is shared access to the file. Normally these lock files are deleted when a file is closed, but can remain after an abnormal closure, such as a program or computer crash. In the event that such a file remains, it will only permit the main file be opened "read-only"; They can be deleted without problem _ONLY_ when OpenOffice is closed, to restore full read/write access to the main file. There can also be another lock file - for purposes I have not enquired into - in the root of the OO User Profile.


Where to find "Profile" folder"?
Hunted for "LOCK" file (all OO closed) and not found.
Copying to a new folder worked for some OO files, but not all.

Thanks, again
⌡im
Open Office 4.1.3 Win 10
THEBookMan
 
Posts: 79
Joined: Wed Sep 30, 2015 10:03 pm
Location: GB, WI (some sort of sport team lives around here)

Re: [SOLVED] "Locked by Unknown User" after upgrade to 4.1.6

Postby THEBookMan » Thu Nov 29, 2018 4:41 pm

Found (after closing OO SS) and deleting 5 of them.

Problem persists....... DAMN

⌡im
Open Office 4.1.3 Win 10
THEBookMan
 
Posts: 79
Joined: Wed Sep 30, 2015 10:03 pm
Location: GB, WI (some sort of sport team lives around here)

Re: [SOLVED] "Locked by Unknown User" after upgrade to 4.1.6

Postby RoryOF » Thu Nov 29, 2018 5:01 pm

If the lock files are being left after you use OpenOffice, there is probably some error in your method of working, particularly your method of closing a file and/or OpenOffice - often an over hasty closedown of the computer before internal housekeepiing is complete.

To find the User Profile, as your Forum .sig says you are using Windows close OpenOffice and the Quickstarter. Open File Explorer. Copy and paste %appdata%\OpenOffice\4 in the File Explorer (sometimes called Windows Explorer) Address Bar and press Enter. Rename the "user" folder - "user.old" is a good choice. Start OpenOffice.
Apache OpenOffice 4.1.6 on Xubuntu 18.04.2 (mostly 64 bit version) and very infrequently on Win2K/XP
User avatar
RoryOF
Moderator
 
Posts: 28402
Joined: Sat Jan 31, 2009 9:30 pm
Location: Ireland

Re: [NOT SOLVED] "Locked by Unknown User" after upgrade to 4

Postby THEBookMan » Thu Feb 21, 2019 4:27 pm

Once again I can't get into any CALC file:
D/L & installed clean copy of OO from Source Forge
Hunted and deled all files ; .~locked Locked (in OO folder)
All folder properties set to show hidden files
User renamed "user.old"

CALC still comes up as "locked by unknown user.

Created new file - went to copy info from original
closed both
opened new file - "Locked by unknown user.

Anyone want access to my 'puter to hunt around and see what the hell is going on?

⌡im
Open Office 4.1.3 Win 10
THEBookMan
 
Posts: 79
Joined: Wed Sep 30, 2015 10:03 pm
Location: GB, WI (some sort of sport team lives around here)

Re: [NOT SOLVED] "Locked by Unknown User" after upgrade to 4

Postby RoryOF » Thu Feb 21, 2019 4:36 pm

This is an outside chance: if you have deleted all the lock files you found, and _at the same time_ renamed the User folder to user.old1 (or something), start TaskManager (Ctrl Shift Esc) and kill any "soffice" processes shown in TM's tabs (note the initial "s" in soffice). Then start OO.

Almost certainly this is caused by some over-hastiness on your part in closing OO and then your computer.
Apache OpenOffice 4.1.6 on Xubuntu 18.04.2 (mostly 64 bit version) and very infrequently on Win2K/XP
User avatar
RoryOF
Moderator
 
Posts: 28402
Joined: Sat Jan 31, 2009 9:30 pm
Location: Ireland

Re: [NOT SOLVED] "Locked by Unknown User" after upgrade to 4

Postby THEBookMan » Thu Feb 21, 2019 5:11 pm

No "soffice" process in TM.

Please define "overhastiness"
I always save, then close.....

TNX for patience
⌡im
Open Office 4.1.3 Win 10
THEBookMan
 
Posts: 79
Joined: Wed Sep 30, 2015 10:03 pm
Location: GB, WI (some sort of sport team lives around here)

Re: [NOT SOLVED] "Locked by Unknown User" after upgrade to 4

Postby RoryOF » Thu Feb 21, 2019 5:23 pm

One should go through the formal computer Shut Down procedure and then wait some few seconds for disk activity to cease before powering off or closing a laptop lid.

This is a frequent cause of locked file or corrupt file problems.
Apache OpenOffice 4.1.6 on Xubuntu 18.04.2 (mostly 64 bit version) and very infrequently on Win2K/XP
User avatar
RoryOF
Moderator
 
Posts: 28402
Joined: Sat Jan 31, 2009 9:30 pm
Location: Ireland

Re: [NOT SOLVED] "Locked by Unknown User" after upgrade to 4

Postby THEBookMan » Thu Feb 21, 2019 5:47 pm

Will reboot now.

Renamed User -> user.old1
reboot
opened e-mail ss (read only)
created new SS (opened ready for add...)
closed both
opened as "read only

GGGRRRRRRR!!!!!
⌡im
Open Office 4.1.3 Win 10
THEBookMan
 
Posts: 79
Joined: Wed Sep 30, 2015 10:03 pm
Location: GB, WI (some sort of sport team lives around here)

Re: [NOT SOLVED] "Locked by Unknown User" after upgrade to 4

Postby Bill » Thu Feb 21, 2019 8:44 pm

There have been several reports of different ransomware protection programs causing this problem.
AOO 4.1.6 and LO 6.2.0.3 on Manjaro MATE
Bill
Volunteer
 
Posts: 7142
Joined: Sat Nov 24, 2007 6:48 am

Re: [NOT SOLVED] "Locked by Unknown User" after upgrade to 4

Postby RoryOF » Thu Feb 21, 2019 10:17 pm

THEBookMan wrote:Will reboot now.

Renamed User -> user.old1
reboot
opened e-mail ss (read only)
created new SS (opened ready for add...)
closed both
opened as "read only

GGGRRRRRRR!!!!!
⌡im


Thus time, use Save As and navigate to your desktop before Saving. If it Saves/opens there, then the problem is a permissions problem.

Windows 10? - A Windows Defender problem? Perhaps a Win10 user would comment?
Apache OpenOffice 4.1.6 on Xubuntu 18.04.2 (mostly 64 bit version) and very infrequently on Win2K/XP
User avatar
RoryOF
Moderator
 
Posts: 28402
Joined: Sat Jan 31, 2009 9:30 pm
Location: Ireland

Re: "Locked by Unknown User" after upgrade to 4.1.6

Postby THEBookMan » Fri Feb 22, 2019 6:33 pm

Will try and report back here.

Biggest reason I'm bugging you is that this is my main business file.
I have bee out of business for several days.

TNX,
⌡im [THE BookMan]
920.265.5966
Open Office 4.1.3 Win 10
THEBookMan
 
Posts: 79
Joined: Wed Sep 30, 2015 10:03 pm
Location: GB, WI (some sort of sport team lives around here)

Re: "Locked by Unknown User" after upgrade to 4.1.6

Postby John_Ha » Fri Feb 22, 2019 7:09 pm

Are you using Bitdefender Ransomware Protection? See Re: Locked for editing by unknown user which says:

I finally found the issue, it was Bitdefender Ransomware Protection.

Even if all the OpenOffice applications are in trusted applications, the problem still happens.

With this switched off, all open document files open fine.

Whether you are or are not, do the following test.

1. Reboot your PC in Safe Mode (Google for how).

Is it now OK? If so it is one of the programs which are started when Windows starts which is causing the problem.
AOO 4.1.6, Windows 7 Home 64 bit

See the Writer Manual, the Writer FAQ, the Writer Tutorials and the Writer guide.

Remember: Always save your Writer files as .odt files. - see here for the many reasons why.
John_Ha
Volunteer
 
Posts: 6456
Joined: Fri Sep 18, 2009 5:51 pm
Location: UK

Re: "Locked by Unknown User" after upgrade to 4.1.6

Postby THEBookMan » Fri Feb 22, 2019 9:24 pm

rebooted into "SAFE MODE"
Everything opens in OO CALC correctly, able to add, delete, save, etc
No "bit defender" on computer.
Using AVAST (Have for years)

How to determine which program is causing the problem?

TNX, as always
⌡im [THE BookMan]
920.265.5966
Open Office 4.1.3 Win 10
THEBookMan
 
Posts: 79
Joined: Wed Sep 30, 2015 10:03 pm
Location: GB, WI (some sort of sport team lives around here)

Re: "Locked by Unknown User" after upgrade to 4.1.6

Postby RoryOF » Fri Feb 22, 2019 9:44 pm

Try disabling Avast and running in Windows normal mode. If OO runs OK and Saves and reopens, then Avast settings are the problem.
Apache OpenOffice 4.1.6 on Xubuntu 18.04.2 (mostly 64 bit version) and very infrequently on Win2K/XP
User avatar
RoryOF
Moderator
 
Posts: 28402
Joined: Sat Jan 31, 2009 9:30 pm
Location: Ireland

Re: "Locked by Unknown User" after upgrade to 4.1.6

Postby John_Ha » Sat Feb 23, 2019 12:12 am

Install CCleaner. Go Tools > Startup > Windows ..., to list the programs. Disable half of them and reboot. Does it still do it? Repeat until you find the culprit.

When you do please post what was causing the problem so we can advise others with the same problem.
Attachments
Clipboard01.gif
AOO 4.1.6, Windows 7 Home 64 bit

See the Writer Manual, the Writer FAQ, the Writer Tutorials and the Writer guide.

Remember: Always save your Writer files as .odt files. - see here for the many reasons why.
John_Ha
Volunteer
 
Posts: 6456
Joined: Fri Sep 18, 2009 5:51 pm
Location: UK

Re: "Locked by Unknown User" after upgrade to 4.1.6

Postby RoryOF » Sat Feb 23, 2019 12:16 am

Might this be an aspect of the Windows Defender problem? (Windows Defender is part of windows 10, and is different from Bitdefender... previously mentioned)
Apache OpenOffice 4.1.6 on Xubuntu 18.04.2 (mostly 64 bit version) and very infrequently on Win2K/XP
User avatar
RoryOF
Moderator
 
Posts: 28402
Joined: Sat Jan 31, 2009 9:30 pm
Location: Ireland

Re: "Locked by Unknown User" after upgrade to 4.1.6

Postby John_Ha » Sat Feb 23, 2019 1:57 pm

RoryOF wrote:Might this be an aspect of the Windows Defender problem? (Windows Defender is part of windows 10, and is different from Bitdefender... previously mentioned)

Could be. I now call Windows 10 updates spitefulware because they do such nasty things.

I wonder if it is a deliberate policy by Microsoft to disable competitors' products?

I am not sure if you can prevent Windows Defender starting???? IF you cannot prevent it starting then check its settings to be sure it is allowing AOO full access to the PC.
AOO 4.1.6, Windows 7 Home 64 bit

See the Writer Manual, the Writer FAQ, the Writer Tutorials and the Writer guide.

Remember: Always save your Writer files as .odt files. - see here for the many reasons why.
John_Ha
Volunteer
 
Posts: 6456
Joined: Fri Sep 18, 2009 5:51 pm
Location: UK

Re: "Locked by Unknown User" after upgrade to 4.1.6

Postby Bill » Sat Feb 23, 2019 2:50 pm

THEBookMan wrote:Using AVAST (Have for years)


Avast Ransomware Shield can also cause this problem.

Re: Files locked by unknown user

For Avast Users, I discovered that the Ransomware Shield will cause this error. I've disabled mine for now, until they fix it or give us options to configure the shield behavior (ie. don't lock OO file types.). Interestingly, I can change the extension to a non-OO extension and manually open the files in OO without trouble, so it is definitely locking the file based on extension and causing havoc.
AOO 4.1.6 and LO 6.2.0.3 on Manjaro MATE
Bill
Volunteer
 
Posts: 7142
Joined: Sat Nov 24, 2007 6:48 am

Re: "Locked by Unknown User" after upgrade to 4.1.6

Postby THEBookMan » Sat Feb 23, 2019 4:51 pm

PHEWWWWwwww1

Disabled AVAST Randsomware shield and seems the problem has disappeared!

Will use throughout the day ad report back tomorrow.

Thanks to all,
⌡im [THE BookMan]
920.265.5966
Open Office 4.1.3 Win 10
THEBookMan
 
Posts: 79
Joined: Wed Sep 30, 2015 10:03 pm
Location: GB, WI (some sort of sport team lives around here)

Re: "Locked by Unknown User" after upgrade to 4.1.6

Postby RoryOF » Sat Feb 23, 2019 6:39 pm

If it is OK, you should query Avast or an Avast support Forum on suitable settings for OO (those for LibreOffice would probably be suitable also).
Apache OpenOffice 4.1.6 on Xubuntu 18.04.2 (mostly 64 bit version) and very infrequently on Win2K/XP
User avatar
RoryOF
Moderator
 
Posts: 28402
Joined: Sat Jan 31, 2009 9:30 pm
Location: Ireland

Re: "Locked by Unknown User" after upgrade to 4.1.6

Postby THEBookMan » Sat Feb 23, 2019 7:24 pm

Informed AVAST as to the problem & solution.

Will post here if they reply.

TNX again,
⌡im [THE BookMan]
920.265.5966
Open Office 4.1.3 Win 10
THEBookMan
 
Posts: 79
Joined: Wed Sep 30, 2015 10:03 pm
Location: GB, WI (some sort of sport team lives around here)

Re: "Locked by Unknown User" after upgrade to 4.1.6

Postby THEBookMan » Thu Feb 28, 2019 10:50 pm

Nothing from AVAST.
Things running as they should.

"CONTINUOUS SAVE" problem has disappeared, also.

You guys are AWSOME!
TNX, ⌡im [THE BookMan]
920.265.5966
Open Office 4.1.3 Win 10
THEBookMan
 
Posts: 79
Joined: Wed Sep 30, 2015 10:03 pm
Location: GB, WI (some sort of sport team lives around here)


Return to Calc

Who is online

Users browsing this forum: No registered users and 46 guests