[Solved] Calc keeps automatically changing my word

Discuss the spreadsheet application

[Solved] Calc keeps automatically changing my word

Postby rocketman_66 » Sun Dec 16, 2007 2:31 am

If I type a word into a Calc cell with all lowercase letters, then type the same word into another cell but I want it to start with a capital letter, Calc automatically replaces the Capital letter with a lowercase letter. Data validity is set to "All" and I removed all formatting for that cell. I guess Calc is so smart that it remembered the first all lowercase word in its selection list and it is certain that I want a word from the "selection list" so it keeps "correcting" me. How can I keep Calc from "correcting" me so I can type the word with a capital letter?
Thanks for taking the time to read this and I hope you can help.
Last edited by Hagar Delest on Tue Jun 10, 2008 3:57 pm, edited 2 times in total.
Reason: tagged the thread as Solved.
rocketman_66
 
Posts: 2
Joined: Sun Dec 16, 2007 2:18 am

Re: Calc keeps automatically changing my word

Postby rocketman_66 » Sun Dec 16, 2007 2:51 am

I think I found my answer after some more searching through the Calc options. Tools > Cell Contents > turn Autoinput off. I guess I am still used to that other spreadsheet program.
rocketman_66
 
Posts: 2
Joined: Sun Dec 16, 2007 2:18 am

Re: [Solved] Calc keeps automatically changing my word

Postby Nikos » Thu Dec 20, 2007 11:45 am

Thanx for posting the solution...had the same problem.
LibreOffice 4.0.5 on OpenSuse 12.3/64bit/KDE4.10 (Version from the TDF page) + LibreOffice 4.1.1 on Debian Wheezy/64bit/KDE4.8 + LibreOffice 4.1.1 on Win7/64bit
Nikos
 
Posts: 172
Joined: Mon Dec 17, 2007 11:50 am

Re: [Solved] Calc keeps automatically changing my word

Postby huw » Thu Dec 20, 2007 12:04 pm

If, like me, you like to work with AutoInput on, but have the occasional need to enter a repeated word with different capitalisation in a column you can type it in a different column and then copy and paste it over. AutoInput doesn't operate on clipboard data.

There's a bunch of related issues:
Cannot enter case-varying 2 letter "words" in column
AutoInput does not honour reproduce case of previous entry
Can not edit contents capitalization when AutoInput is on
AutoInput: Capital letter attribute not copied when AutoSpellCheck is on
huw
Volunteer
 
Posts: 417
Joined: Wed Nov 21, 2007 1:57 pm

Re: [Solved] Calc keeps automatically changing my word

Postby RonIA » Thu Dec 20, 2007 2:05 pm

You should also be able to put it in a macro (or record it even) to turn on or off AutoInput. Then you could assign it a keyboard shortcut or put it in one of your menus.
Ron from Iowa, USA
RonIA
Volunteer
 
Posts: 139
Joined: Mon Oct 08, 2007 1:34 am
Location: Iowa USA

Re: [Solved] Calc keeps automatically changing my word

Postby huw » Thu Dec 20, 2007 2:15 pm

You don't even need a macro. Under Tools > Customise... Keyboard choose Options in Category, and AutoInput in Function, select your shortcut of choice in the list above, and press Modify.
huw
Volunteer
 
Posts: 417
Joined: Wed Nov 21, 2007 1:57 pm

Re: [Solved] Calc keeps automatically changing my word

Postby RonIA » Thu Dec 20, 2007 2:43 pm

Thanks. Forgot this on/off behavior was a menu item therefore just had to be added to a menu / toolbar / keyboard shortcut.
Ron from Iowa, USA
RonIA
Volunteer
 
Posts: 139
Joined: Mon Oct 08, 2007 1:34 am
Location: Iowa USA


Return to Calc

Who is online

Users browsing this forum: MSN [Bot] and 20 guests