Page 1 of 1

MS-style autocorrect interference

PostPosted: Sat Dec 15, 2007 1:15 pm
by timtranslates
I'm trying to create a vertical list of the months of the year, like this:

Jan
Feb
Mar
Apr
May
etc.

The problem is, when I type in certain months, Calc autocorrects them to make them all lowercase, so I get this:

Jan
feb
mar
Apr
may
Jun
Jul
Aug
Sep
oct
nov
Dec

I'm not sure why this is happening for some months and not for others. As a workaround, I was going to make them all lower case, but lo and behold, the one's that can be written in uppercase are autocorrected to upper case! In MS Office, I could use CTRL+Z to undo autocorrects, but that doesn't seem to work in Calc.

I've looked at the autocorrect settings, and I cannot figure out why it is autocorrecting "Feb" to "feb". Can anyone shed any light?

Tim

Re: MS-style autocorrect interference

PostPosted: Sat Dec 15, 2007 2:14 pm
by Villeroy
Never mind. It's just one of those bugs. Put the following formula into the first cell and drag down.
=TEXT(DATE(0;ROW($A1);1);"MMM")

Re: MS-style autocorrect interference

PostPosted: Sat Dec 15, 2007 2:20 pm
by timtranslates
Thanks for the solution (I thought there must be some kind of automated method). Only problem is, in this particularly case I actually want two lines for each month, so my list should be:

Jan

Feb

Mar

Apr

etc

If I use your formula, I get "Mar" where I want "Feb". Any automated way of doing this?

Re: MS-style autocorrect interference

PostPosted: Sat Dec 15, 2007 2:53 pm
by Villeroy
=IF(MOD(ROW($A1);2);TEXT(DATE(0;CEILING(ROW($A1)+1;1)/2;1);"MMM");"")