[Solved] File Owner

Discuss the spreadsheet application

[Solved] File Owner

Postby RonOO » Fri Jun 02, 2017 6:36 am

I have been using Calc since forever. However I tried to open an existing Spreadsheet but got the error message "You don't have permission to open this File. Contact the file owner or an administrator ro obtain permission"
Is this an Owner under Windows 10 or Openoffice?
I recently added a new user name for me without Administrator priveileges because I kept getting W10 messages about not being able to open Apps as Administrator.
This seems to have caused the problem.
I have used both user names when logging on and all my most recent files open correctlly under either user, escept for one (sofar) that will not open under either user.
I have added Owner to Explorer filelister and can see lots of files signed as "Administrators" and some with my Admin Username. I amy have changed my Administrator name also. Some also show an old username.
I am a user since before Microsoft started but I cannot understand Users in W10. I have always been the only user/administrator.
Any suggestions. Is it OpenOffice or W10!
Cheers,
Ron
Last edited by RoryOF on Sun Jun 04, 2017 9:00 am, edited 2 times in total.
Reason: Added green tick [RoryOF, Moderator]
OpenOffice 4.1.1
Windows 10
RonOO
 
Posts: 2
Joined: Fri Jun 02, 2017 6:22 am

Re: File Owner

Postby John_Ha » Fri Jun 02, 2017 11:52 am

Welcome to the forum.

1 Is the file from another PC? If so, it might be Blocked. right-click it > Properties > General ..., and Unblock it.

2 Is the file still attached to an email? Detach and save it before editing it.

3 right-click the file > Properties > General ... Is it Read Only?

4 right-click the file > Properties > Security ... Do you have the permission to edit it?

5 Open the file with Calc. File > Properties > Security. Is it set to Read Only? Has Tools > Protect Document been set?

6 Make a copy of the file. Does the copy open OK?

7 Open the file with Calc. Edit > Select ALL. Edit Copy. Paste into a new document. Can you do the copy? Does the new document work OK?

If this solves the problem, please view your first post in this thread and click the Edit button (top right in the post) and add [Solved] in front of the subject.

If you upload the document here someone will look at it. Use the Upload attachment tab below where you type - 128 kB max here or use a file share site.
AOO 4.1.6, Windows 7 Home 64 bit

See the Writer Manual, the Writer FAQ, the Writer Tutorials and the Writer guide.

Remember: Always save your Writer files as .odt files. - see here for the many reasons why.
John_Ha
Volunteer
 
Posts: 6326
Joined: Fri Sep 18, 2009 5:51 pm
Location: UK

Re: File Owner

Postby Villeroy » Fri Jun 02, 2017 1:42 pm

Every single file under "My Files" should be owned by you, the logged-in user and by nobody else.
Log-in as admin and pass over the ownership of all your files to your regular user account.
Same with %APPDATA% where typical open source applications (Firefox, Thunderbird, OpenOffice) store user data (settings, bookmarks, preferences, templates, emails etc).
Please, edit this topic's initial post and add "[Solved]" to the subject line if your problem has been solved.
Ubuntu 18.04, OpenOffice 4.x & LibreOffice 6.x
User avatar
Villeroy
Volunteer
 
Posts: 26249
Joined: Mon Oct 08, 2007 1:35 am
Location: Germany

Re: File Owner

Postby RonOO » Sun Jun 04, 2017 8:03 am

Hi Folks,
In looking at Owners of many files I was able to detect my previous Username and change back to it.
I have been able to open the locked files with:
Properties/Security/Advanced/Continue/Enable Inheritance
After then opening the file in Calc and closing it the Owner is shown as Administrators.
Now it is up to me to research W10 owners more fully and see how tey work and ensure I do not get into trouble again.
It just shows that you can exist for years and never come across these problems.
I have always find W10 help particularly obscure.
Thanks,
Ron
OpenOffice 4.1.1
Windows 10
RonOO
 
Posts: 2
Joined: Fri Jun 02, 2017 6:22 am

Re: [Solved] File Owner

Postby lmo46 » Wed Jan 16, 2019 7:58 pm

Okay, so Like I said, it only happens sometimes, and today it did it again. On the error message received, I clicked on the link and then clicked on "everyone' and said "remove", and now it works. Don't know why, don't know if this make sense, but it worked for me! (???)
open office 4.1.6 running on windows 10
lmo46
 
Posts: 6
Joined: Wed Jan 09, 2019 10:32 pm


Return to Calc

Who is online

Users browsing this forum: lhentz and 23 guests