Page 5 of 5

Re: Bad allocation ; etc. ~ success

PostPosted: Tue Dec 25, 2018 2:13 am
by FWS
no2ms2007 wrote:I also was getting Fatal Error, Vector <T> too long.
This also happened every time on entering '=' and then switching to another sheet (in the same workbook) to select my cell. The failure happened at this point. The sheet I tried to switch to also had links from yet another sheet in the same workbook. I read this post and followed the advice to reset my user profile. I also changed the sheet names as they previously had spaces, and replaced the spaces with underscores. The problem has now gone away. I can't advise which of the two steps (or maybe both) resolved it for me.

Windows 7 Professional
Office 4.1.0

I founded strange solution.
In my company using Teamviewer v.11. And Teamviewer is always running.
When main Teamviewer is loaded "Bad allocation" and "Vektor <T>", reproduces without probles, as described later.
In a multipage document, enter “=” and try to switch the page to indicate any cell, OO crashes after selecting the page.
When Teamviewer is not loaded, nothing happens. I think TeamViewer intercepts some user level APIs and inserts a delay that disrupts synchronization between OO threads.

Another one observation: with the default profile, OO is less likely to crash. But if I reconfigure keyboard shortcuts, memory options, and other calc parameters, the probability of failure will be higher. This suggests that problems may be localized in space of keyboard hooks, that Teamviewer makes.

Re: Bad allocation ; etc.

PostPosted: Thu Dec 27, 2018 1:50 am
by FWS
Crashes continue. Was able to reproduce the crash on a regular basis.
The cause of the crashes is in its file "registrymodifications.xcu".
Deleting all files in %userprofile%\AppData\Roaming\OpenOffice\4\user\ fixes the problem.
But restore one file "registrymodifications.xcu", returns the problem to its place.

Re: Bad allocation ; etc.

PostPosted: Thu Dec 27, 2018 2:55 am
by FWS
May be [solved].
By dividing the "registrymodification.scu" file into halves on each cycle and leaving only the part where the failure occurs, I selected one parameter:
<item oor:path="/org.openoffice.VCL/Settings/org.openoffice.VCL:ConfigurableSettings['Accessibility']"><prop oor:name="EnableATToolSupport" oor:op="fuse" oor:type="xs:string"><value>true</value></prop></item>

If this parameter is "true", my openoffice 100% crushing, if "false" all ok.
"Support assistive technology tools (program restart required)" must be switched off.

More details:

Re: Bad allocation ; VECTOR T crash

PostPosted: Sun Jan 27, 2019 2:50 am
by timjeanes
I am now continuing to get this crash every time I try and create a formula where I need to extrapolate data from another sheet.
This has now gone beyond a joke and so many hours have gone into designing 5 Sheets with data that are all depended upon each other.

Re: Bad allocation ; etc.

PostPosted: Sun Jan 27, 2019 5:51 pm
by timjeanes
Further to the crash issue refers.

The only way I found around this is to save your worksheet as a different name and then reopen it under it's new file name and it works fine.
I appreciate that there is a glitch with the program which needs to be addressed and rectified by the Developers and by doing what i have may only work for a while. It will be unacceptable to have to continually having to save it under different names periodically.

Re: Bad allocation ; etc.

PostPosted: Wed Mar 06, 2019 5:16 pm
by John_Ha
Searching this forum with Vector<T> too long gets these results where a number of possible causes and workarounds are suggested. When a Vector<T> too long error is received it appears at other times as Bad allocation suggesting they are linked.

It seems that

1. The problem may be user data induced. eg how have you configured your spreadsheet formulae? your Auto Input? or Data Validity?

2. It may be AOO/LO configuration dependent - ie what options have you chosen in Tools > Options ...? what does registrymodifications.xcu contain?

3. Google shows that many other programs (Notepad++, AutoDesk etc) get the same error so it is not just AOO or LO

4. It could be an AOO/LO code error. It could be the code is working normally but the user doing something forbidden which causes the problem.

5. Other programs (eg TeamViewer) seem to interfere with AOO and cause it. Starting in Safe Mode prevents the problem.

6. Researching the error message suggests that it "often seems to be something to do with an equals sign (or possibly a sequence of equals) being misinterpreted in the underlying C++ code". This ties in with the method to reproduce: type an = in a cell, and then click another Sheet Name; and it's random (and does it with some cells and not with others??); and also with Ziz64's analysis of what Auto Input and Data Validity are expecting.

In summary, it is very difficult to track down exactly what is causing it.

Re: Bad allocation ; etc.

PostPosted: Tue Mar 26, 2019 1:50 pm
by Richard of Elmley
I am experiencing the same problem, several times a day. I am running on a new computer HP Envy with Windows 10, bought a week ago. The new download of OpenOffice is Version 4.1.6. My previous machine running Windows 7 Professional had a disc failure and I retrieved my files from a back-up. I had never experienced this problem on the old machine, which was using an earlier Version 4 download from Apache. The Vector <T> error occurs if I try to move to a different sheet when entering/editing a cell entry. I seem to be able to type the name in without triggering the error. The bad allocation error appear to be random. Both are fatal with the results described by others.

Is there any prospect of a solution? It appears from other posts that the problem has been extant for some time, and that suggestions made have had no success.

Re: Bad allocation ; etc.

PostPosted: Wed Mar 27, 2019 12:04 pm
by timjeanes
As this problem has been ongoing now for an unreasonable period of time the frustration thereof will result in many changing to other Software suppliers who offer a workable alternative.

Re: Bad allocation ; etc.

PostPosted: Wed Mar 27, 2019 12:25 pm
by John_Ha
Richard of Elmley wrote:I am experiencing the same problem, several times a day...The Vector <T> error occurs if I try to move to a different sheet when entering/editing a cell entry. I seem to be able to type the name in without triggering the error. The bad allocation error appear to be random. Both are fatal with the results described by others.

Try disabling Support Assistive Technology Tools.

1. Tools > Options > OpenOffice > Accessibility. Untick Support Assistive Technology Tools

2. Restart AOO.

Does that fix it?


This can also be done by directly editing registrymodifications.xcu as described in FWS' post above. If you have done it by Tools > Options ..., above you don't need to do this as well!!

1. Stop AOO
2. Open C:\Users\xxxxxx\AppData\Roaming\OpenOffice\4\user\registrymodifications.xcu with an editor like Notepad or Notepad++
3. Search for <item oor:path="/org.openoffice.VCL/Settings/org.openoffice.VCL:ConfigurableSettings['Accessibility']"><prop oor:name="EnableATToolSupport" oor:op="fuse" oor:type="xs:string"><value>true</value></prop></item>
4. Replace true by false.
5. Start AOO.

It seems that Windows 10 has made significant changes to Assistive Technology Tools which may be the cause of the problem - see Windows 10 Free Upgrade | Assistive Technology 2019

For more AOO details see Accessibility Options Dialog

Re: Bad allocation ; etc.

PostPosted: Wed Sep 04, 2019 12:54 pm
by Richard of Elmley
I have tried both suggestions. The problem is that neither method actually makes the change and when I reopen the document the support assistive etc box remains ticked, similarly the value in the registrymodifications has reverted to true although immediately after making the change to false the file has indeed been modified the reversion occurs when or after reopening a document.