Bad allocation ; etc.

Discuss the spreadsheet application

Re: Bad allocation ; etc.

Postby Alex1 » Sun Dec 21, 2014 3:55 pm

You can install them on the same computer and use them together. What doesn't work is copying and pasting cells in Calc from one program into the other program. The last one (re)installed will get the file types assigned.
AOO 4.1.5 & LO 5.0.6 on Windows XP & 7
Alex1
Volunteer
 
Posts: 603
Joined: Fri Feb 26, 2010 1:00 pm
Location: Netherlands

Re: Bad allocation ; etc.

Postby ptoye » Sun Dec 21, 2014 5:00 pm

Well, all programs give problems. That's life. Unless I've written them, of course....

AOO and LO are fine together. The only thing to remember is that you can have only one default file opener for any file type, but that's pretty obvious.

I don't know how transferable the file formats are, though. Maybe someone else here knows. I would guess that it'll be OK (possibly ish) until one branch includes a feature that the other one doesn't.
Peter
OO 4.1.1 on MS Windows 7 64-bit
ptoye
 
Posts: 225
Joined: Mon Apr 21, 2008 11:07 am
Location: Reading, England

Re: Bad allocation ; etc.

Postby thomasjk » Sun Dec 21, 2014 5:41 pm

File formats are interchangeable between AOO and LO.
Tom K.
Windows 10 Home version 1803 17134.165
LibreOffice 5.4.7.2
thomasjk
Volunteer
 
Posts: 4373
Joined: Tue Dec 25, 2007 4:52 pm
Location: North Carolina

Re: Bad allocation ; etc.

Postby ptoye » Sun Dec 21, 2014 5:51 pm

That's good to know. Thanks.
Peter
OO 4.1.1 on MS Windows 7 64-bit
ptoye
 
Posts: 225
Joined: Mon Apr 21, 2008 11:07 am
Location: Reading, England

Re: Bad allocation ; etc.

Postby Ted X Asperay » Sat Jan 24, 2015 6:43 pm

I can say that I have installed Libre Office, and a quick check shows the error in referencing other worksheets has stopped. So far.
I'll have to wait a few weeks to find out if this is a false dawn.
:? Oddly I notice that the positioning of some graphic draw objects (viz, all the graphic lines & arrows) has been lost in reopening the worksheet in Libre(.ods to .ods format).
I then made some minor entries and changes using Libre and resaved.
On reopening in Apache OO, the position of the arrows was once again disturbed.
I try to avoid graphic objects in spreadsheets, but I find arrow, lines and text boxes invaluable.
Text boxes seem to have stayed more or less where they were.

Perhaps I need to check what features I have enabled?
Apache OpenOffice 4.1.1 on Windows 7 SP1 64bit
Libre OO 4.2.8.2
Ted X Asperay
 
Posts: 28
Joined: Sat Feb 04, 2012 5:40 pm

Re: Bad allocation ; etc.

Postby ptoye » Sat Jan 24, 2015 9:01 pm

Is it worth while opening another thread for this? Sounds like the sort of incompatibility bug that has Microsoft laughing all the way to the bank.
Peter
OO 4.1.1 on MS Windows 7 64-bit
ptoye
 
Posts: 225
Joined: Mon Apr 21, 2008 11:07 am
Location: Reading, England

Re: Bad allocation ; etc.

Postby Ted X Asperay » Mon Jan 26, 2015 8:21 pm

Yeh , you're right, since after one or two more successive resavings between Libre & Apache the arrows disappeared altogether.
[also I had a complete & utter system freeze-crash not long after this - perhaps coincidentally within hours of installing libre - had to Restore system and reinstall Libre again. But all seems well now, but i'm just monitoring everything before opening any new forums..!]
Apache OpenOffice 4.1.1 on Windows 7 SP1 64bit
Libre OO 4.2.8.2
Ted X Asperay
 
Posts: 28
Joined: Sat Feb 04, 2012 5:40 pm

Re: Bad allocation ; etc.

Postby ptoye » Mon Jan 26, 2015 9:19 pm

Yuk!
Peter
OO 4.1.1 on MS Windows 7 64-bit
ptoye
 
Posts: 225
Joined: Mon Apr 21, 2008 11:07 am
Location: Reading, England

Re: Bad allocation ; etc.

Postby Ted X Asperay » Wed Jan 28, 2015 4:05 am

Switch to Libre Office to solve issue -PROGRESS REPORT - 4th day
Apart from the line graphics issue mentioned, everything working better than ever.
One unexpected side effect is that - for the present anyway - the issue is no longer presented in Apache Open Office Calc either!
Anyone else using this solution found this?

I'm using both AOO & Libre during his test period, though mainly Libre for the more complex spreadsheets.
Apache OpenOffice 4.1.1 on Windows 7 SP1 64bit
Libre OO 4.2.8.2
Ted X Asperay
 
Posts: 28
Joined: Sat Feb 04, 2012 5:40 pm

Re: Bad allocation ; etc.

Postby ptoye » Wed Jan 28, 2015 11:14 am

I have found that in AOO, following the crash and a recovery, the crash doesn't happen. But then it reappears the next time I open the spreadsheet.

That's why I think it's an AOO bug rather than a rogue driver. Looks like something isn't being initialised properly the first time. I've not tried (and don't have time today) to save it in LO and reopen in AOO.
Peter
OO 4.1.1 on MS Windows 7 64-bit
ptoye
 
Posts: 225
Joined: Mon Apr 21, 2008 11:07 am
Location: Reading, England

Re: Bad allocation ; etc.

Postby Ted X Asperay » Wed Jan 28, 2015 1:10 pm

Yes, I just tried this. After a couple of saves, AOO crashes with this old error again, when referencing other sheets.
After recovering the file with AOO, I opened it in Libre, and it's OK again.

False dawns can last 3 or 4 weeks, so I'm not saying "Solved" yet. Anyway, this is more a workaround than a solution.
Still got my arrows all over the place!
Apache OpenOffice 4.1.1 on Windows 7 SP1 64bit
Libre OO 4.2.8.2
Ted X Asperay
 
Posts: 28
Joined: Sat Feb 04, 2012 5:40 pm

Re: Bad allocation ; etc.

Postby ptoye » Mon Feb 23, 2015 6:30 pm

I've just had a crash from a different part of Calc - the OOBasic macro editor which has the same symptoms in that following a recovery it works until the next time I reopen the document. I posted it as a separate problem in https://forum.openoffice.org/en/forum/v ... 20&t=75578 but they may be related.
Peter
OO 4.1.1 on MS Windows 7 64-bit
ptoye
 
Posts: 225
Joined: Mon Apr 21, 2008 11:07 am
Location: Reading, England

Re: Bad allocation ; etc.

Postby Ted X Asperay » Tue Feb 24, 2015 2:14 am

UPDATE: So far now, using Libre Office on pre-exisiting AOO Calc sheets, I can say that I have no problems with this error , in referencing cells on different sheets, nor any other appearance of this sort of crash error.
This essentially workaround solution seems to work then. Can't mark this solved for AOO therefore.

However Libre office Calc is not without its problems, and does crash in its own way from time to time, but not as often, and there's the annoying disruption of drawn lines & arrows when converting, which I will raise in another Board.

On balance however, I think I will be slowly moving over to Libre Calc, and for everything else use AOO .
Apache OpenOffice 4.1.1 on Windows 7 SP1 64bit
Libre OO 4.2.8.2
Ted X Asperay
 
Posts: 28
Joined: Sat Feb 04, 2012 5:40 pm

Re: Bad allocation ; etc.

Postby ptoye » Tue Feb 24, 2015 10:46 am

I've not tried LO Calc in anger - just tried it out when AOO crashed. Have you been reporting the LO crashes to their support team? And were they helpful?
Peter
OO 4.1.1 on MS Windows 7 64-bit
ptoye
 
Posts: 225
Joined: Mon Apr 21, 2008 11:07 am
Location: Reading, England

Re: Bad allocation ; etc.

Postby bryan1001 » Mon Mar 30, 2015 3:25 pm

I have had 11 crashes the last 1,5 hours.. All bad allocation. I have tried everything here, but i cannot safe any work after deleting a tab or after deleting a large ammount of data (or copying) never had this hassle before, so what is going on? It's driving me insane. :knock:
open office 3.1.1 on windows 7
bryan1001
 
Posts: 2
Joined: Mon Mar 30, 2015 3:09 pm

Re: Bad allocation ; etc.

Postby ptoye » Mon Mar 30, 2015 5:10 pm

Have you tried Libre Office?
Peter
OO 4.1.1 on MS Windows 7 64-bit
ptoye
 
Posts: 225
Joined: Mon Apr 21, 2008 11:07 am
Location: Reading, England

Re: Bad allocation ; etc.

Postby bryan1001 » Mon Mar 30, 2015 5:13 pm

To add to my problem: Now after the crash because of bad allocation every single formulaq on the sheet has been replaced by =pagename.cell What idiocy this is i just cannot grasp. Is there a way to fix this. Is there a place i can download old versions of open office?
open office 3.1.1 on windows 7
bryan1001
 
Posts: 2
Joined: Mon Mar 30, 2015 3:09 pm

Re: Bad allocation ; etc.

Postby ptoye » Mon Mar 30, 2015 7:00 pm

Oh dear. Not a clue about old versions I'm afraid. Probably someone here knows.

I hope you have a backup.
Peter
OO 4.1.1 on MS Windows 7 64-bit
ptoye
 
Posts: 225
Joined: Mon Apr 21, 2008 11:07 am
Location: Reading, England

Re: Bad allocation ; etc.

Postby W_e-r_n-e_R » Fri Apr 17, 2015 8:17 pm

Good news: The last version where I did not notice this bug was 4.0(.1). Today, it still can be downloaded here: http://www.openoffice.org/download/index.html. You can select a different language and/or version by using the [Tab] and Arrow Keys on this webpage.

Bad news: This bug occurs (i.m.h.o.) since 4.1 no matter which OS version and/or localized Open Office binary I am using (8.1 or 7, x32 or x64; English or French or German); this relatively new bug seems somewhat fatal to Calc, because even the document recovery does not seem to remember any unsaved changes.

I would like to express my hope here, that Open Office version 5.0 Calc will be branched from 4.0 (which continues to run fine with the latest Windows releases with or without Java installed) in comparison to 4.1.
OpenOffice 4.1.1 on Windows 7 x32
Open Office 4.1.1 on Windows 8.1 x64
W_e-r_n-e_R
 
Posts: 1
Joined: Fri Apr 17, 2015 7:43 pm

Re: Bad allocation ; etc.

Postby ptoye » Sat Apr 18, 2015 5:47 pm

I don't seem to have this problem with LibreOffice. Why not try it? And report back here please.
Peter
OO 4.1.1 on MS Windows 7 64-bit
ptoye
 
Posts: 225
Joined: Mon Apr 21, 2008 11:07 am
Location: Reading, England

Re: Bad allocation ; etc.

Postby raywales » Fri May 22, 2015 7:25 am

I also experience lots of "Bad allocation" crashes in Calc with OO 4.1.1 on my Vista Business machine.
However, the problem is almost nonexistent when running OO alone.
The more applications loaded, and therefore the more going on in virtual memory, the worse Calc becomes.
Could the developers please look at OO's VM handlers - I am beginning to believe that the problem lies here.
Hope that this helps.
Ray
OpenOffice 4.1.0 on Windows Vista
raywales
 
Posts: 3
Joined: Mon Jun 09, 2014 3:45 am

Re: Bad allocation ; etc.

Postby lewg2 » Fri Aug 07, 2015 12:03 am

I've gotten similar allocation and vector error messages -- but not always -- with the following setup:
Aoo 4.1.1 on Win 8.1, HP 2-in-1 with 8gb ram and 220gb SSD

I run the macro to clean up a *.csv file imported successfully into Calc (unicode UTF-8, if that's relevant). It does basic searches, deletes rows and columns, adds columns and formulas, etc. I don't know how to code directly, so it's a series of recorded then modified steps.

The crash
The macro first goes to the top of the file and then does a simple forward search for string "trade history". That's where it crashes. Here's the code:
'REMOVE EXTRANEOUS ROWS ABOVE, BELOW RELEVANT ONES
rem ----------------------------------------------------------------------
' find trade history row, select all rows back to the top and delete them
dim args2(1) as new com.sun.star.beans.PropertyValue
args2(0).Name = "SearchItem.SearchString"
args2(0).Value = "trade history"
args2(1).Name = "SearchItem.Backward"
args2(1).Value = false
dispatcher.executeDispatch(document, ".uno:ExecuteSearch", "", 0, args2())

The file recovery
It goes immediately to window that says "unexpected error...has crashed...these files will be recovered". The spreadsheet window is gone. I have gotten the allocation and vector messages, but not always.

Then it goes to the recovery window. "Start recovery", import again succeeds.

The next macro run
And then, after the file recovery, the macro works. This is absolutely consistent. Basically I call up the file, let it crash, recover the file, and then re-run the macro to get my work done.

Today I recorded a little macro to go to the top of the file and then search for a known string. I called up/imported the file, ran the new little search macro, and it crashed. Recovered the file, re-ran the test search macro, and it works.


Note: this did not happen on my old W7 machine -- it ran flawlessly for a couple of years. But then I recently got the W8.1 machine and this starts happening. I can live with it, but....
Ubuntu 16.04
lewg2
 
Posts: 3
Joined: Thu Aug 06, 2015 10:47 pm

Re: Bad allocation ; etc.

Postby ptoye » Fri Aug 07, 2015 10:20 am

Does it do the same with LibreOffice? I've not had this problem with LO.
Peter
OO 4.1.1 on MS Windows 7 64-bit
ptoye
 
Posts: 225
Joined: Mon Apr 21, 2008 11:07 am
Location: Reading, England

Re: Bad allocation ; etc.

Postby Wmeyer52405 » Mon Aug 20, 2018 7:25 am

ok, I can make this happen ANYTIME I WISH, trust me.
I have been experiencing it for months and I assume it is a resource allocation issue.
I have a VERY VERY Large spreadsheet, nearly 100 sheets, with hundreds of cross links and tens of thousands of calculations.
I will work, but I must be careful how I use it,
If I Insert lines, or delete lines they must be done one or two at a time, no batch deletes. And for absolute certain no cut and paste of large sections,
One two maybe three cells, after that its all over.
Also if the auto save kicks in I must double click the title area to shrink the widow size from maximum to smaller then back and forth several times to make sure the save progress bar advances.
ALWAYS save often, if not after you enter a few hundred keystrokes you can start all over.
Before you ask, this is a business model for real estate investment and development to control timing and monitor activities.
OpenOffice 4.1.5 on Windows 10
Wmeyer52405
 
Posts: 3
Joined: Mon Aug 20, 2018 7:02 am

Re: Bad allocation ; etc.

Postby John_Ha » Mon Aug 20, 2018 10:42 am

A heavily edited spreadsheet probably needs to be "untangled" in the same way that a heavily edited text document does.

1. Create a new, empty spreadsheet.
2. Insert > Sheet from file. Now pull in all the sheets from your file.
3. Save the new file.

Does that improve things?
AOO 4.1.5, Windows 7 Home 64 bit

See the Writer Manual, the Writer FAQ, the Writer Tutorials and the Writer guide.

Remember: Always save your Writer files as .odt files. - see here for the many reasons why.
John_Ha
Volunteer
 
Posts: 5858
Joined: Fri Sep 18, 2009 5:51 pm
Location: UK

Re: Bad allocation ; etc.

Postby Wmeyer52405 » Wed Aug 29, 2018 4:09 am

Thanks John, I do know that, and I have done that to rescue the sheets when a crash was unavoidable every time I saved, but there are nearly 100 sheets and thousands of cross links, it would mean easily 10 hours work to re-establish this file. I think it has to do with limited resources available in windows when it encounters VAST amounts of programing.
Changing one field in the dash board sheet can effect 10,000 calculations and this puts a huge demand on software that is not robust. It is NOT a hard drive issue, it occurs on 3 different machines, also I do not believe it to be a memory issue as my PC is running 24 gig of ram, It should not be a video issue as it occurs with the majority of the sheets hidden, The sheets use no sound so it should also not be a sound device interrupt issue. It should not be a speed issue as I am running an i7 quad core processor running at over 2 gig.
So I feel it is NOT a hardware issue, it appears to be a a vector resource overflow in widows of something similar in OO,
OpenOffice 4.1.5 on Windows 10
Wmeyer52405
 
Posts: 3
Joined: Mon Aug 20, 2018 7:02 am

Re: Bad allocation ; etc.

Postby wm27704 » Wed Sep 12, 2018 1:14 am

I get this bad allocation almost every day. It shuts down all open OpenOffice windows. Then it has to restart and recover all of the open files each time. Here's how I can create the problem every time. First have 4 calc windows open with worksheets open. Then have a write window or two open with documents open. Then open another calc file and window. Close it. Open another. Close it. May have to do it another time or two and then the current calc window stops responding and the whole openoffice crashes. I need a number of files open at the same time so when the all crash and have to recover it's a big waste of time and risks corrupting my data files. Any fixes on the horizon?
Open Office 4.1.5 on Windows 10 Home version 1803
wm27704
 
Posts: 1
Joined: Wed Sep 12, 2018 1:10 am

Re: Bad allocation ; etc.

Postby Wmeyer52405 » Wed Sep 12, 2018 7:40 am

Mine will happen with just ONE file open, of course it is just under 10MB in size, and I can NEVER Save As this file because it will ALWAYS crash.
As I said I am sure this is a resource issue with either OO or with windows (I am running Win 10) as I do have a good machine to run it on.
I have never seen a publish limit to the size of files for OO or number of sheets that it will reliably handle, but sure to say it is less than 100 because that is when this started happening when I got up around 100 sheets cross linked.
OpenOffice 4.1.5 on Windows 10
Wmeyer52405
 
Posts: 3
Joined: Mon Aug 20, 2018 7:02 am

Re: Bad allocation ; etc.

Postby fng981 » Thu Oct 18, 2018 5:29 am

I have a large calc file ~ 3.6Mb, with 104 sheets and lots of formulas. When I open it on my home computer - Windows 10 Home, 64 bit, 16GB ram, it crashes every time. When I open the same file on my work computer, Windows 10 Pro, 64 bit, 16GB ram, it *never* crashes. Both machines use OO 4.1.5. I usually have eight other programs running at the same time - more on my work machine. Memory usage is around 50%. Does anyone running Windows 10 Pro have bad allocation crashes?
Open Office 4.1.5
Windows 10 Home
Windows 10 Pro
fng981
 
Posts: 1
Joined: Thu Oct 18, 2018 4:56 am

Re: Bad allocation ; etc.

Postby plcsparky » Wed Oct 24, 2018 3:28 pm

I had a similar problem may be windows security updates problems especially if you have programed a large file ( I had a program on 29 pages).
Delete windows updates back to 9th October 2018.

plcsparky
open office 4.1.5 operating on windows 10,
problem office calc hangs when i try to save
plcsparky
 
Posts: 7
Joined: Thu Sep 06, 2018 2:55 pm

Previous

Return to Calc

Who is online

Users browsing this forum: No registered users and 21 guests