[Solved] Buffer contains null in Content XML ODS file

Discuss the spreadsheet application

[Solved] Buffer contains null in Content XML ODS file

Postby nightwinter » Wed Jul 03, 2013 10:36 am

Dear Experts,

I'm newbie in here, and desperately posting this question after spending 5hours googling the answer. I have ods file that I've been used for the last 2years everyday. Somehow it can't open today, says the file is corrupt and therefore cannot be opened. The file is password protected, it's asking for password, but after entered and loaded, it comes up with that error. I've been searching for content.xml file and try to open it using Komodo Edit , it says "Buffer contains null byte(s)". Are the data in the content.xml ? How to recover this kind of error?

I've upload the file in 4shared since doesn't allow above 128kb in here. Here's the link, size 687kb : http://www.4shared.com/file/3yGcb9nz/suspect.html

The file is : suspect.ods and the password to open it is : 55555

I really need help for this situation. It's my fault don't do backup recently. My last backup for this file was 2months old. Please advice from experts here.. Thanks.
Last edited by nightwinter on Tue Jul 09, 2013 10:58 am, edited 2 times in total.
OpenOffice.org 2.0.2
nightwinter
 
Posts: 7
Joined: Wed Jul 03, 2013 9:54 am

Re: Buffer contains null in Content XML ODS file

Postby nightwinter » Thu Jul 04, 2013 6:15 am

Hikkss does anyone get any suggestions for me..
OpenOffice.org 2.0.2
nightwinter
 
Posts: 7
Joined: Wed Jul 03, 2013 9:54 am

Re: Buffer contains null in Content XML ODS file

Postby acknak » Thu Jul 04, 2013 1:43 pm

It may be possible to get something out of the file, but I can't access the file from the link you gave: I click the download link but all I get is a login box and the download doesn't start.
AOO4/LO5 • Linux • Fedora 23
User avatar
acknak
Moderator
 
Posts: 22756
Joined: Mon Oct 08, 2007 1:25 am
Location: USA:NJ:E3

Re: Buffer contains null in Content XML ODS file

Postby jrkrideau » Thu Jul 04, 2013 3:51 pm

acknak wrote:It may be possible to get something out of the file, but I can't access the file from the link you gave: I click the download link but all I get is a login box and the download doesn't start.


Same problem. Perhaps another file storagae facility ? Both MediaFire or Dropbox seem good.
OpenOffice 4.1.6; Ubuntu 18.04
jrkrideau
Volunteer
 
Posts: 3690
Joined: Sun Dec 30, 2007 10:00 pm
Location: Kingston Ontario Canada

Re: Buffer contains null in Content XML ODS file

Postby nightwinter » Fri Jul 05, 2013 8:38 am

Haiii,

Thanks for the response. Sorry i seem to notice that mostly here use media fire. So I've uploaded the same file to media fire. Here's the link : http://www.mediafire.com/download/ukpar ... uspect.ods

Hope u can see it soon. Thanks :)
OpenOffice.org 2.0.2
nightwinter
 
Posts: 7
Joined: Wed Jul 03, 2013 9:54 am

Re: Buffer contains null in Content XML ODS file

Postby acknak » Fri Jul 05, 2013 12:19 pm

Ok, so I also see the error message, but it says "do you want to repair the file?" and after I click "Yes" the file opens normally.

Does the repair work for you?
AOO4/LO5 • Linux • Fedora 23
User avatar
acknak
Moderator
 
Posts: 22756
Joined: Mon Oct 08, 2007 1:25 am
Location: USA:NJ:E3

Re: Buffer contains null in Content XML ODS file

Postby nightwinter » Mon Jul 08, 2013 5:42 am

Sorry for the late reply, I'm off on weekend. In here, i double click the file, asking the password, I enter the usual password : 55555, then loading the file, but after loading, it says this error : "Read Error. The Wrong password has been entered.."
I'm sure i don't change the password since it has been my working sheet for the last 3years. If you could open it normally, could you post back here without the password?

Many thanks..
OpenOffice.org 2.0.2
nightwinter
 
Posts: 7
Joined: Wed Jul 03, 2013 9:54 am

Re: Buffer contains null in Content XML ODS file

Postby acknak » Mon Jul 08, 2013 12:36 pm

Sure. Let me know once you have it and I'll remove it from the forum.
Last edited by acknak on Tue Jul 09, 2013 12:28 pm, edited 1 time in total.
Reason: removed attached document
AOO4/LO5 • Linux • Fedora 23
User avatar
acknak
Moderator
 
Posts: 22756
Joined: Mon Oct 08, 2007 1:25 am
Location: USA:NJ:E3

Re: Buffer contains null in Content XML ODS file

Postby nightwinter » Tue Jul 09, 2013 9:57 am

WOWWW MARVELOUS!!! How did you do with the file?? Although it's not 100% recovered, at least 80% data back, saving my time to recover the whole thing. MANY THANKS :D Really really thanks for the repaired one..
OpenOffice.org 2.0.2
nightwinter
 
Posts: 7
Joined: Wed Jul 03, 2013 9:54 am

Re: [Solved] Buffer contains null in Content XML ODS file

Postby acknak » Tue Jul 09, 2013 12:30 pm

All I did was open the file, allow the repair, then File > Save As.

In fact, that's all I would be able to do, since the damaged document was password-protected: I don't have the software necessary to unpack and decrypt a password-protected ODF document.
AOO4/LO5 • Linux • Fedora 23
User avatar
acknak
Moderator
 
Posts: 22756
Joined: Mon Oct 08, 2007 1:25 am
Location: USA:NJ:E3

Re: [Solved] Buffer contains null in Content XML ODS file

Postby nightwinter » Tue Jul 09, 2013 12:40 pm

How's miserable.. I did what you did, it couldn't be repaired although it showed up an alert to be repaired. Could be the platform, I'm using Windows XP in 2 different computer, still the same. Maybe cause of linux. Anyway thank you so much :)
OpenOffice.org 2.0.2
nightwinter
 
Posts: 7
Joined: Wed Jul 03, 2013 9:54 am


Return to Calc

Who is online

Users browsing this forum: No registered users and 13 guests