[Solved] AutoFilter missing new data in Calc

Discuss the spreadsheet application

[Solved] AutoFilter missing new data in Calc

Postby koolio » Thu Dec 06, 2007 1:30 pm

Hi, i have a peculiar problem - i have a spreadsheet with roughly 100 rows and when i apply the filter on any of the columns and select a value for filter, it selects that value but also other rows in seemingly random fashion as well. Any idea what i'm doing wrong ? Thanks !
Last edited by Hagar Delest on Sun May 19, 2013 7:28 pm, edited 3 times in total.
Reason: tagged solved.
koolio
 
Posts: 2
Joined: Wed Dec 05, 2007 9:29 pm

Re: Filter functionality in Calc 2.3

Postby huw » Thu Dec 06, 2007 2:10 pm

I've seen this come up before, either here or on another forum, but I can't find the post, or remember if it was solved.

Are you using AutoFilter or Standard Filter? Have you filtered other spreadsheets without this problem occuring? Are you able to attach the spreadsheet here - i.e. is it non-confidential?
huw
Volunteer
 
Posts: 417
Joined: Wed Nov 21, 2007 1:57 pm

Re: Filter functionality in Calc 2.3

Postby selopez » Thu Dec 06, 2007 2:52 pm

I experienced this using the AutoFilter.
This happens to me when I retrieve a data table previously saved with the AutoFilter mode "on" and then I add data to the table from the last row on.
I've solved this turning the autofilter off and then on again, before filtering the table containing the recently added rows.
S.Lopez
selopez
 
Posts: 4
Joined: Sat Dec 01, 2007 6:53 pm

Re: Filter functionality in Calc 2.3

Postby koolio » Thu Dec 06, 2007 2:57 pm

Hmm, i should have thought of that one ;) I copied the contents into a brand new spreadsheet and voila, it works. :oops: Thanks a ton !
koolio
 
Posts: 2
Joined: Wed Dec 05, 2007 9:29 pm

Re: Filter functionality in Calc 2.3

Postby Hagar Delest » Thu Dec 06, 2007 10:52 pm

For information, there is a bug report, you should subscribe and vote for it (up to 2 votes per issue) : Issue 59229 - Autofilter does not recognize added entries. You can also post a comment. It had even been closed as invalid :roll:

NB: I tag you thread as [Issue], it should drag some attention. Perhaps the vote count will increase faster (I just added my 2 votes to make ... 3 !).
AOO 4.1.7 on Xubuntu 19.10 and 4.1.5 on Windows 10 (with winPenPack port).
User avatar
Hagar Delest
Moderator
 
Posts: 28624
Joined: Sun Oct 07, 2007 9:07 pm
Location: France


Return to Calc

Who is online

Users browsing this forum: MSN [Bot] and 31 guests