[Solved] Always printing 0 instead of empty cell

Discuss the spreadsheet application

[Solved] Always printing 0 instead of empty cell

Postby ing » Thu May 15, 2008 1:49 pm

Hello!

My Open Office Calc 2.4 (and even 2.3) always prints a 0 instaead of an empty cell.

I have lots of excel sheets where text cells were copied (too many to change each). When the cell which is copied (as formula i.e. =A1) was empty I see two empty cells on the screen - that's correct. But when I print the document I see in the destination cell a '0'. The source and the destination cells are both formattet as text.

When I start a new document I have the same problem: For example enter no text in A1, =A1 in A2 and then print the document...

Any suggestions?

Thanks

Frank
Last edited by ing on Thu May 15, 2008 3:09 pm, edited 1 time in total.
ing
 
Posts: 4
Joined: Wed May 07, 2008 1:21 pm

Re: always printing 0 instead of empty cell

Postby Cambirder » Thu May 15, 2008 1:59 pm

Can you upload an example?
OOo 3.3 on Windows 7 & 3.2.1 on Mint 10
User avatar
Cambirder
Volunteer
 
Posts: 647
Joined: Thu Nov 22, 2007 1:01 am

Re: always printing 0 instead of empty cell

Postby Villeroy » Thu May 15, 2008 2:14 pm

Turn off Menu:Tools>Options... Calc>View>"Display zero values"
Please, edit this topic's initial post and add "[Solved]" to the subject line if your problem has been solved.
Ubuntu 18.04, no OpenOffice, LibreOffice 6.4
User avatar
Villeroy
Volunteer
 
Posts: 28544
Joined: Mon Oct 08, 2007 1:35 am
Location: Germany

Re: always printing 0 instead of empty cell

Postby Cambirder » Thu May 15, 2008 2:21 pm

Villeroy wrote:Turn off Menu:Tools>Options... Calc>View>"Display zero values"


I have that turned on, and empty cells do not print as zeros. Good job too as I often need to display and print zero values.
OOo 3.3 on Windows 7 & 3.2.1 on Mint 10
User avatar
Cambirder
Volunteer
 
Posts: 647
Joined: Thu Nov 22, 2007 1:01 am

Re: always printing 0 instead of empty cell

Postby Villeroy » Thu May 15, 2008 2:41 pm

Cambirder wrote:
Villeroy wrote:Turn off Menu:Tools>Options... Calc>View>"Display zero values"


I have that turned on, and empty cells do not print as zeros. Good job too as I often need to display and print zero values.

But links to empty cells display as zero (e.g. =IV65536), which seems to be what ing complains.
Please, edit this topic's initial post and add "[Solved]" to the subject line if your problem has been solved.
Ubuntu 18.04, no OpenOffice, LibreOffice 6.4
User avatar
Villeroy
Volunteer
 
Posts: 28544
Joined: Mon Oct 08, 2007 1:35 am
Location: Germany

Re: always printing 0 instead of empty cell

Postby Cambirder » Thu May 15, 2008 2:52 pm

But links to empty cells display as zero (e.g. =IV65536), which seems to be what ing complains.


Ah! yes, I got the wrong end of the stick there.

Ing must already have turned that off, but unfortunately that only turns the display off, the zero values still print as zeros.
OOo 3.3 on Windows 7 & 3.2.1 on Mint 10
User avatar
Cambirder
Volunteer
 
Posts: 647
Joined: Thu Nov 22, 2007 1:01 am

Re: always printing 0 instead of empty cell

Postby ing » Thu May 15, 2008 3:02 pm

Thanks for the reply.

That's Right: I've turned that off. When turning it on, it displays 0 also on the screen.

But what can I do to get "nothing"? On Screen AND Printer? (Without changing each single cell)
Attachments
test.ods
example for the described problem
(7.11 KiB) Downloaded 190 times
Last edited by ing on Thu May 15, 2008 3:05 pm, edited 1 time in total.
ing
 
Posts: 4
Joined: Wed May 07, 2008 1:21 pm

Re: always printing 0 instead of empty cell

Postby Dave » Thu May 15, 2008 3:04 pm

File/Page Preview/Format page/Sheet/Print ....Toggle Zero Values off.

David.
Dave
 
Posts: 1011
Joined: Sun Dec 23, 2007 6:53 pm

Re: always printing 0 instead of empty cell

Postby Cambirder » Thu May 15, 2008 3:07 pm

If your spreadsheets are only using whole numbers, you can format all cells for 0 leading digits and 0 decimal places. You will then lose your printed zeros, at the expense of not being able to show decimal places.

Edit - Dave's solution is better.
Last edited by Cambirder on Thu May 15, 2008 3:10 pm, edited 1 time in total.
OOo 3.3 on Windows 7 & 3.2.1 on Mint 10
User avatar
Cambirder
Volunteer
 
Posts: 647
Joined: Thu Nov 22, 2007 1:01 am

Re: always printing 0 instead of empty cell

Postby ing » Thu May 15, 2008 3:08 pm

That's the solution.

Thank You very much!
ing
 
Posts: 4
Joined: Wed May 07, 2008 1:21 pm

Re: always printing 0 instead of empty cell

Postby Villeroy » Thu May 15, 2008 3:24 pm

ing wrote:Thanks for the reply.

That's Right: I've turned that off. When turning it on, it displays 0 also on the screen.

But what can I do to get "nothing"? On Screen AND Printer? (Without changing each single cell)

As far as I know this option should apply to any output device, be it printer, screen or something else.
 Edit: Oh, I missed the option at Format>Page...tab:Page where you can set this option for print devices separately. The setting applies to the current sheet's page style, thus it affects all sheets sharing this particular page style.The following advice might be obsolete. 


Try number format [>0]General;[<0]-General;""
This number format shows positive and negative numbers in the default format, which is called "General" for cells having some English number format language (may be "Standard" or something with other locales). Zeroes are hidden even if there are zero values actually.
Please, edit this topic's initial post and add "[Solved]" to the subject line if your problem has been solved.
Ubuntu 18.04, no OpenOffice, LibreOffice 6.4
User avatar
Villeroy
Volunteer
 
Posts: 28544
Joined: Mon Oct 08, 2007 1:35 am
Location: Germany


Return to Calc

Who is online

Users browsing this forum: No registered users and 11 guests