General Input Output Error When Loading Excel File

Discuss the spreadsheet application

General Input Output Error When Loading Excel File

Postby skadley » Wed Oct 17, 2012 2:37 am

I'm running OpenOffice 3.4 on Windows 7 and trying to edit a document created several years ago in Excel and modified numerous times since in OO. It's a multi-sheet workbook but not really large. The last edit was approx Oct 3rd on the same device, OS, and version of OO. When attempting to open the doc, I get a separate window General Error - General input/output error and the doc doesn't open. I tried opening the file on another PC (Windows XP and OO 3.3) and got the same error. The file still has content; file size is 68k. I was able to find a backup of the file dated Sept 26th, but not the latest edit. I was able to open the old backup copy and edit it. However, I think I've lost some data because I can't open the version with the most recent data in it. Any ideas?
OpenOffice 3.4 on Windows 7
Posts: 1
Joined: Mon Oct 15, 2012 12:34 am

Re: General Input Output Error When Loading Excel File

Postby Hagar Delest » Wed Oct 17, 2012 9:09 am

Hi and welcome to the forum!

Basically, better use the native format (.ods) if you work with AOO. Remember that .xls import/export filters have been reverse engineered, hence some flaws. xls has not been designed to be compatible with anything else than MS Office, that's the vendor lock-in policy and that's why it's important to rely on true standards like ODF.
AOO 4.1.1 on Windows 7 and Xubuntu 15.10 (Wily Werewolf)
User avatar
Hagar Delest
Posts: 26458
Joined: Sun Oct 07, 2007 9:07 pm
Location: France

Re: General Input Output Error When Loading Excel File

Postby kingfisher » Wed Oct 17, 2012 10:39 am

That sounds like a macro error. I understand that you can open your document with a compression tool. You may have to change the extension to .zip first. When uncompressed, one of the files within is content.xml. You may be able to glean your data from that. If you search the forum for corrupted file, you may find that you can even restore a readable file from the various components but I have long since forgotten how to do that.

EDIT: You may have a copy in your profile backups sub-folder. Look in Tools > Options > OO > Paths for the location.
Apache OpenOffice 4.1.2 (64 bit) on PCLinuxOS
User avatar
Posts: 2104
Joined: Tue Nov 20, 2007 10:53 am

Return to Calc

Who is online

Users browsing this forum: No registered users and 23 guests