[Solved] Turn off Spell check only in Calc

Discuss the spreadsheet application

[Solved] Turn off Spell check only in Calc

Postby Rajagopalanta » Tue Jul 28, 2009 11:58 am

Hi All,

The second question is.

2. Is there a way to turn off the red wavy lines of spell check only for calc. I want those lines to come up automatically in Writer but not in calc.

Thanks

- Raja
Last edited by Rajagopalanta on Thu Jul 30, 2009 11:31 am, edited 1 time in total.
OOo 3.0.X on Ms Windows XP
Rajagopalanta
 
Posts: 31
Joined: Tue Jan 27, 2009 4:23 pm

Re: Turn off Spell check only in Calc

Postby TheGurkha » Tue Jul 28, 2009 12:53 pm

I've played around with this but I can't find a way to do it. Everything I've tried turns it off for all OOo apps.
Ubuntu 14.10 Utopic Unicorn, LibreOffice Version: 4.3.3.2
Gurkha Welfare Trust
User avatar
TheGurkha
Volunteer
 
Posts: 6482
Joined: Thu Mar 13, 2008 12:13 pm
Location: North Wales, UK.

Re: Turn off Spell check only in Calc

Postby Villeroy » Tue Jul 28, 2009 2:55 pm

[Tutorial] Creating a new default template
Create a default template for Calc or edit the existing default template.
Get the template's default cell style.
Assign font language "[None]" to this style.
Please, edit this topic's initial post and add "[Solved]" to the subject line if your problem has been solved.
Ubuntu 12.04, OpenOffice 4.x & LibreOffice 4.x
User avatar
Villeroy
Volunteer
 
Posts: 20406
Joined: Mon Oct 08, 2007 1:35 am
Location: Germany

Re: [Solved] Turn off Spell check only in Calc

Postby Rajagopalanta » Thu Jul 30, 2009 11:33 am

Thanks Villeroy... Before posting here I tried whatever possible... This was like Magic...
OOo 3.0.X on Ms Windows XP
Rajagopalanta
 
Posts: 31
Joined: Tue Jan 27, 2009 4:23 pm

Re: [Solved] Turn off Spell check only in Calc

Postby esperantisto » Fri Jul 31, 2009 11:14 am

Sorry for being slow, but I can’t understand, what’s so difficult about pressing/unpressing the auto-spellcheck button…
Attachments
spellcheck.png
Location of spellcheck button in Calc toolbar
spellcheck.png (21.53 KiB) Viewed 7608 times
AOO 4.1.1 / LibO 5.0.0.3 / Win 7 / openSUSE Linux 11.3 (32-bit) / 13.2 (64-bit)
esperantisto
 
Posts: 359
Joined: Mon Oct 08, 2007 1:31 am

Re: [Solved] Turn off Spell check only in Calc

Postby Villeroy » Fri Jul 31, 2009 2:07 pm

esperantisto wrote:Sorry for being slow, but I can’t understand, what’s so difficult about pressing/unpressing the auto-spellcheck button…

You are not slow at all. I would turn on and off the auto-checker as needed. It's a chain of misunderstanding of Rajagopalanta and mine.

Rajagopalanta assumes that OOo Writer and Calc are two different applications, which is not entirely true. Thus the auto-spellcheck applies to all components of the single office program.
Reading the subject line, I thought of a way to disable the whole spell-checking for the Calc component and setting all cells to no language is one way.
Probably, TheGurkha got the question right and provided the only correct answer. The automatic spell checking can not be turned of for one component.

@Rajagopalanta,
Are you aware that you turned off all spell-checking (not only the automatic mode) for all documents that are created from your new default template? You may override this userdefined default for selected text cells, preferably through predefined style(s) for text values.
Please, edit this topic's initial post and add "[Solved]" to the subject line if your problem has been solved.
Ubuntu 12.04, OpenOffice 4.x & LibreOffice 4.x
User avatar
Villeroy
Volunteer
 
Posts: 20406
Joined: Mon Oct 08, 2007 1:35 am
Location: Germany

Re: [Solved] Turn off Spell check only in Calc

Postby Rajagopalanta » Tue Sep 08, 2009 10:08 am

Oops... I have not following this post for long as I considered I got the solution... Thanks for pointing that out... I just tried pressing F7 in my calc document and it does not show any misspelt word... Great on my skills :-)

Thanks for correcting me.
OOo 3.0.X on Ms Windows XP
Rajagopalanta
 
Posts: 31
Joined: Tue Jan 27, 2009 4:23 pm

Re: [Solved] Turn off Spell check only in Calc

Postby stefanwaner » Thu Jul 17, 2014 9:18 pm

I don't believe this issue is really "solved" -- at least for the Mac version.
1. The Auto Spell Check button works, but it applies to the whole of OpenOffice and cannot be set to apply only to a specific document or type of document.
2. Setting the language as "[none]" in cell formats is not possible in the Mac version as that option is not in the drop-down language list - apparently that only works for the PC version.
Mac OS 10.8.5
OpenOffice 4.1.0
stefanwaner
 
Posts: 2
Joined: Thu Jul 17, 2014 9:02 pm

Re: [Solved] Turn off Spell check only in Calc

Postby esperantisto » Wed Jul 23, 2014 1:32 pm

1. The auto spellcheck button is supposed to work this way. Thus, no issue at all.
2. Are you sure that [none] is really absent? In the cell formatting dialog → font tab, open the language selection list and scroll up to the very top. If this is really the case, it’s a good reason for filing a bug report.
AOO 4.1.1 / LibO 5.0.0.3 / Win 7 / openSUSE Linux 11.3 (32-bit) / 13.2 (64-bit)
esperantisto
 
Posts: 359
Joined: Mon Oct 08, 2007 1:31 am

Re: [Solved] Turn off Spell check only in Calc

Postby stefanwaner » Wed Jul 23, 2014 4:43 pm

The first item in the language selection is "Afrikaans". No; there is no "[none]" in the Mac version (4.1.0), and I am not sure if this qualifies as a "bug" as opposed to a simple distinction between the Mac and PC versions.

At any rate, it is not a big deal, as one can use the spell check button as needed.
Mac OS 10.8.5
OpenOffice 4.1.0
stefanwaner
 
Posts: 2
Joined: Thu Jul 17, 2014 9:02 pm

Re: [Solved] Turn off Spell check only in Calc

Postby esperantisto » Wed Jul 23, 2014 4:49 pm

I think, this does qualify as a platform-specific bug as AOO is supposed to offer the same functionality to Windows/Linux/MacOS users.
AOO 4.1.1 / LibO 5.0.0.3 / Win 7 / openSUSE Linux 11.3 (32-bit) / 13.2 (64-bit)
esperantisto
 
Posts: 359
Joined: Mon Oct 08, 2007 1:31 am


Return to Calc

Who is online

Users browsing this forum: No registered users and 16 guests