OLE Errors?

Discuss the spreadsheet application

OLE Errors?

Postby egoman69 » Wed Jan 16, 2008 9:44 pm

OOo ver 2.31 running under Win2000 Pro.

I have several spreadsheets that use Writer text embedded under OLE. I can create the object and edit it in the original document, but if I save the spreadsheet and re-open I get a "General Error. General input/output error" and the embedded text is still visible but has become a transparent graphic and cannot be opened for editting. The error box is random, but the text behavior can be duplicated at will. This was not a problem up through version 2.0 I believe, but has been in the last couple. Anyone else having similar issues, or know what I am doing wrong? Barring that, would anyone know of an old version archive so I can downgrade? Thanks.
egoman69
 
Posts: 2
Joined: Wed Jan 16, 2008 9:35 pm

Re: OLE Errors?

Postby maxqnz » Thu Jan 17, 2008 12:55 am

When you say that "the error box is random", do you mean that the message you get varies, but that the behaviour itself is consistent? I ask because I just tried creating a new calc *.ods, and embedded an *.odt file as an OLE object, and was unable to replicate this behaviour. I am still running 2.3.0 on XP Pro, but I created the *.ods, embedded the *.odt, and then saved and exited. I re-opened the *.ods, edited the text from within the calc file, and saved. I then re-opened and did the same again. Each time, the file opened without problems.
non sum uni angulo natus, patria mea totus hic mundus est. - Seneca
The world's about to end... lucky escape for Arsenal if it did. - Douglas Adams
What's a pieriansipist?
User avatar
maxqnz
 
Posts: 77
Joined: Mon Oct 08, 2007 1:33 am
Location: Te Ika a Maui, Aotearoa

Re: OLE Errors?

Postby egoman69 » Thu Jan 17, 2008 3:13 pm

Sorry for the ambiguity. The error message is always the same (General input/output error) when the box pops up, but the actual appearance of the error box seems to be random, by which I mean I cannot determine the difference in conditions that causes the error one time but not the next. The object behavior is the same whether the error message appears or not... an embedded text object appears as a graphic (of the created text) with a transparent background. All of my text is still in the object frame, the frame can be moved and resized, however I cannot edit the text as Calc appears to see it as a graphic rather than an OLE object. I originally thought it was an OLE error in Win2000, but it only seems to happen in OO so I posted here. I hope that clarifies. Thank you.
egoman69
 
Posts: 2
Joined: Wed Jan 16, 2008 9:35 pm


Return to Calc

Who is online

Users browsing this forum: Google [Bot] and 29 guests