[Solved] Autofilter - delete filter is unavailable

Discuss the spreadsheet application

[Solved] Autofilter - delete filter is unavailable

Postby humulus » Wed Apr 01, 2009 9:41 pm

Hi,
the other day I made a filtering with Autofilter. After that I saved the calc sheet as Excel 2007 and ended the session. Now I can't delete the filter to get all lines back (they are there, I can see it from the line numbers) as the option Data - Filter - Delete filter is grey. I get the same problem with the file converted into .ods.
Last edited by humulus on Wed Apr 01, 2009 11:15 pm, edited 1 time in total.
humulus
 
Posts: 35
Joined: Wed Apr 01, 2009 7:54 pm

Re: Autofilter - delete filter is unavailable

Postby FJCC » Wed Apr 01, 2009 9:52 pm

Try selecting the entire filtered region and then go to Format -> Row -> Show.
Windows 10 and Linux Mint, since 2017
If your question is answered, please go to your first post, select the Edit button, and add [Solved] to the beginning of the title.
FJCC
Moderator
 
Posts: 7061
Joined: Sat Nov 08, 2008 8:08 pm
Location: Colorado, USA

Re: Autofilter - delete filter is unavailable

Postby humulus » Wed Apr 01, 2009 10:30 pm

Thanks, now all rows are visible. However, I've met another problem which I haven't seen before. When I start Autofilter and click at the arrow I don't see the contents of the column, just the rows All, 10 highest an Standard filter. When I click on 10 highest nothing happens but Standard filter works normally and the autofiltering in a testfile as well.
OOo 3.0.X on MS Windows Vista
humulus
 
Posts: 35
Joined: Wed Apr 01, 2009 7:54 pm

Re: Autofilter - delete filter is unavailable

Postby Villeroy » Wed Apr 01, 2009 10:48 pm

menu:Data>Select...
You may see some name like "Excel_Autofilter...". Select that one. This is the range that is supposed to be filtered.
If it is the wrong range call menu:Data>Define... select the "Excel_Autofilter...", adjust the reference, click [Modify] and [OK]
If there is no database range like "Excel_Autofilter...", select the whole list range, call menu:Data>Define... define a named database range, click [Add] and [OK].
Now you will not lose the filter settings anymore.
Do not append new data below the list. Always insert new cells and delete unwanted cells rather than clear contents. This way all your named and unnamed references [such as sum(A2:A99)], charts, conditional formattings, validations and data pilots refer to the correctly sized list range.
Storing data in a database and link them by means of import ranges in spreadsheets would solve all of those problems (losing Excel compatibility though).
Please, edit this topic's initial post and add "[Solved]" to the subject line if your problem has been solved.
Ubuntu 18.04, OpenOffice 4.x & LibreOffice 6.x
User avatar
Villeroy
Volunteer
 
Posts: 26403
Joined: Mon Oct 08, 2007 1:35 am
Location: Germany

Re: Autofilter - delete filter is unavailable

Postby humulus » Wed Apr 01, 2009 11:14 pm

Thanks a lot - it works.
OOo 3.0.X on MS Windows Vista
humulus
 
Posts: 35
Joined: Wed Apr 01, 2009 7:54 pm


Return to Calc

Who is online

Users browsing this forum: No registered users and 15 guests