[Issue] Faulty language selection

Discuss the spreadsheet application

[Issue] Faulty language selection

Postby andifor » Fri Jan 04, 2008 11:05 am

OOo 2.3.1 on Linux, English installation

I have a spreadsheet with some English and some German text in different cells. I can set the spell checker for the English cells, but I cannot set the German spell checker correctly.

I can set "Word is German (Switzerland)" but I only can set "Paragraph is German (Germany)". It's not possible for me to set "Paragraph is German (Switzerland)". My "openoffice.org/share/dict/ooo/dictionary.lst" lists only "*de CH*" language variant and in "Tools > Options > Language Settings" I can only selecte "German (Switzerland)" (and of course English, but no "German (Germany)").

I guess, this is only a problem of the userinterface, or does OOo have some hidden spell feature I'm not aware of?

andifor
Last edited by Hagar Delest on Mon Jun 30, 2008 9:49 pm, edited 1 time in total.
Reason: Tagged the thread as issue (link to a bug report).
andifor
 
Posts: 3
Joined: Fri Jan 04, 2008 10:46 am

Re: faulty language selection

Postby Villeroy » Fri Jan 04, 2008 1:41 pm

andifor wrote:OOo 2.3.1 on Linux, English installation

Which distro? Did you Install the office + German lang pack by package manager or did you install Sun's original packages manually?
andifor wrote:I have a spreadsheet with some English and some German text in different cells. I can set the spell checker for the English cells, but I cannot set the German spell checker correctly.

I can set "Word is German (Switzerland)" but I only can set "Paragraph is German (Germany)". It's not possible for me to set "Paragraph is German (Switzerland)".

How do you set up a paragraph's property in a spreadsheet? I think there are no paragraphs at all, not even in a cell with multiple lines of text.
andifor wrote:My "openoffice.org/share/dict/ooo/dictionary.lst" lists only "*de CH*" language variant and in "Tools > Options > Language Settings" I can only selecte "German (Switzerland)" (and of course English, but no "German (Germany)").

I guess, this is only a problem of the userinterface, or does OOo have some hidden spell feature I'm not aware of?

andifor

I guess, this is just another problem of a Linux distribution, trying to "enhance" and "integrate" their own compilation of this office suite.
Please, edit this topic's initial post and add "[Solved]" to the subject line if your problem has been solved.
Ubuntu 18.04, no OpenOffice, LibreOffice 6.4
User avatar
Villeroy
Volunteer
 
Posts: 28846
Joined: Mon Oct 08, 2007 1:35 am
Location: Germany

Re: faulty language selection

Postby andifor » Fri Jan 04, 2008 1:58 pm

Villeroy wrote:
andifor wrote:OOo 2.3.1 on Linux, English installation

Which distro? Did you Install the office + German lang pack by package manager or did you install Sun's original packages manually?


Sun?? I downloaded OOo_2.3.1_LinuxIntel_install_en-US.tar.gz from a mirror, unpacked it manually and copied all the files to my /opt/ directory. No German language pack, nothing. Just this one download.

(Sorry, I was so unspecific, this was the idea of the information about the English installation)


Villeroy wrote:
andifor wrote:I have a spreadsheet with some English and some German text in different cells. I can set the spell checker for the English cells, but I cannot set the German spell checker correctly.

I can set "Word is German (Switzerland)" but I only can set "Paragraph is German (Germany)". It's not possible for me to set "Paragraph is German (Switzerland)".

How do you set up a paragraph's property in a spreadsheet? I think there are no paragraphs at all, not even in a cell with multiple lines of text.


I don't, it's just the context menu that appears if I click a cell: "Word is..." or "Paragraph is..." (should probably be "Cell is...")

Villeroy wrote:
andifor wrote:My "openoffice.org/share/dict/ooo/dictionary.lst" lists only "*de CH*" language variant and in "Tools > Options > Language Settings" I can only selecte "German (Switzerland)" (and of course English, but no "German (Germany)").

I guess, this is only a problem of the userinterface, or does OOo have some hidden spell feature I'm not aware of?

andifor

I guess, this is just another problem of a Linux distribution, trying to "enhance" and "integrate" their own compilation of this office suite.


Well, wrong guess. Thanks anyway.
andifor
andifor
 
Posts: 3
Joined: Fri Jan 04, 2008 10:46 am

Re: faulty language selection

Postby Villeroy » Fri Jan 04, 2008 3:36 pm

You installed the English original by Sun, which should be fine even without German language pack. Having additional language packs installed, you can switch the language of the user interface and help system.
Independant from the user interface language, you can install spell checker dictionaries for many languages. Menu:File>Wizzards>Install dictionary...

On cell level the spell checker language depends on the language set in the "Font" tab of the cell formatting dialogue. Within a single text-cell you can even format different portions of text. Language "[None]" implies no spell checking and no typographic features like typographic quotes:
„german“
“english”
"none"

In a multilingual spreadsheet I would create a set of cell styles for each language. This is far more comfortable than manual hard formatting.
Call the stylist (F11), hit the top-left button for cell styles, pick "hierarchical" from the bottom list, use context-menues to add/edit/remove styles.
Proposal:
Code: Select all   Expand viewCollapse view
[+]Default
    |_[+]Text (top-left orientation, font language "[None]", number format "Text")
        |_Text_Swiss (font language "German(Swiss)")
        |_Text_English (font language "English(GB)")

The suggested set of cell styles lets you define a common set of property for all text cells, with sub-variants for each language.
A more simple variant may work for you as well:
Code: Select all   Expand viewCollapse view
[+]Default
    |_[+]Text_Swiss (top-left orientation, number format "Text", font language "German(Swiss)")
        |_Text_English (font language "English(GB)")

Double-click a style in order to apply all its settings to the currently selected cells. Simply edit the style in order to change all cells sharing the same style.

Still puzzled by the paragraph formatting you mentioned: We are not talking about a table in a text document. Your table is a grid of 64536x256 cells as genearated by Menu:File>New>Spreadsheet...?
In either case you should learn about the concept of styles, which is consistant throughout the whole office suite.
Please, edit this topic's initial post and add "[Solved]" to the subject line if your problem has been solved.
Ubuntu 18.04, no OpenOffice, LibreOffice 6.4
User avatar
Villeroy
Volunteer
 
Posts: 28846
Joined: Mon Oct 08, 2007 1:35 am
Location: Germany

Re: faulty language selection

Postby andifor » Fri Jan 04, 2008 3:57 pm

Villeroy wrote:You installed the English original by Sun, which should be fine even without German language pack. Having additional language packs installed, you can switch the language of the user interface and help system.
Independant from the user interface language, you can install spell checker dictionaries for many languages. Menu:File>Wizzards>Install dictionary...


I don't want/need other language packages. I'm happy with what is comming with the original version from Sun.


Villeroy wrote:Still puzzled by the paragraph formatting you mentioned: We are not talking about a table in a text document. Your table is a grid of 64536x256 cells as genearated by Menu:File>New>Spreadsheet...?
In either case you should learn about the concept of styles, which is consistant throughout the whole office suite.


Yes, I use a spreadsheet document and not a table in a text document, that's why I posted in the Calc group.

<offtopic>
I know about OOos style capabilities. I don't like them. The concept just doesn't work as I need it. Compare it with the paragraph and font formats (styles) Frame Maker uses (the software I use to write text with). OOos styles is a copy of MS Office' style function. Might be some improvement, but the concept is still the same.
</offtopic>

Anyway, as I think, that OOo uses the correct spell checker (no other spell checker is installed anyway), it's not a big problem. I just was surprised to find me in this situation.


Thanks so far!
andifor
andifor
 
Posts: 3
Joined: Fri Jan 04, 2008 10:46 am

Re: faulty language selection

Postby Hagar Delest » Fri Jan 04, 2008 11:57 pm

andifor wrote:if I click a cell: "Word is..." or "Paragraph is..." (should probably be "Cell is...")

I confirm, same for me with a spreadsheet (using OOo 2.3.1, official version on Ubuntu).

andifor wrote:OOos styles is a copy of MS Office' style function. Might be some improvement, but the concept is still the same.

Definitively not. But this is offtopic.

I've made some tries and internally OOo, it seems that there is a language guessing process. Its results depend on the sentence it seems. I just typed "Warum" in a Writer document and OOo asked me if the word or paragraph were in ... Latin ! And I don't have the Latin dictionary installed at all :shock:

Have you tried to apply cell styles as advised by Villeroy ?
LO 6.4.6 on Xubuntu 20.04 and Windows 10.
User avatar
Hagar Delest
Moderator
 
Posts: 29079
Joined: Sun Oct 07, 2007 9:07 pm
Location: France

Re: faulty language selection

Postby Hagar Delest » Sun Jan 27, 2008 10:55 pm

For information, after some searches, I've found that one: Issue 66798 - language detection in context menu is broken. I've added comments, you should subscribe and vote for it (up to 2 votes per issue).
LO 6.4.6 on Xubuntu 20.04 and Windows 10.
User avatar
Hagar Delest
Moderator
 
Posts: 29079
Joined: Sun Oct 07, 2007 9:07 pm
Location: France


Return to Calc

Who is online

Users browsing this forum: No registered users and 28 guests