[Solved] Frustration with bad allocation and program crash

Discuss the spreadsheet application

[Solved] Frustration with bad allocation and program crash

Postby fatgreta » Sat May 02, 2020 7:10 pm

I have switched from saving files as .xls to .ods in hopes of no longer having them crash and need to be recovered and losing data, which happens as of my latest survey 1.2 out of every 5 saves (6 of the last 18). I've only been specifically counting since then but that strikes me as about what it's been like since I first started having this problem with Open Office many years ago. It's terribly frustrating. I get a message saying bad allocation, some error code, then the application shuts down. When I recover the file, all data entered in the last session is lost. I've taken to leaving the file open for 10 minutes before saving in hopes of auto save kicking in, but that does not always happen despite the fact that i have that option enabled. In fact, the fact that it has not yet happened is almost certain indication that when I manually save it's going to crash. The progress bar along the bottom starts turning more and more green, at about half-way the pop up window appears briefly then the whole thing crashes. I've posted intermittently over the years trying to figure out why this program so frequently crashes for me, and am still hoping for some kind of solution to this bedeviling problem.

In another post, someone directed me to the Windows Defender tutorial, which has the following line:

'If you use a third party Anti Virus software then Windows Defender is no longer available and the procedure below is no longer available.'

I use webroot so I think that means that Windows Defender is not the problem?

This problem persists at about the same level as I indicated above. It is terribly frustrating, especially because autosave doesn't seem to function regularly and the problem often happens as i'm saving data, so I have no way that I can figure out to not lose data. It happens after hitting save, it happens when trying to copy and paste and it happens when renaming cells, those are the most frequent triggers. Sometimes it give and error message, sometimes it simply shuts down. Any help I can get on this problem will be greatly appreciated.

Additionally, in case this is relevant, when I use Help -> Check for updates that always fails, I have to manually go the website to see if my version is current, which I believe it is (4.1.7)

Thanks for any help,

Last edited by Hagar Delest on Fri May 08, 2020 5:24 pm, edited 1 time in total.
Reason: tagged solved
Open Office 4.1.7 on Windows 10
Posts: 41
Joined: Sat Feb 26, 2011 1:59 am

Re: Continued frustration with bad allocation and program cr

Postby RoryOF » Sat May 02, 2020 7:20 pm

A wild guess: what graphics card/chip is used on your computer?
Apache OpenOffice 4.1.8 on Xubuntu 20.04.1 (mostly 64 bit version) and very infrequently on Win2K/XP
User avatar
Posts: 32038
Joined: Sat Jan 31, 2009 9:30 pm
Location: Ireland

Re: Continued frustration with bad allocation and program cr

Postby John_Ha » Sat May 02, 2020 7:38 pm

Search the forum with bad allocation and see if anything in those 21 threads helps.

I quickly found that it seems to be a bug - see Issue 125006 - Calc Consistently crashing, usually with "Fatal Error - Bad Allocation"

You might like to switch to LibreOffice and see if LO is better as it is almost certain never to be fixed in AOO - it was reported in 2014.
LO, Windows 10 Home 64 bit

See the Writer Guide, the Writer FAQ, the Writer Tutorials and Writer for students.

Remember: Always save your Writer files as .odt files. - see here for the many reasons why.
Posts: 8101
Joined: Fri Sep 18, 2009 5:51 pm
Location: UK

Re: Continued frustration with bad allocation and program cr

Postby fatgreta » Fri May 08, 2020 5:01 pm

I thought i'd replied earlier but see that it did not post I want to thank you for your help and recommendation of switching to Libre Office. The problem has not re-occured since, and I've been using some of the large spreadsheets more than usual, so I believe the LO switch was the fix for me. That saved me a lot of time and frustration, I am very thankful to you for the recommendation.

Open Office 4.1.7 on Windows 10
Posts: 41
Joined: Sat Feb 26, 2011 1:59 am

Re: [Solved] Frustration with bad allocation and program cra

Postby robleyd » Sat May 09, 2020 1:37 am

You seem to have two topics discussing very similar problems - see viewtopic.php?f=9&t=101222
Apache OpenOffice 420m2(Build:9821) - Slackware 14.2 - 64 bit
LibreOffice (SlackBuild for 6.4.6 by Eric Hameleers) - Slackware 14.2 - 64 bit
Apache OpenOffice 4.1.4 - Windows 7 Virtual machine
User avatar
Posts: 3660
Joined: Mon Aug 19, 2013 3:47 am
Location: Murbko, Australia

Return to Calc

Who is online

Users browsing this forum: No registered users and 14 guests