[Solved] Macro Security

Discuss the spreadsheet application

[Solved] Macro Security

Postby grahamn » Sun Jan 19, 2020 5:26 am

I have updated from W7 to W10
My macros no longer work
When I ry to run them manually I get the message :
"For security resons, you cannot use this macro"
I have tried deleting the macros and re-installing them to no avail
Please advise what I can do
Last edited by robleyd on Mon Jan 20, 2020 1:05 am, edited 1 time in total.
Reason: Tagged [Solved]
OpenOffice 4.1.0 on windows 7
grahamn
 
Posts: 7
Joined: Sat Aug 16, 2014 4:15 am

Re: Macro Security

Postby robleyd » Sun Jan 19, 2020 5:43 am

Check the security settings in Tools | Options | OpenOffice | Security Macro Security.

You may have to restart OpenOffice for changes to be recognised.
Cheers
David
Apache OpenOffice 420m2(Build:9821) - Slackware 14.2 - 64 bit
LibreOffice 6.0.7.3 - Slackware 14.2 - 64 bit
Apache OpenOffice 4.1.4 - Windows 7 Virtual machine
User avatar
robleyd
Moderator
 
Posts: 3463
Joined: Mon Aug 19, 2013 3:47 am
Location: Murbko, Australia

Re: Macro Security

Postby Zizi64 » Sun Jan 19, 2020 11:51 am

I have updated from W7 to W10
My macros no longer work
When I ry to run them manually I get the message :
"For security resons, you cannot use this macro"
I have tried deleting the macros and re-installing them to no avail


Which macros do you mean? Are those some Extensions, or are those your own StarBasic+API macros embedded into the documents, or placed in the MyMacros/Standard (or other) library?

Can you share some code of your macros here?
Tibor Kovacs, Hungary; LO6.1.6, 6.2.8 /Win7-10 x64Prof.
PortableApps/winPenPack: LO3.3.0-6.4.5;AOO4.1.7
Please, edit the initial post in the topic: add the word [Solved] at the beginning of the subject line - if your problem has been solved.
User avatar
Zizi64
Volunteer
 
Posts: 9548
Joined: Wed May 26, 2010 7:55 am
Location: Budapest, Hungary

Re: Macro Security

Postby grahamn » Mon Jan 20, 2020 12:25 am

robleyd - thanks, that worked

Zizy64 - thanks for your reply
OpenOffice 4.1.0 on windows 7
grahamn
 
Posts: 7
Joined: Sat Aug 16, 2014 4:15 am

Re: Macro Security

Postby Lupp » Mon Jan 20, 2020 12:29 am

This shouldn't be an effect of your system update. You may have (inadvertently) changed the macro security setting saved in your user profile.

Anyway only document macros (saved in the document's file) should be afflicted.

Go >Tools>Options>OpenOffice>Security>Macro Security and choose 'Medium'.

This setting will cause OpenOffice to prompt you for permisson to execute macro code when loaded from file.
(Don't choose 'Low'. Too risky.)
On Windows 10: LibreOffice 7.0 and older versions, PortableOpenOffice 4.1.7 and older, StarOffice 5.2
---
Lupp from München
User avatar
Lupp
Volunteer
 
Posts: 2918
Joined: Sat May 31, 2014 7:05 pm
Location: München, Germany


Return to Calc

Who is online

Users browsing this forum: eleanorb and 13 guests