Page 1 of 1

[Tutorial] Embedding Video into OOo Impress for Windows

PostPosted: Wed Nov 24, 2010 5:38 pm
by Rezo
How To Embed Video into OpenOffice Impress
By: Rezo

There have been a lot of questions as to why the OpenOffice Impress Software cannot
use Videos.

Reason:

The embedded video does not actually run through the program itself.

Solution:

You must add software to your computer in order for it to work.


Instructions:

Download the following:

1. DirectX End-User Runtime Web Installer

Link: http://www.microsoft.com/downloads/en/d ... laylang=en

2. CCCP Codec Pack

Link: http://www.cccp-project.net/download.php?type=cccp

3. Java

Link: http://www.java.com (Click "FREE JAVA DOWNLOAD")


Install DirectX End-User Runtime Web Installer

Install CCCP Codec Pack

Ensure the LATEST JAVA VERSION IS INSTALLED

Now that they are installed, insert the video.. it will play.

Re: [Tutorial] Embedding Video into OOo Impress for Windows

PostPosted: Wed Mar 16, 2011 6:55 pm
by helenladam
Followed your instructions, but keep getting "format not supported". Any other ideas?

Re: [Tutorial] Embedding Video into OOo Impress for Windows

PostPosted: Thu Mar 17, 2011 12:22 am
by RoryOF
In Windows, if your video will not play in an external program such as Windows media player, or some other video player, it is a sign that the correct codec is not installed for that format. If that is the case, it will most definitely not play in Impress; the cure is to analyse the video stream, find and install the correct codecs. Google for Gspot, which is a good stream analyser. Google is your friend with stubborn video streams after such analysis. Note that these remarks apply only to Impress running on Windows. LibreOffice is said to have better video support under most operating systems.

Re: [Tutorial] Embedding Video into OOo Impress for Windows

PostPosted: Wed Sep 18, 2013 3:21 pm
by Petrocelli99
Thanks for the info RoryOf. Your suggestion worked, however I just upgraded to Windows 8, and am at square one during the install. I'll post back later, maybe I can help someone with the same issue.