Page 1 of 1

[Solved] Formatting bullet points

PostPosted: Wed Feb 13, 2019 1:47 am
by TonyRolfe
I am using Open office 4.1.5 on Windows 10.

I am trying to reformat bullet points created by clicking the bullets on/off button. The default setting that the second and subsequent lines align with the text of the first line and indented from the bullet.

It looks like
Code: Select all   Expand viewCollapse view
.   My text starts here
    and the next line starts here.


What I want to achieve: Each point has a short name, followed by a tab then the actual text. I want the second and subsequent lines to start below the text. Looking like this:

Code: Select all   Expand viewCollapse view
.  Cat    lots of text about cats
          overflowing like this
.  Dog    lots of text about dogs
          flowing to here


This is easy to achieve with normal, not bulleted, paragraphs, but I can't get it to work with bullets. If I can get it to work, is there a way to save that format so I can reuse it easily?

Help would be appreciated

Thanks

Tony

Re: Formatting bullet points

PostPosted: Wed Feb 13, 2019 3:50 am
by Villeroy
Tabs don't work across lines. Make a 2-column table.

Re: Formatting bullet points

PostPosted: Wed Feb 13, 2019 4:04 am
by TonyRolfe
Sorry, I don't understand what "across lines" means.

I know how to make the table, but I had hoped that I could somehow format the paragraph. If the items aren't bulleted, just having a hanging indent equal to the tab width works fine. Somehow, with a bulleted list that doesn't seem to work properly.

Re: Formatting bullet points

PostPosted: Wed Feb 13, 2019 9:43 am
by Hagar Delest
You have to use a List style. Just change the Indent field in the Position tab. Set it to 3.0cm for example.
The strange thing is that the indent value will be applied to the first tab you type. I would not expect this value to be taken into account for the first line but it's not that surprising either.

Please add [Solved] at the beginning of the title in your first post (top of the topic) with the *EDIT button if your issue has been fixed.

Re: Formatting bullet points

PostPosted: Wed Feb 13, 2019 11:36 am
by Bill
TonyRolfe wrote:...I had hoped that I could somehow format the paragraph. If the items aren't bulleted, just having a hanging indent equal to the tab width works fine. Somehow, with a bulleted list that doesn't seem to work properly.

Use Format > Paragraph to format paragraphs.
Use Format > Bullets and Numbering to format lists.

Re: Formatting bullet points

PostPosted: Wed Feb 13, 2019 2:36 pm
by Villeroy
bullets_and_tabs.odt
(12.18 KiB) Downloaded 14 times

Re: Formatting bullet points

PostPosted: Wed Feb 13, 2019 6:27 pm
by jrkrideau
TonyRolfe wrote:I am using Open office 4.1.5 on Windows 10.

I am trying to reformat bullet points created by clicking the bullets on/off button. The default setting that the second and subsequent lines align with the text of the first line and indented from the bullet.

It looks like
Code: Select all   Expand viewCollapse view
.   My text starts here
    and the next line starts here.


What I want to achieve: Each point has a short name, followed by a tab then the actual text. I want the second and subsequent lines to start below the text. Looking like this:

Code: Select all   Expand viewCollapse view
.  Cat    lots of text about cats
          overflowing like this
.  Dog    lots of text about dogs
          flowing to here


This is easy to achieve with normal, not bulleted, paragraphs, but I can't get it to work with bullets. If I can get it to work, is there a way to save that format so I can reuse it easily?

Help would be appreciated

Thanks

Tony


Try setting the List Contents with a first line indent of -2. cm [minus 2], the Before line indent with 4.00cm, then delete all tabs and set a new tab at 4.00 cm.

See attached example. I think I understand what you mean.

Re: Formatting bullet points

PostPosted: Wed Feb 13, 2019 8:37 pm
by Bill
Setting the indent on the Bullets and Numbering dialog as stated by Hagar works perfectly. There's no need to change any paragraph or paragraph style settings.

Re: Formatting bullet points

PostPosted: Wed Feb 13, 2019 10:54 pm
by Hagar Delest
I've to admit that I first went the same way than jrkrideau, thinking that the list style would provide the bullet and the paragraph style the indenting. But I then discovered by chance that the list indent was overriding the paragraph settings. In fact, indenting through paragraph settings worked on the paragraphs I had already made but not on the new paragraphs created with Enter after the existing ones. A bit weird BTW.

Re: Formatting bullet points

PostPosted: Thu Feb 14, 2019 1:08 am
by TonyRolfe
OK. I've got it now. I had to change the indent value (the last field on the position tab) to 24 and that does it. I suspect that this sets a default for all level 1 bullets, so you can't have different indents for level 1 in different parts of the document, but that's not a major problem.

Thanks to all for the help.

Off to set the [Solved] flag.

Re: [Solved] Formatting bullet points

PostPosted: Thu Feb 14, 2019 1:27 am
by robleyd
You could create other styles for level 1 bullets and apply them as needed.

Re: [Solved] Formatting bullet points

PostPosted: Thu Feb 14, 2019 1:41 am
by TonyRolfe
Ah, yes. I hadn't though of that. Thanks

Re: [Solved] Formatting bullet points

PostPosted: Thu Feb 14, 2019 2:59 am
by Bill
TonyRolfe wrote:OK. I've got it now. I had to change the indent value (the last field on the position tab) to 24 and that does it. I suspect that this sets a default for all level 1 bullets, so you can't have different indents for level 1 in different parts of the document, but that's not a major problem.

It doesn't set the default for "all" level 1 bullets. When you change a setting on the Bullets and Numbering dialog, you're changing the setting for the list style that is applied to the selected list item. If that list style is applied to other lists, then those lists will also change, but if that list style isn't applied to other lists, then the other lists won't be changed.