Selecting different language for new writer doc doesn't work

Discuss the word processor

Selecting different language for new writer doc doesn't work

Postby Namyo85 » Wed Oct 10, 2018 1:11 am

Hi, I've installed Open office 4.1.5, I've also installed Apache_OpenOffice_4.1.5_Win_x86_langpack_ru and dict_pack_ru-aot-0.4.2.oxt
I'm experimenting with trying to type in Russian. I found this video online: https://www.youtube.com/watch?v=OTYDXDtohaY which explains how to change the language. However, When I open a new Writer document and change the language at the bottom of the document as the video explains, as soon as I start typing, it instantly changes back to English. I can't find any answers anywhere on this forum that definitively explains how to switch between languages when starting a new document. There are lots of posts that talk about changing the language settings but they don't fix this issue. I've come across spellcheck questions and similar issues but not specifically what I want to do, i.e. start a new document and set the language for that document.

I think therefore the right questions to ask are:
1. Why is the language reverting back to English as soon as I type the first letter?
2. How do I fix this problem?
Last edited by robleyd on Wed Oct 10, 2018 1:35 am, edited 1 time in total.
Reason: Remove Toxic Issue icon [robleyd, moderator]
OpenOffice 4.1.5 on Windows 7
Namyo85
 
Posts: 8
Joined: Wed Oct 10, 2018 12:46 am
Location: UK

Re: Selecting different language for new writer doc doesn't

Postby Bill » Wed Oct 10, 2018 2:54 am

If you want to change the default language for the document to Russian, then use Tools > Language > For All Text. The method shown on the video just applies direct formatting to characters without changing the document language. IIRC, in Windows the keyboard language setting is applied directly to characters. If the keyboard language is set to English, that would change the language setting when you start typing. If so, then you may need to change the keyboard language setting to change the language being typed.
AOO 4.1.5 and LO 6.0.3.2 on Manjaro MATE
Bill
Volunteer
 
Posts: 6906
Joined: Sat Nov 24, 2007 6:48 am

Re: Selecting different language for new writer doc doesn't

Postby Hagar Delest » Wed Oct 10, 2018 7:59 am

See also: [Troubleshooting] Spell check in OpenOffice.

Please add '[Solved]' at beginning of your first post title (edit button) if your issue has been fixed.
AOO 4.1.6 on Xubuntu 18.10 and 4.1.5 on Windows 7 (with winPenPack port).
User avatar
Hagar Delest
Moderator
 
Posts: 28258
Joined: Sun Oct 07, 2007 9:07 pm
Location: France

Re: Selecting different language for new writer doc doesn't

Postby Bill » Wed Oct 10, 2018 10:45 am

AOO 4.1.5 and LO 6.0.3.2 on Manjaro MATE
Bill
Volunteer
 
Posts: 6906
Joined: Sat Nov 24, 2007 6:48 am

Re: Selecting different language for new writer doc doesn't

Postby John_Ha » Wed Oct 10, 2018 11:26 am

See Choosing language settings in Chapter 2 - Setting up Writer

As a new poster you will find much useful information in the Writer FAQ, the Writer Tutorials, the up to date Writer guide and the Writer Manual. May I suggest you bookmark the pages.

Press F1 to access the Help screen and search for your problem

The chapter headings in the manual are:

1 - Introducing Writer
2 - Setting up Writer
3 - Working with Text
4 - Formatting Pages
5 - Printing, Exporting, Faxing and E-Mailing
6 - Introduction to Styles
7 - Working with Styles
8 - Working with Graphics
9 - Working with Tables
10 - Working with Templates
11 - Using Mail Merge
12 - Tables of Contents, Indexes and Bibliographies
13 - Working with Master Documents
14 - Working with Fields
15 - Using Forms in Writer
16 - Customizing Writer – Keyboard shortcuts.

When a pop-up window opens, click the Help button for extensive help on that function - it is often more comprehensive than the manual.
AOO 4.1.5, Windows 7 Home 64 bit

See the Writer Manual, the Writer FAQ, the Writer Tutorials and the Writer guide.

Remember: Always save your Writer files as .odt files. - see here for the many reasons why.
John_Ha
Volunteer
 
Posts: 5857
Joined: Fri Sep 18, 2009 5:51 pm
Location: UK

Re: Selecting different language for new writer doc doesn't

Postby jrkrideau » Wed Oct 10, 2018 11:46 am

My rather simple technique is to create a template with the Default Paragraph Style set to Russian. This avoids executing the Tools > Language > For All Text command all the time but it means that one must separately define Character Styles, or at least, I cannot see how to do a global change in Character Styles the way changing the Default Styles will in paragraphs.
AOO 4.1.5; Ubuntu 18.04
jrkrideau
Volunteer
 
Posts: 3574
Joined: Sun Dec 30, 2007 10:00 pm
Location: Kingston Ontario Canada

Re: Selecting different language for new writer doc doesn't

Postby Namyo85 » Fri Oct 12, 2018 12:46 am

Thanks for above replies. I tried all of the language changes in the options but nothing worked. Can someone confirm that I have to change the language settings on Windows in order for changing language in Open Office Writer to work? There is no mention of that in the youtube video. With the language pack already installed in Writer I would have thought it would do that independently regardless of what the Windows OS typing language is set to.
OpenOffice 4.1.5 on Windows 7
Namyo85
 
Posts: 8
Joined: Wed Oct 10, 2018 12:46 am
Location: UK

Re: Selecting different language for new writer doc doesn't

Postby Bill » Fri Oct 12, 2018 3:16 am

There is no mention of the Windows language settings in the YouTube video because that video done on a Mac in 2013. The AOO enhancement to use the keyboard language settings in Windows was done two years later.

I did extensive testing and commented on the effect of the Windows settings in 2017 when I was still using Windows. You can do the same testing to see if you get the same results.

[Solved] Language switches by itself
AOO 4.1.5 and LO 6.0.3.2 on Manjaro MATE
Bill
Volunteer
 
Posts: 6906
Joined: Sat Nov 24, 2007 6:48 am

Re: Selecting different language for new writer doc doesn't

Postby jrkrideau » Fri Oct 12, 2018 3:19 pm

Namyo85 wrote: Can someone confirm that I have to change the language settings on Windows in order for changing language in Open Office Writer to work? T


While I cannot actually confirm it, that is my impression based on some discussions in this forum a couple of years ago. IIRC, keyboard layout in Windows is a matter of changing the language setting.
AOO 4.1.5; Ubuntu 18.04
jrkrideau
Volunteer
 
Posts: 3574
Joined: Sun Dec 30, 2007 10:00 pm
Location: Kingston Ontario Canada

Re: Selecting different language for new writer doc doesn't

Postby Namyo85 » Sat Oct 13, 2018 1:15 am

How strange. :| I can't believe that whoever built this thing hasn't accounted for such an eventuality. It's 2018, NASA have remote controlled robots on Mars. Humans are making breakthroughs in Artificial Intelligence, not to mention the advanced Military Technology out there. Despite this no-one knows how to change the language setting in Open Office on Windows, even the people that made it. :!:
Thanks though for the comments above, at least you tried.
OpenOffice 4.1.5 on Windows 7
Namyo85
 
Posts: 8
Joined: Wed Oct 10, 2018 12:46 am
Location: UK

Re: Selecting different language for new writer doc doesn't

Postby jrkrideau » Sat Oct 13, 2018 1:33 am

Actually it is easy to change the language setting in AOO. As was mentioned earlier
Tools > Options > Language Settings > Languages and change the Default languages for document Western to Russian (I assume that you have a Russian dictionary installed).

The problem is Windows with its clumsy way of changing keyboard layouts.

In Ubuntu, I simply click on the keyboard selection button and pick a keyboard layout.
AOO 4.1.5; Ubuntu 18.04
jrkrideau
Volunteer
 
Posts: 3574
Joined: Sun Dec 30, 2007 10:00 pm
Location: Kingston Ontario Canada

Re: Selecting different language for new writer doc doesn't

Postby Bill » Sat Oct 13, 2018 10:17 am

Namyo85 wrote:...no-one knows how to change the language setting in Open Office on Windows, even the people that made it. :!:

Have you asked the people that made it? They aren't here.

It's very easy to change the language setting in OpenOffice. What you can not do is make OpenOffice ignore the input language setting in Windows. If you have the input language in Windows set to English when you start typing, then OpenOffice will respect that English setting and change the language in OpenOffice to English even if you have changed the document language to Russian or any other language. If you don't want to set up the languages you're using as input languages in Windows, then you should try LibreOffice. They have added an option to make LO ignore the input language setting.

Writer: document language changes with keyboard layout - how to remove this behavior? [closed]

Note that while the title of the linked thread says "changes with keyboard layout", it should read "changes with input language". "Input language" affects the language while typing. "Keyboard layout" does not affect language. It only affects what character is generated when a key is pressed.
AOO 4.1.5 and LO 6.0.3.2 on Manjaro MATE
Bill
Volunteer
 
Posts: 6906
Joined: Sat Nov 24, 2007 6:48 am

Re: Selecting different language for new writer doc doesn't

Postby Namyo85 » Sat Oct 13, 2018 2:01 pm

I'm aware it's very easy to change the language settings in open office, what I'm trying to say is 'it doesn't work'. :roll: I take it the post above confirms that you have to change the language settings in Windows before changing the language setting in Office for the changes to remain? Again, I find that strange and a poor do really. I maintain that it should operate independently of what the OS language is set to, I don't understand why it hasn't been made to do that in the first place. I do appreciate the answers, they are helping actually, even if I come across slightly frustrated, which I am. There's a lot of questions and answers here and on different forums but they are fragmented and confusing. I'll work it out myself and I may even write a definitive guide to how to succesfully change the language settings in Open Office. 8-)
OpenOffice 4.1.5 on Windows 7
Namyo85
 
Posts: 8
Joined: Wed Oct 10, 2018 12:46 am
Location: UK

Re: Selecting different language for new writer doc doesn't

Postby Hagar Delest » Sat Oct 13, 2018 2:39 pm

Have you configured your styles with the correct languages?
Have you checked: [Tutorial] Spell check and Language configuration?

My machines are set to French (Linux & Windows) and I use either English or French in my documents with no issue at all.
AOO 4.1.6 on Xubuntu 18.10 and 4.1.5 on Windows 7 (with winPenPack port).
User avatar
Hagar Delest
Moderator
 
Posts: 28258
Joined: Sun Oct 07, 2007 9:07 pm
Location: France

Re: Selecting different language for new writer doc doesn't

Postby Namyo85 » Sat Oct 13, 2018 2:54 pm

Thanks but I've finally sussed it.
I can confirm that the Input language in the Operating System, in my case Windows 7, has to be changed in order to successfully change the language in Apache Open Office. Official confirmation! Wowsers! I am now in the process of writing a basic tutorial for new users who want to change the language in real time whilst using open office.
OpenOffice 4.1.5 on Windows 7
Namyo85
 
Posts: 8
Joined: Wed Oct 10, 2018 12:46 am
Location: UK

Re: Selecting different language for new writer doc doesn't

Postby esperantisto » Wed Oct 17, 2018 1:30 pm

writing a basic tutorial for new users who want to change the language in real time


You’re kidding! Does one need a basic tutorial to hit Alt+Shift (or Ctrl+Shift, or whatever keyboard shortcut is defined for shifting languages)?
AOO 4.2.0 / LibO 5.0.2.1 / Win 7 / openSUSE Linux 11.3 (32-bit) / 13.2 (64-bit)
esperantisto
Volunteer
 
Posts: 474
Joined: Mon Oct 08, 2007 1:31 am

Re: Selecting different language for new writer doc doesn't

Postby Bill » Wed Oct 17, 2018 2:27 pm

It's more than just hitting the keyboard shortcut. The keyboard shortcut doesn't change the language directly in OpenOffice. It changes the language in Windows and OpenOffice responds to that change. The main reason for a tutorial is to inform users that the language/keyboard layout must be installed in Windows. If the language/keyboard layout isn't installed, the keyboard shortcut won't do anything.
AOO 4.1.5 and LO 6.0.3.2 on Manjaro MATE
Bill
Volunteer
 
Posts: 6906
Joined: Sat Nov 24, 2007 6:48 am

Re: Selecting different language for new writer doc doesn't

Postby Namyo85 » Wed Oct 17, 2018 10:46 pm

Hi esperantisto, the tutorial is for how to change language in realtime for beginners, it isn't a tutorial on how to press Alt + Shift. Perhaps there's something you missed lol. :mrgreen:
OpenOffice 4.1.5 on Windows 7
Namyo85
 
Posts: 8
Joined: Wed Oct 10, 2018 12:46 am
Location: UK


Return to Writer

Who is online

Users browsing this forum: No registered users and 20 guests