[Solved] Format error discovered in the sub-document

Discuss the word processor

[Solved] Format error discovered in the sub-document

Postby Herntalad » Mon Apr 02, 2018 4:57 am

Hi everyone. I have an odt file that won't open due to a format error in the sub-document content. I know this has question has been answered on this forum -- there's even an excellent tutorial -- but alas, I find myself too ignorant to even follow the steps described to make the necessary fix. Can someone help walk me through this? Honestly, I can't even figure out step one, which is no knock against the tutorial. I am just out of my element, here.

Thanks!
Last edited by robleyd on Mon Apr 02, 2018 5:39 am, edited 2 times in total.
Reason: Add green tick [robleyd, Moderator]
OpenOffice 4.1.4 on Windows 10
Herntalad
 
Posts: 4
Joined: Mon Apr 02, 2018 4:31 am

Re: Format error discovered in the sub-document

Postby robleyd » Mon Apr 02, 2018 5:01 am

G'day, and welcome to the community forum.

I suggest you upload the document and let someone try and fix it for you.
[Forum] How to attach a document here Note maximum file size is 128K. If your file is larger, use a file sharing site such as Mediafire and post the link here.
Cheers
David
Apache OpenOffice 420m2(Build:9821) - Slackware 14.2 - 64 bit
LibreOffice 6.0.7.3 - Slackware 14.2 - 64 bit
Apache OpenOffice 4.1.4 - Windows 7 Virtual machine
User avatar
robleyd
Moderator
 
Posts: 3057
Joined: Mon Aug 19, 2013 3:47 am
Location: Murbko, Australia

Re: Format error discovered in the sub-document

Postby Herntalad » Mon Apr 02, 2018 5:08 am

Thanks, mate. Let's give it a try.
Last edited by Herntalad on Mon Apr 02, 2018 8:55 am, edited 1 time in total.
OpenOffice 4.1.4 on Windows 10
Herntalad
 
Posts: 4
Joined: Mon Apr 02, 2018 4:31 am

Re: Format error discovered in the sub-document

Postby robleyd » Mon Apr 02, 2018 5:15 am

If you PM me with an email address, I'll send you a hopefully fully repaired file.
Cheers
David
Apache OpenOffice 420m2(Build:9821) - Slackware 14.2 - 64 bit
LibreOffice 6.0.7.3 - Slackware 14.2 - 64 bit
Apache OpenOffice 4.1.4 - Windows 7 Virtual machine
User avatar
robleyd
Moderator
 
Posts: 3057
Joined: Mon Aug 19, 2013 3:47 am
Location: Murbko, Australia

Re: Format error discovered in the sub-document

Postby RoryOF » Mon Apr 02, 2018 5:24 am

I have no tools on this computer, but can see that the error is as John_Ha has identified in other similar files - multiple Annotations wrongly inserted in P1 style. How was the file edited - with OpenOffice, LibreOffice or MS Word?

If robleyd's repair is not good. I'll look at it later on another computer with the proper tools.
Apache OpenOffice 4.1.7 on Xubuntu 18.04.3 (mostly 64 bit version) and very infrequently on Win2K/XP
User avatar
RoryOF
Moderator
 
Posts: 29893
Joined: Sat Jan 31, 2009 9:30 pm
Location: Ireland

Re: Format error discovered in the sub-document

Postby robleyd » Mon Apr 02, 2018 5:34 am

For information, I removed all but one of the multiple Annotations. I experimented with removing the last Annotation but that gave a document of 213 pages compared to 234 in the first repair I did.
Cheers
David
Apache OpenOffice 420m2(Build:9821) - Slackware 14.2 - 64 bit
LibreOffice 6.0.7.3 - Slackware 14.2 - 64 bit
Apache OpenOffice 4.1.4 - Windows 7 Virtual machine
User avatar
robleyd
Moderator
 
Posts: 3057
Joined: Mon Aug 19, 2013 3:47 am
Location: Murbko, Australia

Re: Format error discovered in the sub-document

Postby Herntalad » Mon Apr 02, 2018 5:35 am

It's fixed! Amazing, thanks so much, robleyd!
OpenOffice 4.1.4 on Windows 10
Herntalad
 
Posts: 4
Joined: Mon Apr 02, 2018 4:31 am

Re: [Solved] Format error discovered in the sub-document

Postby RoryOF » Mon Apr 02, 2018 5:54 am

I think the Annotation not to remove is the shortest one. It would be helpful for fault-finding to know if this document originated in MS Word or has been Saved in MS Word .doc or .docx (which?) format.
Apache OpenOffice 4.1.7 on Xubuntu 18.04.3 (mostly 64 bit version) and very infrequently on Win2K/XP
User avatar
RoryOF
Moderator
 
Posts: 29893
Joined: Sat Jan 31, 2009 9:30 pm
Location: Ireland

Re: [Solved] Format error discovered in the sub-document

Postby Herntalad » Mon Apr 02, 2018 8:54 am

Hmmm...probably originated as docx, but not sure. Definitely has been saved back and forth from docx to odt.
OpenOffice 4.1.4 on Windows 10
Herntalad
 
Posts: 4
Joined: Mon Apr 02, 2018 4:31 am

Re: [Solved] Format error discovered in the sub-document

Postby RoryOF » Mon Apr 02, 2018 9:27 am

Has this ever been edited/saved by MS Word, or has it always been worked using OpenOffice or LibreOffice: if so, which? Help About will tell exact version of either. We are trying to track down the causer of this corruption and this information will be helpful.
Apache OpenOffice 4.1.7 on Xubuntu 18.04.3 (mostly 64 bit version) and very infrequently on Win2K/XP
User avatar
RoryOF
Moderator
 
Posts: 29893
Joined: Sat Jan 31, 2009 9:30 pm
Location: Ireland

Re: [Solved] Format error discovered in the sub-document

Postby John_Ha » Mon Apr 02, 2018 12:05 pm

See [Tutorial] Differences between Writer and MS Word files for why you should always work in and save files as .odt.
AOO 4.1.6, Windows 7 Home 64 bit

See the Writer Guide, the Writer FAQ, the Writer Tutorials and Writer for students.

Remember: Always save your Writer files as .odt files. - see here for the many reasons why.
John_Ha
Volunteer
 
Posts: 6947
Joined: Fri Sep 18, 2009 5:51 pm
Location: UK


Return to Writer

Who is online

Users browsing this forum: No registered users and 33 guests