Page 1 of 1

[Solved] Thesaurus stopped working...

PostPosted: Mon Jan 22, 2018 1:55 am
by roninwolf109
I recently upgraded my version of OpenOffice to the latest version and now my thesaurus has stopped working. The thesaurus window will open but it won't suggest any replacement words. I've even gone as far as uninstalling OpenOffice, downloading it again and reinstalling but nothing works. Thanks for your help! :)

Re: Thesaurus stopped working...

PostPosted: Mon Jan 22, 2018 2:23 am
by robleyd
A similar situation was reported in this post a couple of days ago.. The solution there may also help you.

Re: Thesaurus stopped working...

PostPosted: Mon Jan 22, 2018 2:36 am
by roninwolf109
Hm...nope... All the language options are set to the appropriate settings (American English). When I try to use it the original word I'm asking for suggestions to change is in the field at the top but there's nothing in the suggested window.

Re: Thesaurus stopped working...

PostPosted: Mon Jan 22, 2018 9:10 am
by Hagar Delest

Re: Thesaurus stopped working...

PostPosted: Mon Jan 22, 2018 1:12 pm
by Bill
roninwolf109 wrote:Hm...nope... All the language options are set to the appropriate settings (American English). When I try to use it the original word I'm asking for suggestions to change is in the field at the top but there's nothing in the suggested window.

By "American English", do you mean the default "English (USA)" or have you installed an additional dictionary for "American English"?

Re: Thesaurus stopped working...

PostPosted: Tue Jan 23, 2018 8:16 pm
by roninwolf109
The default English (USA) one.

Re: Thesaurus stopped working...

PostPosted: Tue Jan 23, 2018 9:22 pm
by Bill
roninwolf109 wrote:Hm...nope... All the language options are set to the appropriate settings (American English). When I try to use it the original word I'm asking for suggestions to change is in the field at the top but there's nothing in the suggested window.


Is there truly nothing in the Alternatives box or does it say "No alternatives found"?

Re: Thesaurus stopped working...

PostPosted: Tue Jan 23, 2018 10:06 pm
by Bill
Did you reset your user profile? I've been able to duplicate the problem by deleting the dictionary from the user profile. In that case, all language settings appear correct in Writer, but all words become underlined as misspelled and "Synonyms" and "Thesaurus" no longer appear on the context menu when right-clicking on a word. The Thesaurus window can still be opened by selecting Tools > Language > Thesaurus, but only "No alternatives found" appears in the Alternatives box. Resetting the user profile reinstalls the dictionary and the Thesaurus then works as expected.

Re: Thesaurus stopped working...

PostPosted: Thu Jan 25, 2018 7:02 pm
by roninwolf109
How do I do that? That's the exact problem I'm having save the spell checking thing.

Re: Thesaurus stopped working...

PostPosted: Thu Jan 25, 2018 7:11 pm
by jrkrideau
roninwolf109 wrote:How do I do that? That's the exact problem I'm having save the spell checking thing.


reset your OpenOffice user profile.

Re: Thesaurus stopped working...

PostPosted: Thu Jan 25, 2018 8:16 pm
by roninwolf109
That link wouldn't open. I managed to get into the user file...then what? I have no idea about computers. Thanks for everybody's help so far. :)

Re: Thesaurus stopped working...

PostPosted: Thu Jan 25, 2018 8:28 pm
by RoryOF
I have corrected an error in the link. Please click on it again and read the posting to which it refers, which will tell you what to do.

Re: Thesaurus stopped working...

PostPosted: Fri Jan 26, 2018 7:29 am
by roninwolf109
Hurray! It worked. Thanks everybody. I got it fixed.