[Solved] Thesaurus stopped working...

Discuss the word processor

[Solved] Thesaurus stopped working...

Postby roninwolf109 » Mon Jan 22, 2018 1:55 am

I recently upgraded my version of OpenOffice to the latest version and now my thesaurus has stopped working. The thesaurus window will open but it won't suggest any replacement words. I've even gone as far as uninstalling OpenOffice, downloading it again and reinstalling but nothing works. Thanks for your help! :)
Last edited by Hagar Delest on Fri Jan 26, 2018 8:58 am, edited 1 time in total.
Reason: tagged solved
OpenOffice 4.1.5 Windows 10
roninwolf109
 
Posts: 9
Joined: Mon Jan 22, 2018 1:48 am

Re: Thesaurus stopped working...

Postby robleyd » Mon Jan 22, 2018 2:23 am

A similar situation was reported in this post a couple of days ago.. The solution there may also help you.
Cheers
David
Apache OpenOffice 4.1.6 RC1 - Slackware 14.2 - 64 bit
Apache OpenOffice 4.1.4 - Windows 7 Virtual machine
User avatar
robleyd
Moderator
 
Posts: 2161
Joined: Mon Aug 19, 2013 3:47 am
Location: Murbko, Australia

Re: Thesaurus stopped working...

Postby roninwolf109 » Mon Jan 22, 2018 2:36 am

Hm...nope... All the language options are set to the appropriate settings (American English). When I try to use it the original word I'm asking for suggestions to change is in the field at the top but there's nothing in the suggested window.
OpenOffice 4.1.5 Windows 10
roninwolf109
 
Posts: 9
Joined: Mon Jan 22, 2018 1:48 am

Re: Thesaurus stopped working...

Postby Hagar Delest » Mon Jan 22, 2018 9:10 am

AOO 4.1.6 on Xubuntu 18.10 and 4.1.5 on Windows 7 (with winPenPack port).
User avatar
Hagar Delest
Moderator
 
Posts: 28256
Joined: Sun Oct 07, 2007 9:07 pm
Location: France

Re: Thesaurus stopped working...

Postby Bill » Mon Jan 22, 2018 1:12 pm

roninwolf109 wrote:Hm...nope... All the language options are set to the appropriate settings (American English). When I try to use it the original word I'm asking for suggestions to change is in the field at the top but there's nothing in the suggested window.

By "American English", do you mean the default "English (USA)" or have you installed an additional dictionary for "American English"?
AOO 4.1.5 and LO 6.0.3.2 on Manjaro MATE
Bill
Volunteer
 
Posts: 6900
Joined: Sat Nov 24, 2007 6:48 am

Re: Thesaurus stopped working...

Postby roninwolf109 » Tue Jan 23, 2018 8:16 pm

The default English (USA) one.
OpenOffice 4.1.5 Windows 10
roninwolf109
 
Posts: 9
Joined: Mon Jan 22, 2018 1:48 am

Re: Thesaurus stopped working...

Postby Bill » Tue Jan 23, 2018 9:22 pm

roninwolf109 wrote:Hm...nope... All the language options are set to the appropriate settings (American English). When I try to use it the original word I'm asking for suggestions to change is in the field at the top but there's nothing in the suggested window.


Is there truly nothing in the Alternatives box or does it say "No alternatives found"?
AOO 4.1.5 and LO 6.0.3.2 on Manjaro MATE
Bill
Volunteer
 
Posts: 6900
Joined: Sat Nov 24, 2007 6:48 am

Re: Thesaurus stopped working...

Postby Bill » Tue Jan 23, 2018 10:06 pm

Did you reset your user profile? I've been able to duplicate the problem by deleting the dictionary from the user profile. In that case, all language settings appear correct in Writer, but all words become underlined as misspelled and "Synonyms" and "Thesaurus" no longer appear on the context menu when right-clicking on a word. The Thesaurus window can still be opened by selecting Tools > Language > Thesaurus, but only "No alternatives found" appears in the Alternatives box. Resetting the user profile reinstalls the dictionary and the Thesaurus then works as expected.
AOO 4.1.5 and LO 6.0.3.2 on Manjaro MATE
Bill
Volunteer
 
Posts: 6900
Joined: Sat Nov 24, 2007 6:48 am

Re: Thesaurus stopped working...

Postby roninwolf109 » Thu Jan 25, 2018 7:02 pm

How do I do that? That's the exact problem I'm having save the spell checking thing.
OpenOffice 4.1.5 Windows 10
roninwolf109
 
Posts: 9
Joined: Mon Jan 22, 2018 1:48 am

Re: Thesaurus stopped working...

Postby jrkrideau » Thu Jan 25, 2018 7:11 pm

roninwolf109 wrote:How do I do that? That's the exact problem I'm having save the spell checking thing.


reset your OpenOffice user profile.
AOO 4.1.5; Ubuntu 18.04
jrkrideau
Volunteer
 
Posts: 3574
Joined: Sun Dec 30, 2007 10:00 pm
Location: Kingston Ontario Canada

Re: Thesaurus stopped working...

Postby roninwolf109 » Thu Jan 25, 2018 8:16 pm

That link wouldn't open. I managed to get into the user file...then what? I have no idea about computers. Thanks for everybody's help so far. :)
OpenOffice 4.1.5 Windows 10
roninwolf109
 
Posts: 9
Joined: Mon Jan 22, 2018 1:48 am

Re: Thesaurus stopped working...

Postby RoryOF » Thu Jan 25, 2018 8:28 pm

I have corrected an error in the link. Please click on it again and read the posting to which it refers, which will tell you what to do.
Apache OpenOffice 4.1.5 on Xubuntu 18.04 (mostly 64 bit version) and infrequently on Win2K/XP
User avatar
RoryOF
Moderator
 
Posts: 27472
Joined: Sat Jan 31, 2009 9:30 pm
Location: Ireland

Re: Thesaurus stopped working...

Postby roninwolf109 » Fri Jan 26, 2018 7:29 am

Hurray! It worked. Thanks everybody. I got it fixed.
OpenOffice 4.1.5 Windows 10
roninwolf109
 
Posts: 9
Joined: Mon Jan 22, 2018 1:48 am


Return to Writer

Who is online

Users browsing this forum: robleyd and 17 guests