Page 1 of 1

[Solved] Thesaurus works with doc but not with odt

PostPosted: Sat Jan 20, 2018 4:34 am
by Doddy
I have reinstalled Open Office after a computer crash and now find that Thesaurus only works with documents saved in .doc format but not in .odt.
Any explanation??

Re: Thesaurus works with doc but not with odt

PostPosted: Sat Jan 20, 2018 5:19 am
by RoryOF
Please upload a short sample document in each format.

Re: Thesaurus works with doc but not with odt

PostPosted: Sat Jan 20, 2018 5:47 am
by Doddy
Thanks for prompt response.
When checking files I found the problem.
In a document if language is set as English(USA) the thesaurus works.
If set to English (New Zealand) it doesn't
In the settings Tools/options/Language Settings/Languages the User Interface is set at English(USA).
I cannot change it as it is the only option.
The other three boxes are set at English(New Zealand)
Presumably I need to change the User interface to New Zealand but don't know how.
Cheers
Brian

Re: Thesaurus works with doc but not with odt

PostPosted: Sat Jan 20, 2018 1:24 pm
by Hagar Delest
Language settings in documents are not managed by the interface setting.
Since I don't have any New Zealand flavor in the default dictionary delivered with AOO, I guess that you've installed a specific one for New Zealand. If so, it may have no thesaurus. In this case, you can switch the language setting of the text to English US or tweak the NZ dictionary extension so that it uses the English thesaurus (never tried myself but quite sure it's feasible).

Re: Thesaurus works with doc but not with odt

PostPosted: Sun Jan 21, 2018 12:52 am
by Doddy
Thanks again.
After reading your message I googled "Open Office Thesaurus not working in English Language" and was directed to a site -
https://extensions.libreoffice.org/exte ... saurus/1.0
I went to the site and downloaded the extension.
Thesaurus now working!
Cheers