Arabic support - Writer hangs on OO 4.1.3

Discuss the word processor

Arabic support - Writer hangs on OO 4.1.3

Postby Anael » Sun Sep 24, 2017 10:39 am

Dear all,
I come to you confronted by a problem I am not quite sure to know how to tackle. For research purposes, I transcribe and translate documents in Arabic, having on the same page Arabic script (right-left) and latin script (left-right). For reasons still unknown to me, those documents have proved to be extremely sensitive and crash more often than one would wish. The first immediate cause of crash seems to be the beginning of new line, in continuation of the same sentence. OO then freezes. The second cause is the addition of a larger piece of text (a few pages), an action which almost immediately sends OO crashing.
I have tried to regularize formats, to no avail. The only technique that seemed to have any effect was to add page breaks, which appeared to alleviate the problem, but I have recently reached the limits of that solution.
You will find attached two versions. The first one (without parentheses) cannot be opened anymore and I would be curious to know if anyone can. The second is copy of the text of the first one, copied from Wordpad (not having any other idea). It can be opened but crashes as soon as I had more text.
Since I am discussing the problem of Arabic support, I also wish to understand why the first degree of bullets cannot be properly displayed when the text is set on right-left direction. Instead, a white 10 in a black circle appears. I changed the font format, without any effect.

I thank you for any remark or suggestion on the origins of those two problems.

Best,

A.
Attachments
Mahdiyya - 2-66-01 (nouvelle version).odt
Stable version
(30.93 KiB) Downloaded 9 times
Mahdiyya - 2-66-01.odt
Version that systematically crashes.
(31.84 KiB) Downloaded 12 times
Last edited by Anael on Tue Sep 26, 2017 9:27 am, edited 2 times in total.
OpenOffice 4.1.3 on Windows 10 (64)
Anael
 
Posts: 4
Joined: Sun Sep 24, 2017 10:17 am

Re: Arabic support - Constant crash on OO 4.1.3

Postby jrkrideau » Sun Sep 24, 2017 8:41 pm

I'm not set up for Right-to-Left text but both files open properly. As a first step, I recommend that you reset the User Profile . It often cures all sorts of strange behaviours in AOO.
Last edited by jrkrideau on Tue Sep 26, 2017 11:16 am, edited 3 times in total.
LibreOffice 5.1.4.2 Ubuntu 17.04 "Zesty Zapus"
jrkrideau
Volunteer
 
Posts: 3375
Joined: Sun Dec 30, 2007 10:00 pm
Location: Kingston Ontario Canada

Re: Arabic support - Constant crash on OO 4.1.3

Postby Anael » Sun Sep 24, 2017 11:50 pm

Thank you for your answer. I have just reset the user profile but OO still immediately crashes when I open this file. Weirdly enough, another file with Arabic script seems to work fine but I am at odds finding a reason for the different reaction of OO.

Thanks again.
OpenOffice 4.1.3 on Windows 10 (64)
Anael
 
Posts: 4
Joined: Sun Sep 24, 2017 10:17 am

Re: Arabic support - Constant crash on OO 4.1.3

Postby RusselB » Mon Sep 25, 2017 1:21 am

Loading the file listed as the Stable version, then using Edit -> Compare Document, then selecting the file marked as the one that crashes. the comparison dialog shows 16 changes between the two.
Additionally the two are not the same size.
You might want to look at the changes that the Compare Document lists to see if any of them look weird.
OpenOffice 4.1.4 and LibreOffice 5.2.7.2 on Windows 7 Pro & Ultimate
If you believe your problem has been resolved, please go to your first post in this topic, click the Edit button and add [Solved] to the beginning of the Subject line.
RusselB
Volunteer
 
Posts: 4157
Joined: Fri Jan 03, 2014 7:31 am
Location: Sarnia, ON

Re: Arabic support - Constant crash on OO 4.1.3

Postby John_Ha » Mon Sep 25, 2017 4:04 pm

Mahdiyya - 2-66-01.odt doesn't cause Writer to crash - it causes Writer to hang - ie not respond. When Writer hangs, it is consuming circa 50% of CPU and the memory used by soffice.bin continues to increase suggesting a recursive loop, or a memory leak.

I created a new, empty text document and went Insert > From file ..., and I inserted Mahdiyya - 2-66-01.odt and saved the file. The file is a little larger than before, and no longer causes Writer to hang.

I don't know why, but files sometimes seem to get "tangled" and doing this removes the "tangles" and fixes problems.

Anael wrote:The only technique that seemed to have any effect was to add page breaks, which appeared to alleviate the problem

See the discussion about footnotes, text spilling and Writer looping doing page layout, where adding page breaks is suggested as a cure, in [Solved] AOO stops responding when opening this one document

If this solves the problem, please view your first post in this thread and click the Edit button (top right in the post) and add [Solved] in front of the subject. Also, can I suggest you change "crash" to "hang" in the subject. I do not think being Arabic has anything to do with it.

 Edit: On further testing, the error seems to be associated with footnote 1. If I add extra empty paragraphs on that page so as to cause the line with the footnote 1 marker (5th from bottom) to spill, the repaired document then hangs.

If I delete the footnote, and re-insert it, the document does not hang and works properly. 
Attachments
Mahdiyya - 2-66-01 after Insert.odt
File after inserting it into a new, empty document
(32.11 KiB) Downloaded 7 times
AOO 4.1.4, Windows 7 Home 64 bit

See the Writer Manual, the Writer FAQ, the Writer Tutorials and the up to date Writer guide for information. Click the Help button on a pop-up window for extensive help on that function.
John_Ha
Volunteer
 
Posts: 4623
Joined: Fri Sep 18, 2009 5:51 pm
Location: UK

Re: Arabic support - Writer hangs on OO 4.1.3

Postby Anael » Tue Sep 26, 2017 9:49 am

Thank you infinitely for your time.
I had initially copied the text onto a new file, without any effect. On your indication, I have deleted the footnote, which indeed seemed to be causing the problem. If you don't mind, I am going to wait a few days to see how stable the document is.
I nonetheless believe this is linked with the Arabic script. The same kind of issue had not occurred to me before, but consistently with Arabic documents (even if not to the extent of this case).
I should very probably open a new thread, but since the question is linked with Arabic script, would you happen to have any idea on why the classic dot (U+2022) cannot be displayed properly, whereas the other sublevels work perfectly fine ?

Thanks again for your help.
OpenOffice 4.1.3 on Windows 10 (64)
Anael
 
Posts: 4
Joined: Sun Sep 24, 2017 10:17 am

Re: Arabic support - Writer hangs on OO 4.1.3

Postby John_Ha » Tue Sep 26, 2017 11:56 am

Anael wrote:...would you happen to have any idea on why the classic dot (U+2022) cannot be displayed properly, whereas the other sublevels work perfectly fine ?

Sorry - I don't know. What is wrong with it? It displays as a small filled dot - U+25CF is a large dot. I did notice that if I add an empty paragraph, and then type tabs, the dot changes shape repeatedly until it eventually stabilises!

I wondered if the problem could be something to do with the fact that the text is right to left, but the footnote is left to right. Also, was the document ever saved as as a .doc or .docx? Or was it ever edited using MS Word? Or have Edit > Changes ..., ever been used - especially if the document has been edited on MS Word.
Attachments
Clipboard01.png
Small and large dots
Clipboard01.png (4.32 KiB) Viewed 300 times
AOO 4.1.4, Windows 7 Home 64 bit

See the Writer Manual, the Writer FAQ, the Writer Tutorials and the up to date Writer guide for information. Click the Help button on a pop-up window for extensive help on that function.
John_Ha
Volunteer
 
Posts: 4623
Joined: Fri Sep 18, 2009 5:51 pm
Location: UK

Re: Arabic support - Writer hangs on OO 4.1.3

Postby Anael » Tue Sep 26, 2017 4:19 pm

The initial next was never altered by using any other text editor and the problem predates my copying of the text through MS Word. Not finding a better solution, I switched the dot to U+25CF. For some reason, the U+2022 just won't be displayed when set from right to left. Strangely, the other dots are displayed fine.
OpenOffice 4.1.3 on Windows 10 (64)
Anael
 
Posts: 4
Joined: Sun Sep 24, 2017 10:17 am

Re: Arabic support - Writer hangs on OO 4.1.3

Postby John_Ha » Tue Sep 26, 2017 4:25 pm

You may find that resetting the profile helps - see Resetting the user profile.
AOO 4.1.4, Windows 7 Home 64 bit

See the Writer Manual, the Writer FAQ, the Writer Tutorials and the up to date Writer guide for information. Click the Help button on a pop-up window for extensive help on that function.
John_Ha
Volunteer
 
Posts: 4623
Joined: Fri Sep 18, 2009 5:51 pm
Location: UK


Return to Writer

Who is online

Users browsing this forum: No registered users and 25 guests