Help with a form

Discuss the word processor

Help with a form

Postby NaturpawRD » Thu Sep 14, 2017 6:09 am

Hello everyone!! I'm making a form in OOO but came across an issue that i can't seem to find a way to fix. I opened this document in 3 different PDF viewers with the same problem showed in the image.

Any ideas on how can i make the end result form look like the document? I will leave the document below so you guys can check it out.

I'm no expert with Open Office so it might be a mess lol.

My document is in Spanish so don't mind it.

Thanks!
Attachments
formulario.odt
(49.02 KiB) Downloaded 21 times
prev 2.PNG
prev 2.PNG (9.08 KiB) Viewed 551 times
prev.PNG
prev.PNG (5.58 KiB) Viewed 551 times
OpenOffice 0.4 on Windows 7
NaturpawRD
 
Posts: 5
Joined: Thu Sep 14, 2017 5:53 am

Re: Help with a form

Postby jrkrideau » Thu Sep 14, 2017 11:06 am

Can you explain the problem in more detail? At the moment the .odt and pdf files look the same to me.

What am I missing?
LibreOffice 5.1.4.2 Ubuntu 17.04 "Zesty Zapus"
jrkrideau
Volunteer
 
Posts: 3375
Joined: Sun Dec 30, 2007 10:00 pm
Location: Kingston Ontario Canada

Re: Help with a form

Postby NaturpawRD » Thu Sep 14, 2017 2:22 pm

The blueish rectangle in the middle of the text boxes is not present when editing,even if I change the background to a color other than white,that rectangle still fills all of them,it appears in the PDF version only.

Sorry I didn't stop to actually explain it,my bad :p
OpenOffice 0.4 on Windows 7
NaturpawRD
 
Posts: 5
Joined: Thu Sep 14, 2017 5:53 am

Re: Help with a form

Postby Villeroy » Thu Sep 14, 2017 2:59 pm

I don't see these artefacts. It might be added by your PDF viewer. My PDF viewer is Evince on Linux.
Please, edit this topic's initial post and add "[Solved]" to the subject line if your problem has been solved.
Ubuntu 16.04, OpenOffice 4.x & LibreOffice 5.x
User avatar
Villeroy
Volunteer
 
Posts: 24656
Joined: Mon Oct 08, 2007 1:35 am
Location: Germany

Re: Help with a form

Postby NaturpawRD » Thu Sep 14, 2017 3:23 pm

I opened it in 3 different viewers: Adobe,Chrome's native PDF reader and Fox-it reader,all 3 had the same problem.
Last edited by NaturpawRD on Thu Sep 14, 2017 4:16 pm, edited 1 time in total.
OpenOffice 0.4 on Windows 7
NaturpawRD
 
Posts: 5
Joined: Thu Sep 14, 2017 5:53 am

Re: Help with a form

Postby jrkrideau » Thu Sep 14, 2017 3:32 pm

I have to agree with Villeroy. I do not see these artefacts in Okular or Evince in Ubuntu.

Ah, wait, if I open the file in Chrome I see the blue background. If I enter any data the box turns white during data entry and then the blue background returns.

Firefox opens the file with no background but tells me that "The filling of form fields is not supported".

@ Villeroy
What happens if you open the file in Chrome? Linux -- Windows difference perhaps?
LibreOffice 5.1.4.2 Ubuntu 17.04 "Zesty Zapus"
jrkrideau
Volunteer
 
Posts: 3375
Joined: Sun Dec 30, 2007 10:00 pm
Location: Kingston Ontario Canada

Re: Help with a form

Postby Villeroy » Thu Sep 14, 2017 4:41 pm

Firefox is my one and only browser. It could be related to a theme or something. Somewhere in the Windows control panel you can adjust the overall appearance of GUI elements and form controls.
Please, edit this topic's initial post and add "[Solved]" to the subject line if your problem has been solved.
Ubuntu 16.04, OpenOffice 4.x & LibreOffice 5.x
User avatar
Villeroy
Volunteer
 
Posts: 24656
Joined: Mon Oct 08, 2007 1:35 am
Location: Germany

Re: Help with a form

Postby keme » Wed Sep 20, 2017 8:10 am

At first I thought the problem was that the "Ciudad" field disappeared... :oops: This appeared to me a greater problem than field shadings

Markings for input fields is the default setting for most PDF readers I have used, but normally you can turn it off. In any case the shading will not appear on printed copies of the form.

In Adobe Reader you can adjust the marking of input fields like this:
Menu Edit - Settings or shortcut key ctrl+K. (... or something like that. My install is in Norwegian, so I can't say for sure what the English version would be. I suppose yours is in Spanish.)
See the Forms category (#6 counting from the bottom in my install)
User avatar
keme
Volunteer
 
Posts: 2663
Joined: Wed Nov 28, 2007 10:27 am
Location: Egersund, Norway

Re: Help with a form

Postby NaturpawRD » Thu Sep 21, 2017 3:48 pm

I will check it right away!
Mine is in English actually,its way easier.
OpenOffice 0.4 on Windows 7
NaturpawRD
 
Posts: 5
Joined: Thu Sep 14, 2017 5:53 am


Return to Writer

Who is online

Users browsing this forum: No registered users and 21 guests