Page 1 of 1

A.O.O. red lining common words

PostPosted: Sun May 14, 2017 8:16 pm
by Fred22
I have O.O. 4.1.1 on both my desktop and my laptop. Here's what I don't understand. I have a long list of names in my desktop doc. files. Not one name was marked as misspelled as I entered them. Then I put the file in my Dropbox, go to my desktop to print it off and several names were red lined as misspelled...even common surnames like Cassidy. Why would this happen if the doc. was originally made in 4.1.1 and opened in the same version on my desktop.

Re: A.O.O. red lining common words

PostPosted: Sun May 14, 2017 8:31 pm
by RusselB
While no one, to my knowledge, has been able to determine why this happens, the common solution is to reset your user profile.
Start by renaming your OpenOffice user profile.

As you are using Windows close OpenOffice and the Quickstarter. Open File Explorer.
Copy and paste %appdata%\OpenOffice\4 in the File Explorer (sometimes called Windows Explorer)
Address Bar and press Enter. Rename the "user" folder - "user.old" is a good choice.
Start OpenOffice.

This cures most spellcheck problems.

Re: A.O.O. red lining common words

PostPosted: Mon May 15, 2017 4:31 pm
by Fred22
RusselB wrote:While no one, to my knowledge, has been able to determine why this happens, the common solution is to reset your user profile.
Start by renaming your OpenOffice user profile.

As you are using Windows close OpenOffice and the Quickstarter. Open File Explorer.
Copy and paste %appdata%\OpenOffice\4 in the File Explorer (sometimes called Windows Explorer)
Address Bar and press Enter. Rename the "user" folder - "user.old" is a good choice.
Start OpenOffice.

This cures most spellcheck problems.

Not only did it not work, but now the files on my desktop, which I fixed yesterday are red lined again. When I went to the appdata thing I had 2 folders...one user and the one I'd renamed Fred. I believe I then deleted Fred, but things are still messed up. I haven't even tried to export my file from my laptop via Dropbox yet, but I know what's going to happen. Can you please tell me what I should do now? I don't want to change the settings on my laptop b/c there is no redlining in the file...only on my desktop...help please.

Re: A.O.O. red lining common words

PostPosted: Mon May 15, 2017 4:53 pm
by RoryOF
In OpenOffice /Tools /Options /Language Setting /Languages s what language is selected in "Default languages for documents : Western"; is this same language (to the precise variety) shown in the centre of the Status Bar (bottom bar) in OO Writer in one of your red-lined documents?

Re: A.O.O. red lining common words

PostPosted: Mon May 15, 2017 7:06 pm
by Fred22
Okay, I have language settings and it says, "This is where you make settings concerning language and writing aids etc. but I don't see anything re "default languages". Where is this located?

Re: A.O.O. red lining common words

PostPosted: Mon May 15, 2017 7:15 pm
by RoryOF
Click the black triangle to the left of the "Language Settings" in the lefthand panel. Then make your settings in the windows that open when you click on each of "Languages" and "Writing Aids".

Re: A.O.O. red lining common words

PostPosted: Mon May 15, 2017 7:39 pm
by Fred22
RoryOF wrote:Click the black triangle to the left of the "Language Settings" in the lefthand panel. Then make your settings in the windows that open when you click on each of "Languages" and "Writing Aids".
Okay I have it. It says "Default - English USA next to "Western"...what now? (Actually I don't see a black triangle..more like a square with + in the middle).

Re: A.O.O. red lining common words

PostPosted: Mon May 15, 2017 9:57 pm
by Hagar Delest
Some screenshots here: [Troubleshooting] Spell check in OpenOffice.

Please add [Solved] at the beginning of the title in your first post (top of the topic) with the edit button if your issue has been fixed.

Re: A.O.O. red lining common words

PostPosted: Mon May 15, 2017 10:04 pm
by RoryOF
The black triangle may be specific to a linux version; the square with + in the middle may be the Windows version.

Re: A.O.O. red lining common words

PostPosted: Mon May 15, 2017 10:46 pm
by Fred22
Hagar Delest wrote:Some screenshots here: [Troubleshooting] Spell check in OpenOffice.

Please add [Solved] at the beginning of the title in your first post (top of the topic) with the edit button if your issue has been fixed.

Sorry but this issue has not been fixed.

Re: A.O.O. red lining common words

PostPosted: Tue May 16, 2017 7:52 am
by Hagar Delest
Then tell us what is different from the screenshots.

Re: A.O.O. red lining common words

PostPosted: Tue May 16, 2017 2:50 pm
by Fred22
RoryOF wrote:The black triangle may be specific to a linux version; the square with + in the middle may be the Windows version.

Well I did as instructed: Tools, Options, Language Setting, etc. but didn't see "Default Languages for Docs." I did see that for writer and western? I believe that all language boxes said English - USA. there was also a box to be filled in which asked "what dictionary" but I didn't put anything there. I also uninstalled O.O. and then reinstalled from disc, but after that I got an error message "Fatal Error During Install" and all my doc's are still red lined. Now I don't mean the problem that I posted about here sometime ago when almost everything was red lined. This time most names weren't red lined but some common one's such as Haden, Cassidy and others were. Where do we go from here?

Re: A.O.O. red lining common words

PostPosted: Tue May 16, 2017 3:50 pm
by Villeroy
US-doc.odt
Text with language attribute en-USA
(17.03 KiB) Downloaded 163 times

Re: A.O.O. red lining common words

PostPosted: Tue May 16, 2017 5:08 pm
by RoryOF
Here are my settings within Writer

/Format /Styles and Formatting : press first icon from left, Right click on Default, select Modify, Font tab, Language English (UK) (blue ABC tick showing). OK out.

/Tools /Extension Manager, English spelling and hyphenation dictionary and thesaurus 20170.03.01 installed

/Tools /Options /Language settings /Languages : User interface default English (UK), Locale setting default English (UK), Default currency EUR € Irish [this won't affect spellcheck], Default Languages for Documents: Western English (UK) (blue tick showing)

/Tools /Options /Language settings /Writing aids : Writing Aids: Hunspell checker ticked, Language Tool ticked, LibHyphen hyphenator ticked, OpenOffice New Thesaurus ticked.

/Tools /Options /Language settings /Writing aids : User defined dictionaries : Business (all), soffice (all), IgnoreAlllist (all) all checked.

/Tools /Options /Language settings /Writing aids : Options: check spelling as you type checked, check grammar as you type checked [this last may be from Language Tool]

If you want a different variety of English, such as English (USA), substitute it in place of English (UK)

You may need to restart OpenOffice, including the OO Quickstarter, after making any of these corrections. I always suggest closing down computer and powering off after making such fundamental changes to a system.

On restart, open a new writer document. Is English(UK) shown to left of centre on status bar? If so, type dt then press F3. You get a screenful of text. greenbacks should be the only word flagged with a red wiggly underline, as far as I remember.

Note that the /Tools /Options paths will differ for Macs. I think /Options is under Preferences on a Mac.