[Solved] Interaction with clipboard in Windows 8

Discuss the word processor

[Solved] Interaction with clipboard in Windows 8

Postby franklekens » Thu Apr 10, 2014 8:17 am

Windows 8.1, Word 2013, OoO 4.0.
I select a word in Word. I copy it (CTRL+C). I go to Writer and press CTRL++SHIFT+V to paste without formatting: nothing happens.
I go to another application (Notepad, a rich text editor, doesn't matter wich) and press CTRL+V there: the word is pasted alright. So it is on the clipboard.

Why doesn't it want to be copied to Open Office? At least not without formatting?

It's not consistent: I copy all text in the document in Word, I paste that into Open Office: it works. I select another word: it works. I select another word: it doesn't work.
Last edited by thomasjk on Fri Apr 11, 2014 4:51 pm, edited 1 time in total.
Reason: Mark thread [Solved] and add green checkmark
--
Frank Lekens
OOo 4.4.0 on Ms Windows 8.1
(compatibility: MS Office 2013)
User avatar
franklekens
 
Posts: 133
Joined: Thu Oct 30, 2008 11:05 am
Location: Amsterdam

Re: interaction with clipboard in Windows 8

Postby John_Ha » Thu Apr 10, 2014 10:34 am

This works OK for me on Windows 7 where ctrl / shift / v brings up the Paste special menu. I assume that ctrl / v pastes OK into AOO for you, as does Edit > Paste and Edit > Paste special.

There are several things to check:

1 There have been reports of clipboard viewers and clipboard history applications interfering with AOO. Stop all these running and test again.

2 Add-ons can intefere, so disable all add-ons and retest.

3 Another application could have reserved the ctrl / shift / v sequence so it is not available to AOO. Restart the PC in Safe Mode (or temporarily disable all start-up programs using msconfig and reboot), and then start AOO on its own.

4 In the past, Windows' implementation of clipboard has left something to be desired and it could be a problemette with Windows 8 - googling might help

Your signature says XP and OOo 3.3.0.
AOO 4.1.6, Windows 7 Home 64 bit

See the Writer Manual, the Writer FAQ, the Writer Tutorials and the Writer guide.

Remember: Always save your Writer files as .odt files. - see here for the many reasons why.
John_Ha
Volunteer
 
Posts: 6576
Joined: Fri Sep 18, 2009 5:51 pm
Location: UK

Re: interaction with clipboard in Windows 8

Postby franklekens » Thu Apr 10, 2014 11:13 am

It's a very weird problem. It's intermittent.
You see, it's not that the CTRL+SHIFT+V doesn't work per se. If I paste from another application, it works fine in OoO.

And just now I tried again: copied a word in Word, special-pasted it with CTRL+SHIFT+V in Writer: it worked.
Copied a second word: CTRL+SHIFT+V doesn't give me the "special paste"menu.
Tried CTRL+C instead: nothing seemed to happen. But after a while, the word *was* pasted. As soon as I had done this, I could also perform CTRL+SHIFT+V.
Only the copying took longer. It seems as though something is making it hard for Open Office (or Windows) to paste, or to access the clipboard.
As though Word, after copying a word to clipboard, somehow locks up the clipboard that makes it harder to access -- but so far only for Open Office.

I've just noticed: after I've copied a word in Word, the menu options for copy, paste, special paste and even select text are greyed out in Open Office.


I have no 3rd party clipboard apps. I suspect the problem is somewhere with Office 2013 (maybe a recent update). But it's rather annoying.
Attachments
paste greyed out.jpg
paste greyed out.jpg (15.71 KiB) Viewed 9303 times
--
Frank Lekens
OOo 4.4.0 on Ms Windows 8.1
(compatibility: MS Office 2013)
User avatar
franklekens
 
Posts: 133
Joined: Thu Oct 30, 2008 11:05 am
Location: Amsterdam

Re: interaction with clipboard in Windows 8

Postby John_Ha » Thu Apr 10, 2014 11:54 am

franklekens wrote:And just now I tried again: copied a word in Word, special-pasted it with CTRL+SHIFT+V in Writer

It really would help the diagnosis if you stopped Word and all other applications from running so you can pin down exactly where the problem is when ONLY AOO is running, and by doing your copy from AOO and paste into AOO. As it is, we have no idea whether it is Word or AOO. If it happens when only AOO is running, and nothing else, we then know it is probably either AOO or Windows 8. Then start one other application - perhaps a browser - and copy some text from a web page and paste it into AOO. Then start MS Word and copy and paste.

The advantage of starting in Safe Mode is that it stops everything else from starting - even quick starters and background applications (like backup).

So, start the PC in Safe Mode (In W7, Start > type msconfig > enter > run msconfig > General > Diagnostic startup). Now restart the PC. Now start AOO only. Now disable all AOO add-ons. Now restart AOO and check all add-ons are still disabled.

 Edit: Be sure to note the original msconfig settings so you can set them back afterwards 


Does it still do it?
Last edited by John_Ha on Mon Aug 18, 2014 5:25 pm, edited 1 time in total.
AOO 4.1.6, Windows 7 Home 64 bit

See the Writer Manual, the Writer FAQ, the Writer Tutorials and the Writer guide.

Remember: Always save your Writer files as .odt files. - see here for the many reasons why.
John_Ha
Volunteer
 
Posts: 6576
Joined: Fri Sep 18, 2009 5:51 pm
Location: UK

Re: interaction with clipboard in Windows 8

Postby John_Ha » Thu Apr 10, 2014 1:03 pm

franklekens wrote:Only the copying took longer. It seems as though something is making it hard for Open Office (or Windows) to paste, or to access the clipboard.

That is a typical symptom of AOO clipboard interaction with another application (eg see Time delay when using copy/paste/cut when a clipboard viewer is running). Some applications which aren't clipboard viewers silently monitor the clipboard causing the same effect. See Comment 2 in OO does not paste the text contents of the Windows clipboard - instead, it pastes the previous text copied in OO which says:

Note that the user does not need to be running a Clipboard viewer to experience the delays because some applications apparently silently monitor the Clipboard without telling the user (by calls to the MS API function called SetClipboardViewer().)
AOO 4.1.6, Windows 7 Home 64 bit

See the Writer Manual, the Writer FAQ, the Writer Tutorials and the Writer guide.

Remember: Always save your Writer files as .odt files. - see here for the many reasons why.
John_Ha
Volunteer
 
Posts: 6576
Joined: Fri Sep 18, 2009 5:51 pm
Location: UK

Re: Interaction with clipboard in Windows 8

Postby franklekens » Fri Apr 11, 2014 11:00 am

Thank you for all the links and the explanations. The thing is, I didn't have a clipboard viewer running that I was aware of, and I had the distinct impression it occurred only when I tried to copy from MS Word, so I thought the problem resided there.

But now I think of it: I didn't have a clipboard viewer running, but I do have one installed, called AceText. It's partly integrated with Editpad (by the same author). I had that running when the problem started to occur, but I had thought to shut down AceText to rule that out.
Apparently, shutting down AceText, especially when Editpad is still running, doesn't kill it completely enough to get rid of this problem in Open Office.

Thanks for bearing with me on this.
--
Frank Lekens
OOo 4.4.0 on Ms Windows 8.1
(compatibility: MS Office 2013)
User avatar
franklekens
 
Posts: 133
Joined: Thu Oct 30, 2008 11:05 am
Location: Amsterdam

Re: Interaction with clipboard in Windows 8

Postby John_Ha » Fri Apr 11, 2014 11:14 am

Good. Please edit your original and add [Solved] it the problem has been resolved.

franklekens wrote:Apparently, shutting down AceText, especially when Editpad is still running, doesn't kill it completely enough to get rid of this problem in Open Office.

That is precisely why I asked you to boot in Safe Mode - it guarantees things like this are not started.
AOO 4.1.6, Windows 7 Home 64 bit

See the Writer Manual, the Writer FAQ, the Writer Tutorials and the Writer guide.

Remember: Always save your Writer files as .odt files. - see here for the many reasons why.
John_Ha
Volunteer
 
Posts: 6576
Joined: Fri Sep 18, 2009 5:51 pm
Location: UK


Return to Writer

Who is online

Users browsing this forum: No registered users and 14 guests