[Issue] Toolbar icons black out

Discuss the word processor

[Issue] Toolbar icons black out

Postby all4pink » Mon Sep 23, 2013 2:33 am

Just wondering if anyone knows why the toolbar icons would black out. (meaning they get black boxes over the top of them) Sometimes I can just click 'save' and they all go back to normal. I can also scroll my mouse across them and most of them go back to normal. But solving this issue would be quite joyful! :D
Last edited by Hagar Delest on Sat Jan 02, 2016 7:29 pm, edited 1 time in total.
Reason: tagged [Issue] (link to a bug report).
OpenOffice 3.4.1 on Windows 7
all4pink
 
Posts: 21
Joined: Tue Apr 30, 2013 7:04 pm

Re: toolbar icons black out

Postby Zizi64 » Mon Sep 23, 2013 7:09 am

I never seen this issue.

Maybe your PC is too slow, (or it is slow down by another running applications)
Or maybe it is a videocard driver issue...

Can you upload a screenshot about it?

This problem has occurred recently, or is this a permanent problem since you have installed the AOO3.4.1 on Win7?
Tibor Kovacs, Hungary; LO6.1.6, 6.2.8 /Win7-10 x64Prof.
PortableApps/winPenPack: LO3.3.0-6.4.5;AOO4.1.7
Please, edit the initial post in the topic: add the word [Solved] at the beginning of the subject line - if your problem has been solved.
User avatar
Zizi64
Volunteer
 
Posts: 9614
Joined: Wed May 26, 2010 7:55 am
Location: Budapest, Hungary

Re: Toolbar icons black out

Postby all4pink » Tue Sep 24, 2013 7:14 am

I have tried to snip a screenshot, and "prt sc sysrq" it...but it won't copy here for me. And I don't know how to bring it in from my files. But I do have a screenshot of it if you can tell me how to get it posted.

I have had this problem off and on for a while. It quit for a while after the upgrade, but now it has started doing it again.

Oh yeah, and my PC has been running real slow the past few weeks and I cannot figure out why.
OpenOffice 3.4.1 on Windows 7
all4pink
 
Posts: 21
Joined: Tue Apr 30, 2013 7:04 pm

Re: Toolbar icons black out

Postby Hagar Delest » Tue Sep 24, 2013 8:12 am

Save the screenshot as .png, crop it if needed and upload it (see How to attach a document here).

If your machine is running slowly, you should check your system with some free utility. And make a anti-virus scan of course.
AOO 4.1.7 on Xubuntu 20.04 and 4.1.5 on Windows 10 (with winPenPack port).
User avatar
Hagar Delest
Moderator
 
Posts: 29006
Joined: Sun Oct 07, 2007 9:07 pm
Location: France

Re: Toolbar icons black out

Postby all4pink » Wed Sep 25, 2013 8:00 pm

attaching the screen shot. Most times all of the icons are blacked...this screenshot shows only about half of them blacked.

I will troubleshoot my system with a utility check.
Attachments
screenshot.png
OpenOffice 3.4.1 on Windows 7
all4pink
 
Posts: 21
Joined: Tue Apr 30, 2013 7:04 pm

Re: Toolbar icons black out

Postby all4pink » Wed Sep 25, 2013 8:06 pm

here is a better one with most of them blacked out.
Attachments
screenshot.png
OpenOffice 3.4.1 on Windows 7
all4pink
 
Posts: 21
Joined: Tue Apr 30, 2013 7:04 pm

Re: Toolbar icons black out

Postby Hagar Delest » Wed Sep 25, 2013 8:58 pm

Tools>Options>OO>View, make sure that Icon size and style field is not set to High contrast.

Please add [Solved] at the beginning of the title in your first post (top of the topic) with the edit button if your issue has been fixed.
AOO 4.1.7 on Xubuntu 20.04 and 4.1.5 on Windows 10 (with winPenPack port).
User avatar
Hagar Delest
Moderator
 
Posts: 29006
Joined: Sun Oct 07, 2007 9:07 pm
Location: France

Re: Toolbar icons black out

Postby all4pink » Wed Sep 25, 2013 9:31 pm

It is set on Automatic (Galaxy) default.
OpenOffice 3.4.1 on Windows 7
all4pink
 
Posts: 21
Joined: Tue Apr 30, 2013 7:04 pm

Re: Toolbar icons black out

Postby Hagar Delest » Wed Sep 25, 2013 11:42 pm

If you change the theme of your Windows account, does it help?
AOO 4.1.7 on Xubuntu 20.04 and 4.1.5 on Windows 10 (with winPenPack port).
User avatar
Hagar Delest
Moderator
 
Posts: 29006
Joined: Sun Oct 07, 2007 9:07 pm
Location: France

Re: Toolbar icons black out

Postby Bill » Thu Sep 26, 2013 2:40 am

Themes can be disabled for AOO. Right-click the AOO shortcut on the Start Menu and select Properties. Click the Compatibility tab and check the "Disable visual themes" setting.
AOO 4.1.7 on Manjaro Cinnamon
Bill
Volunteer
 
Posts: 7926
Joined: Sat Nov 24, 2007 6:48 am

Re: Toolbar icons black out

Postby all4pink » Thu Sep 26, 2013 2:52 am

I did as Bill suggested. The box was unclicked, so I hope that will solve it.

I do not know how to change the windows theme, if that is necessary.

I also ran some utilities to clean up and speed up the computer, so hoping that will help, too.

I will post solved if that problem does not reoccur.
Thank you for all the suggestions! :)
OpenOffice 3.4.1 on Windows 7
all4pink
 
Posts: 21
Joined: Tue Apr 30, 2013 7:04 pm

Re: Toolbar icons black out

Postby Bill » Thu Sep 26, 2013 3:01 am

You may be able to find the Theme settings by right-clicking the Desktop and selecting Personalize. I don't have Windows 7.
AOO 4.1.7 on Manjaro Cinnamon
Bill
Volunteer
 
Posts: 7926
Joined: Sat Nov 24, 2007 6:48 am

Re: Toolbar icons black out

Postby all4pink » Fri Sep 27, 2013 7:26 am

Oh, that theme. Yes I know how to do that but don't understand what that would have to do with open office. So far today the icons have not blacked out but I also cannot now open the files from the "open" file tab when you first open OO. Neither would it let me 'save as' so I could do a back up of the document I had open. I closed OO out and restarted the computer but same problem....
And when you are in the document, it won't open my files from the icon that looks like a file folder....I have to go 'through the backdoor' to my files and open it from there. All I did was what Bill suggested:
[[Themes can be disabled for AOO. Right-click the AOO shortcut on the Start Menu and select Properties. Click the Compatibility tab and check the "Disable visual themes" setting.]] That is the only thing I have changed and I don't see how that could keep my files from opening.

I have Microsoft Word 2010, but I just prefer using OO the most, and in spite of challenges I really don't want to change!!!! :roll:
OpenOffice 3.4.1 on Windows 7
all4pink
 
Posts: 21
Joined: Tue Apr 30, 2013 7:04 pm

Re: Toolbar icons black out

Postby Hagar Delest » Fri Sep 27, 2013 7:55 am

all4pink wrote:Oh, that theme. Yes I know how to do that but don't understand what that would have to do with open office.

I guess that AOO adapt its rendering depending on the theme used (dark/bright/high contrast, ...).

As for the other issues, try to reset your OpenOffice user profile.
AOO 4.1.7 on Xubuntu 20.04 and 4.1.5 on Windows 10 (with winPenPack port).
User avatar
Hagar Delest
Moderator
 
Posts: 29006
Joined: Sun Oct 07, 2007 9:07 pm
Location: France

Re: Toolbar icons black out

Postby all4pink » Fri Sep 27, 2013 8:08 pm

I have reset my user profile several times in the recent past for issues, therefore I already have user.old in the file location. (also user)

I changed user.old to user.old2 and I am still having the same problem...can't access the files from the open file icon.
OpenOffice 3.4.1 on Windows 7
all4pink
 
Posts: 21
Joined: Tue Apr 30, 2013 7:04 pm

Re: Toolbar icons black out

Postby Bill » Fri Sep 27, 2013 8:40 pm

Please elaborate on "can't access the files". Is there an error message? Does the Open dialog fail to appear? Can you select files?
AOO 4.1.7 on Manjaro Cinnamon
Bill
Volunteer
 
Posts: 7926
Joined: Sat Nov 24, 2007 6:48 am

Re: Toolbar icons black out

Postby all4pink » Fri Sep 27, 2013 9:50 pm

The open dialog fails to appear. It does nothing when I click on the button/icon. Same thing with the 'save as' button. Usually, when I click on them, it opens up my file browser.
OpenOffice 3.4.1 on Windows 7
all4pink
 
Posts: 21
Joined: Tue Apr 30, 2013 7:04 pm

Re: Toolbar icons black out

Postby Hagar Delest » Fri Sep 27, 2013 10:00 pm

Perhaps you should try to remove AOO, clean the registry and reinstall.
AOO 4.1.7 on Xubuntu 20.04 and 4.1.5 on Windows 10 (with winPenPack port).
User avatar
Hagar Delest
Moderator
 
Posts: 29006
Joined: Sun Oct 07, 2007 9:07 pm
Location: France

Re: Toolbar icons black out

Postby Bill » Fri Sep 27, 2013 10:31 pm

all4pink wrote:The open dialog fails to appear. It does nothing when I click on the button/icon. Same thing with the 'save as' button. Usually, when I click on them, it opens up my file browser.

Sometimes the dialog opens off-screen and has to be moved back to the screen. To move a dialog back to the screen, press ALT+Space. If the dialog is off-screen, a menu will appear at the edge of the screen. Select Move on the menu, then use the arrow keys to move the window.
AOO 4.1.7 on Manjaro Cinnamon
Bill
Volunteer
 
Posts: 7926
Joined: Sat Nov 24, 2007 6:48 am

Re: Toolbar icons black out

Postby KFerland » Sat Sep 28, 2013 10:46 pm

Hello - I have the same issue with blacked out toolbar icons. I previously was running Open Office 3.0 but my spreadsheet software was rendered useless for me because of this.

Today I upgraded to Open Office 4.0 and the problem was initially fixed but after toggling between sheets, the problem came back. A "save as" has solved it for now, but I expect the issue to return and would welcome any suggestions.

Thanks,

Katie
OpenOffice 4.0 installed on Windows 7 Home Premium
KFerland
 
Posts: 1
Joined: Sat Sep 28, 2013 10:42 pm

Re: Toolbar icons black out

Postby all4pink » Sun Sep 29, 2013 4:45 am

I did everything suggested by the last 2 posts, including uninstalling, re-downloading, cleaning the registery, and reinstalling AOO.
I still cannot open the file dialog box (if that's what you call it) or do save as.
(sigh)
OpenOffice 3.4.1 on Windows 7
all4pink
 
Posts: 21
Joined: Tue Apr 30, 2013 7:04 pm

Re: Toolbar icons black out

Postby all4pink » Sun Sep 29, 2013 5:09 am

So I decided to try uninstalling and running the registry cleaner again. It found these files and it won't fix them because it says they can't be found, and suggests I delete the registry value...guess they expect if you are using a registry cleaner that you should know how to delete the registry value.
This is all seeming like too much trouble and is taking too much time. I'm pretty close to giving up and giving in to using Microsoft works. :(
Attachments
CCleaner screenshot.png
OpenOffice 3.4.1 on Windows 7
all4pink
 
Posts: 21
Joined: Tue Apr 30, 2013 7:04 pm

Re: Toolbar icons black out

Postby all4pink » Sun Sep 29, 2013 5:25 am

Yeah Katie! Thanks for posting! At least I know I am not going crazy here.
OpenOffice 3.4.1 on Windows 7
all4pink
 
Posts: 21
Joined: Tue Apr 30, 2013 7:04 pm

Re: Toolbar icons black out

Postby all4pink » Sun Sep 29, 2013 6:41 am

Whooohooo! It's working now! Cross my fingers it stays. I followed the file trail from those screenshots I sent and found an OpenOffice 3 that was still in there and hand deleted that...ran the CCleaner again, the reinstalled and so far it is working!
Hope this works for you, too, Katie. Good luck!

PS I will post solved after a couple days to make sure it's working good first. :)
OpenOffice 3.4.1 on Windows 7
all4pink
 
Posts: 21
Joined: Tue Apr 30, 2013 7:04 pm

Re: Toolbar icons black out

Postby all4pink » Mon Oct 07, 2013 3:57 am

After about a week of using AOO I am still having the icons black out occasionally...But I am really glad my files are working good, so I will just deal with it as is for now.
OpenOffice 3.4.1 on Windows 7
all4pink
 
Posts: 21
Joined: Tue Apr 30, 2013 7:04 pm

Re: Toolbar icons black out

Postby jolly » Sat Jun 28, 2014 12:32 pm

Having same problem in spreadsheet
Also affects comments when I click in those
Checked view and contrast - set to Galaxy
any suggestions?
Open office 3.4.1 on Windows 7
jolly
 
Posts: 1
Joined: Sat Jun 28, 2014 12:28 pm

Re: Toolbar icons black out -reproduced

Postby whbecker3500 » Mon Dec 21, 2015 10:02 pm

I have had this problem intermittently and could never pin it down. I had to do a reboot to restore proper operation. However I have just realized that I can reproduce this behavior. I am running Kaspersky Internet Security. All is well until I open Kaspersky's "Safe Money" browser window. Then any open documents (either OpenOffice or Libre Office) show the "black icon" problem and scrolling in the document doesn't work properly. Closing the Kaspersky browser window and re-opening the document fixes the problem. Maybe this will be a clue that can help a developer run down the cause.
OpenOffice 4.0.4 on Windows 7Pro x64
whbecker3500
 
Posts: 1
Joined: Fri Apr 25, 2014 8:06 pm

Re: Toolbar icons black out

Postby schattenmann » Sat Jan 02, 2016 1:45 pm

Thank you, whbecker3500! Kaspersky's safe money browser is causing the problem on my system, too. Now that I know this, I can work around it.
OpenOffice 4.1.2 on Windows 8.1
schattenmann
 
Posts: 1
Joined: Sat Jan 02, 2016 1:41 pm

Re: Toolbar icons black out

Postby Hagar Delest » Sat Jan 02, 2016 7:28 pm

Thanks!
I've reported it as a bug, perhaps the devs will be able to fix it: Issue 126767 - Toolbar icons black out
AOO 4.1.7 on Xubuntu 20.04 and 4.1.5 on Windows 10 (with winPenPack port).
User avatar
Hagar Delest
Moderator
 
Posts: 29006
Joined: Sun Oct 07, 2007 9:07 pm
Location: France

Re: [Issue] Toolbar icons black out

Postby oonumberoo » Wed Mar 02, 2016 8:20 pm

I have the same black outs, but only when I am working on a website built using Drupal.
I always type text on the website, copy it, and past it into a blank OpenOffice document to then check the spelling. The icons will always be black when the blank page opens.
Don't ask why I prefer to type on the website rather than OpenOffice in the first place.
Thanks.
OpenOffice 3.1 on Windows 7
oonumberoo
 
Posts: 1
Joined: Wed Mar 02, 2016 8:12 pm


Return to Writer

Who is online

Users browsing this forum: No registered users and 14 guests