Cannot change subscript/superscript size

Discuss the word processor
Post Reply
timvg
Posts: 8
Joined: Wed Feb 13, 2013 4:17 pm

Cannot change subscript/superscript size

Post by timvg »

Since upgrading from LibreOffice3 to 4, I have not been able to change the default sizes of both superscript and subscript. I managed to do it last time by going into the styles and formatting and setting them under the 'Position' tab. However, changing the relative font size and position now has no effect. I can still change the size manually by highlighting the relevant text and then changing it via the Format -> Character menu, but I would really like to set the changes as default.

If anyone could help me with this it would be great as it was a really nice feature, and the size at the moment is just way too small.

Tim
LibreOffice 4.0.0.3 Ubuntu 12.04
jrkrideau
Volunteer
Posts: 3813
Joined: Sun Dec 30, 2007 10:00 pm
Location: Kingston Ontario Canada

Re: Cannot change subscript/superscript size

Post by jrkrideau »

timvg wrote:Since upgrading from LibreOffice3 to 4, I have not been able to change the default sizes of both superscript and subscript. I managed to do it last time by going into the styles and formatting and setting them under the 'Position' tab. However, changing the relative font size and position now has no effect. I can still change the size manually by highlighting the relevant text and then changing it via the Format -> Character menu, but I would really like to set the changes as default.

If anyone could help me with this it would be great as it was a really nice feature, and the size at the moment is just way too small.

Tim
I don't quite understand what you are doing. Has LibreOffice included a superscript and a subscript Style. I don't see one in 3.6.2.2. Otherwise have you defined new Styles?
LibreOffice 7.1.5.2; Ubuntu 21.10
timvg
Posts: 8
Joined: Wed Feb 13, 2013 4:17 pm

Re: Cannot change subscript/superscript size

Post by timvg »

Hi there, thanks for the reply. Ok, maybe I wasn't too clear in my first post. What I want to do is to change the default size of the super/sub-script as the default of 58% relative font size is too small for my liking. I remember from before that I went into Styles and Formatting, then modified the relevant style that was using by making the following adjustment in the 'Position' tab: I changed both the superscript and subscript relevant font size settings to 70%. This is the method that is described in the LibreOffice writer guide as it states that these setting change the behaviour of the super/sub-scripts when selected with CTRL+SHIFT P or B. When I change these settings, the preview that is given at the bottom looks exactly how I want it to - but when I click Apply and then type text into the document, no changes have taken effect. If, on the other hand, I highlight the relevant super/sub-script and then go to Format -> Character and change the relevant font size, I get the desired outcome. But this is not a good work-around as it requires manually selecting and changing every instance.
LibreOffice 4.0.0.3 Ubuntu 12.04
User avatar
RoryOF
Moderator
Posts: 33478
Joined: Sat Jan 31, 2009 9:30 pm
Location: Ireland

Re: Cannot change subscript/superscript size

Post by RoryOF »

Have you unchecked the Automatic checkbox beside the settings? "Automatic" checked forces the normal 58% etc settings.
Apache OpenOffice 4.1.12 on Xubuntu 20.04.4 and very infrequently on Win2K/XP
timvg
Posts: 8
Joined: Wed Feb 13, 2013 4:17 pm

Re: Cannot change subscript/superscript size

Post by timvg »

Sorry, forgot to mention that bit. Yes, I did do that. However... on that note, I have noticed something interesting. I uncheck the 'Automatic' box and then click Apply, then OK... but when I reopen the settings by selecting 'modify', the boxes are checked again! I think this could be the root of the problem. However, I have no idea how to fix it.
LibreOffice 4.0.0.3 Ubuntu 12.04
User avatar
RoryOF
Moderator
Posts: 33478
Joined: Sat Jan 31, 2009 9:30 pm
Location: Ireland

Re: Cannot change subscript/superscript size

Post by RoryOF »

If you change the settings by using /Format /Character, as far as I know this only changes the settings for the current selection. If you change the settings in /Format /Styles and Formatting by right clicking on the paragraph style in use and selecting Modify, they should be applied to every instance of the paragraph style. At least, that is what is happening in my test example (AOO 3.4.1 on Xubuntu 12.10).
Apache OpenOffice 4.1.12 on Xubuntu 20.04.4 and very infrequently on Win2K/XP
timvg
Posts: 8
Joined: Wed Feb 13, 2013 4:17 pm

Re: Cannot change subscript/superscript size

Post by timvg »

Yes, that's what I thought. The problem that I am having is that as soon as I close the settings window (that comes up when I right click an select 'modify'), the 'Automatic' selection gets checked again. It seems as though I just cannot turn it off from defaulting back to that. It remembers my selection of 70%, but this is clearly having no effect as it immediately returns to the automatic setting.
LibreOffice 4.0.0.3 Ubuntu 12.04
timvg
Posts: 8
Joined: Wed Feb 13, 2013 4:17 pm

Re: Cannot change subscript/superscript size

Post by timvg »

Is there anyone that can help me with this? I am sure that I following all of the instructions correctly but it is making no difference. Can anyone see if I am doing something wrongly, or should I file this as a bug?
LibreOffice 4.0.0.3 Ubuntu 12.04
jrkrideau
Volunteer
Posts: 3813
Joined: Sun Dec 30, 2007 10:00 pm
Location: Kingston Ontario Canada

Re: Cannot change subscript/superscript size

Post by jrkrideau »

timvg wrote:Is there anyone that can help me with this? I am sure that I following all of the instructions correctly but it is making no difference. Can anyone see if I am doing something wrongly, or should I file this as a bug?
I think I'd file a bug report. If I understood what you are doing I think I had the same problem in L/O 3.6.2.2 (Build ID: 360m1(Build:2)). It does not seem to save the setting.
LibreOffice 7.1.5.2; Ubuntu 21.10
Post Reply