[Issue] Pasting from clipboard will not work sometimes

Discuss the word processor

[Issue] Pasting from clipboard will not work sometimes

Postby kryman » Sat Mar 09, 2013 1:43 am

Hi,

This problem or strange thing has occurred several times, hence I created this topic asking for help. Many times when I copy content from the web (ctrl+c) and paste it into Writer (ctrl+v) that content will not be copied which is marked but only the last copy from the clipboard. For example, first I copy "hello there" from the web, this works fine pasting into writer, secondly I remove that text and copy another text from the same site "some other info" but Writer pastes still the old info from the clipboard "hello there", not the new one? And to assure that I've done it right, as always, in my reliable notepad++ when I copy the same text from the site into n++ the new text appears.

What's going on? Is there some odd clipboard cache that is stuck (if there even can be such thing), or, what is it, since I have no clue.
Last edited by Hagar Delest on Sat Jul 27, 2013 9:22 am, edited 1 time in total.
Reason: tagged [Issue] (link to a bug report).
LibreOffice 5 (5.1.4.2 (x64)) on Win 10 Pro
kryman
 
Posts: 45
Joined: Mon Dec 10, 2012 2:48 am

Re: Pasting from clipboard will not work sometimes

Postby eremmel » Sat Mar 09, 2013 8:42 pm

Windows has a complex clip board. Selected data is put into different formats in the clipboard. It might that your browser is e.g. filling only one type, or that OO looks at the wrong section. I think that you should not try to validate with Notepad++ for it is a text only editor. I think WordPad is a better way to test.

You can always try to past in OO via menu: Edit Past-special (Ctrl-Shift-V) you will see different data-formats. You can now check which section contains the right text.
It's Microsoft marketing that tells you computers are qualified for non-technicians
eremmel
 
Posts: 1041
Joined: Tue Dec 30, 2008 1:15 am

Re: Pasting from clipboard will not work sometimes

Postby Hagar Delest » Sat Mar 09, 2013 10:06 pm

We have seen such issues indeed in the forum.
The workaround is to copy and paste content from your document to your document to somehow reset the clipboard.

Please add '[Solved]' at the beginning of your first post title (edit button) if your issue has been fixed.
AOO 4.1.7 on Xubuntu 20.04 and 4.1.5 on Windows 10 (with winPenPack port).
User avatar
Hagar Delest
Moderator
 
Posts: 28951
Joined: Sun Oct 07, 2007 9:07 pm
Location: France

Re: Pasting from clipboard will not work sometimes

Postby kryman » Sun Mar 10, 2013 12:01 am

Hagar Delest wrote:We have seen such issues indeed in the forum.
The workaround is to copy and paste content from your document to your document to somehow reset the clipboard.

You mean copy the info from the web into notepad++ (or any other) and then copy from notepad++ back into writer?
LibreOffice 5 (5.1.4.2 (x64)) on Win 10 Pro
kryman
 
Posts: 45
Joined: Mon Dec 10, 2012 2:48 am

Re: Pasting from clipboard will not work sometimes

Postby Hagar Delest » Sun Mar 10, 2013 12:08 am

No. Before copying the content from the web, try to copy something from your Writer document to this same document (and delete it just afterward). Then try to copy and paste the web content.
AOO 4.1.7 on Xubuntu 20.04 and 4.1.5 on Windows 10 (with winPenPack port).
User avatar
Hagar Delest
Moderator
 
Posts: 28951
Joined: Sun Oct 07, 2007 9:07 pm
Location: France

Re: Pasting from clipboard will not work sometimes

Postby kryman » Wed Mar 13, 2013 11:48 pm

I tried copy the content in the same odt on different locations, but it didn't work. It just copied the same previous clipboard content. So, there is nothing else to do?
LibreOffice 5 (5.1.4.2 (x64)) on Win 10 Pro
kryman
 
Posts: 45
Joined: Mon Dec 10, 2012 2:48 am

Re: Pasting from clipboard will not work sometimes

Postby Hagar Delest » Thu Mar 14, 2013 11:16 am

Have you tried to copy some text from that file to another place in the same file? I mean, not something that comes from outside the file.
AOO 4.1.7 on Xubuntu 20.04 and 4.1.5 on Windows 10 (with winPenPack port).
User avatar
Hagar Delest
Moderator
 
Posts: 28951
Joined: Sun Oct 07, 2007 9:07 pm
Location: France

Re: Pasting from clipboard will not work sometimes

Postby kryman » Thu Mar 14, 2013 1:01 pm

But what good will this do? Then the copied text in the clipboard from the web will be erased. Please let me know.
LibreOffice 5 (5.1.4.2 (x64)) on Win 10 Pro
kryman
 
Posts: 45
Joined: Mon Dec 10, 2012 2:48 am

Re: Pasting from clipboard will not work sometimes

Postby jrkrideau » Thu Mar 14, 2013 2:27 pm

kryman wrote:But what good will this do? Then the copied text in the clipboard from the web will be erased. Please let me know.


I believe Hagar is saying that you need to flush the clipboard and such a cut and paste should do that. You will then need to go back to the website and recopy the material you want from there.

eremmel is saying that the Windows clipboard is complex and your browser is probably getting confused for some reason. Thus Hagar's suggestion to reset the clipboard by doing a really simple cut and paste.
LibreOffice 6.4.3.2; Ubuntu 20.04
jrkrideau
Volunteer
 
Posts: 3788
Joined: Sun Dec 30, 2007 10:00 pm
Location: Kingston Ontario Canada

Re: Pasting from clipboard will not work sometimes

Postby Geof » Sun Apr 21, 2013 7:19 pm

Reset the clipboard with the Windows utility: clipbrd.exe .
On Windows XP and earlier you should find clipbrd.exe in the or C:\Windows\System32\ directory. (or maybe C:\Windows\System\)
You won't find it in Windows 7 however: copy and paste it into C:\Windows\System32\ from an old copy of XP, create a desktop shortcut and problem solved.
OpenOffice 3.4.1 on Windows 7 Professional
Geof
 
Posts: 1
Joined: Sun Apr 21, 2013 6:55 pm

Re: Pasting from clipboard will not work sometimes

Postby obswob » Mon Apr 29, 2013 10:29 am

Have you tried deleting your user profile?
c:\users\yourname\appdata\roaming\openoffice.org\3\user.
Delete or rename that folder.

I've had problems where paste would only paste old content, a bit like what you say. Doing this fixed it, along will all kinds of other bizarre intermittent bugs.
OpenOffice 3.4.1 on Windows 8
obswob
 
Posts: 23
Joined: Mon Mar 11, 2013 1:22 am

Re: Pasting from clipboard will not work sometimes

Postby kryman » Tue Jul 02, 2013 11:56 am

I still have an endless problem with pasting. I have noticed that very often (perhaps every time) when I copy content from another odt (let's say doc. 2) and after that when I copy content from the web and want to paste it into doc. 1 (.odt), the doc. 1 won't accept the content from the web, but still obstinate pastes the old content from doc. 2. Yet pasting the same content from the web into any other application, like notepad++, wordpad, or other, it works fine. But not into the odt doc. nr. 1. What's going on?
LibreOffice 5 (5.1.4.2 (x64)) on Win 10 Pro
kryman
 
Posts: 45
Joined: Mon Dec 10, 2012 2:48 am

Re: Pasting from clipboard will not work sometimes

Postby kryman » Tue Jul 02, 2013 11:58 am

obswob wrote:Have you tried deleting your user profile?
c:\users\yourname\appdata\roaming\openoffice.org\3\user.
Delete or rename that folder.

I've had problems where paste would only paste old content, a bit like what you say. Doing this fixed it, along will all kinds of other bizarre intermittent bugs.

I've tried this one too, both renaming and deleting the profile. And yes, when deleting the profile it went a bit smoother, yet, I still have the same error as you can see above this reply on 02 Jul 2013, 11:56.
LibreOffice 5 (5.1.4.2 (x64)) on Win 10 Pro
kryman
 
Posts: 45
Joined: Mon Dec 10, 2012 2:48 am

Re: Pasting from clipboard will not work sometimes

Postby Hagar Delest » Sat Jul 27, 2013 9:22 am

AOO 4.1.7 on Xubuntu 20.04 and 4.1.5 on Windows 10 (with winPenPack port).
User avatar
Hagar Delest
Moderator
 
Posts: 28951
Joined: Sun Oct 07, 2007 9:07 pm
Location: France

Re: [Issue] Pasting from clipboard will not work sometimes

Postby kryman » Sat Jul 27, 2013 9:27 am

Thanks for the reply. Yep, I've read a little of those links before your reply. And waiting some seconds seems for me the only solution now. I've gone over to LibreOffice some month ago, and surely, the same problem occur there too, but this I believe shouldn't be of any surprise.
LibreOffice 5 (5.1.4.2 (x64)) on Win 10 Pro
kryman
 
Posts: 45
Joined: Mon Dec 10, 2012 2:48 am

Re: [Issue] Pasting from clipboard will not work sometimes

Postby Hagar Delest » Sun Jul 28, 2013 11:00 pm

Can you test again with AOO 4?
AOO 4.1.7 on Xubuntu 20.04 and 4.1.5 on Windows 10 (with winPenPack port).
User avatar
Hagar Delest
Moderator
 
Posts: 28951
Joined: Sun Oct 07, 2007 9:07 pm
Location: France

Re: [Issue] Pasting from clipboard will not work sometimes

Postby kryman » Mon Jul 29, 2013 7:55 am

Hagar Delest wrote:Can you test again with AOO 4?

Sure. I installed the latest version from their webpage today (Apache_OpenOffice_4.0.0_Win_x86_install_en-US.exe), and the same problem is there. If you're on Win 7 x64 you should have the same problem, whatever version of Windows and version of AOO or LO installed, at least the latest versions.

Perhaps we can only wait and sit to see what happens.
LibreOffice 5 (5.1.4.2 (x64)) on Win 10 Pro
kryman
 
Posts: 45
Joined: Mon Dec 10, 2012 2:48 am

Re: [Issue] Pasting from clipboard will not work sometimes

Postby Hagar Delest » Mon Jul 29, 2013 8:55 am

It must be something linked to some corner case too because I've experienced this only once.
AOO 4.1.7 on Xubuntu 20.04 and 4.1.5 on Windows 10 (with winPenPack port).
User avatar
Hagar Delest
Moderator
 
Posts: 28951
Joined: Sun Oct 07, 2007 9:07 pm
Location: France

Re: [Issue] Pasting from clipboard will not work sometimes

Postby kryman » Mon Jul 29, 2013 11:49 am

Hagar Delest wrote:It must be something linked to some corner case too because I've experienced this only once.

Perhaps you're not as familiar to this problem as I am. Or, of course, perhaps you've understand it quite good. For me this happens every time, try it yourself if you haven't.

Open a new odt (nr. 1), write something in it, copy it to a new odt (nr. 2), and then copy some content from the web into nr. 2. For me always the old content copies from the odt numbered as 1, but never the new from the web.

Try this if you haven't and let me know. Of course, reply to me please that you're also using an x64 based Windows os.
LibreOffice 5 (5.1.4.2 (x64)) on Win 10 Pro
kryman
 
Posts: 45
Joined: Mon Dec 10, 2012 2:48 am

Re: [Issue] Pasting from clipboard will not work sometimes

Postby Hagar Delest » Mon Jul 29, 2013 10:44 pm

Works fine with Ubuntu 64bit, will try with Windows 7 tomorrow.
AOO 4.1.7 on Xubuntu 20.04 and 4.1.5 on Windows 10 (with winPenPack port).
User avatar
Hagar Delest
Moderator
 
Posts: 28951
Joined: Sun Oct 07, 2007 9:07 pm
Location: France

Re: Pasting from clipboard will not work sometimes

Postby skickahit10 » Fri Apr 10, 2020 10:34 am

Hagar Delest wrote:We have seen such issues indeed in the forum.
The workaround is to copy and paste content from your document to your document to somehow reset the clipboard.

Please add '[Solved]' at the beginning of your first post title (edit button) if your issue has been fixed.


It's 2020 and the same issue is still around :lol:

Luckily, however, the same workaround still works ;)
OpenOffice v4.1.6
Windows 10 Home, 64-bit
skickahit10
 
Posts: 5
Joined: Fri Dec 20, 2013 12:49 pm

Re: [Issue] Pasting from clipboard will not work sometimes

Postby Villeroy » Fri Apr 10, 2020 5:09 pm

It's 2020 and the same issue is still around :lol:

Luckily, however, the same workaround still works ;)

If you want any progress, install https://libreoffice.org/ instead of OpenOffice.
Pasting plain text only is not a work-around. It is best practise.
Please, edit this topic's initial post and add "[Solved]" to the subject line if your problem has been solved.
Ubuntu 18.04, no OpenOffice, LibreOffice 6.4
User avatar
Villeroy
Volunteer
 
Posts: 28544
Joined: Mon Oct 08, 2007 1:35 am
Location: Germany


Return to Writer

Who is online

Users browsing this forum: No registered users and 11 guests