[Solved] Auto Spell Check Not Working Right

Discuss the word processor

[Solved] Auto Spell Check Not Working Right

Postby gshatterhand » Sat Oct 06, 2012 4:44 pm

My automatic spell check will simply not work consistently. It works in some documents, and only in certain parts of other documents. (Such documents have NOT been created in different programs or at different times.)

The Auto Spell Check box IS checked in TOOLS, OPTIONS, LANGUAGE SETTINGS, WRITING AIDS.

I also just reinstalled Apache Open Office 3.4.1. Using Windows 7. The auto spell check still functions improperly, exactly as it did before. Shutting down and restarting the program does not seem to have any effect.

I found many complaints and questions about this problem on the WEB and thought surely I would find a definitive answer here. If the answer is here, I'm missing it.
Last edited by Hagar Delest on Sat Oct 06, 2012 11:21 pm, edited 1 time in total.
Reason: tagged [Solved].
Open Office 3.4.1
Windows 7
gshatterhand
 
Posts: 7
Joined: Sat Oct 06, 2012 4:28 pm

Re: Auto Spell Check Not Working Right

Postby FJCC » Sat Oct 06, 2012 5:12 pm

Have tried the steps in the spell check troubleshooting tutorial?
AOO 3.4 or 4.0 on MS Windows XP ( before 2013-08-03) or Windows 7
If your question is answered, please go to your first post, select the Edit button, and add [Solved] to the beginning of the title.
FJCC
Moderator
 
Posts: 3678
Joined: Sat Nov 08, 2008 8:08 pm
Location: Colorado, USA

Re: Auto Spell Check Not Working Right

Postby gshatterhand » Sat Oct 06, 2012 7:07 pm

I tried. Spent over an hour and a half trying to go through the steps that seem to relate. But the tutorial is from 2007, and my program doesn't seem to respond as the tutorial says it will.

In fact, I don't find anything in the tutorial that seems to directly relate to auto spell checker working sometimes, in some documents, only in some parts of some documents, or not at all. I really tried to troubleshoot as directed.

Any chance some kind soul can suggest some more direct, relevant ways to deal with this? I'm not a novice with computers but no expert. How can there be so little here about this issue when it seems to be such a common complaint on the web? Just looking for help.
Open Office 3.4.1
Windows 7
gshatterhand
 
Posts: 7
Joined: Sat Oct 06, 2012 4:28 pm

Re: Auto Spell Check Not Working Right

Postby FJCC » Sat Oct 06, 2012 7:38 pm

Could you upload a document illustrating the problem? Be sure it doesn't contain confidential information. There is an Upload Attachment just under the box where you type a response. Also, when you say spell check doesn't work, does that mean it flags everything as misspelled or it flags nothing?
AOO 3.4 or 4.0 on MS Windows XP ( before 2013-08-03) or Windows 7
If your question is answered, please go to your first post, select the Edit button, and add [Solved] to the beginning of the title.
FJCC
Moderator
 
Posts: 3678
Joined: Sat Nov 08, 2008 8:08 pm
Location: Colorado, USA

Re: Auto Spell Check Not Working Right

Postby gshatterhand » Sat Oct 06, 2012 9:15 pm

Thanks for following up.

Automatic Spell Check is working in certain sections of the same document. And not in others. For instance, I can type a nonsense word, clearly misspelled, into one part of the document, and it is flagged as misspelled. In another section of the same document, it might not be. In some documents, the auto spell check works for the entire document. In no instance has every word been flagged as misspelled.

I've never uploaded a document to this site, but I might be able to. Problem is I'll probably have to create a new document. All the current problem documents are the pages of a nonfiction publication slated for publication early next year. Creating a new document to illustrate the issue could take a while. If it doesn't appear, don't assume I've solved the problem. I'll see if I can duplicate the issue but the document might be a bit incoherent, at least as far as content.
Open Office 3.4.1
Windows 7
gshatterhand
 
Posts: 7
Joined: Sat Oct 06, 2012 4:28 pm

Re: Auto Spell Check Not Working Right

Postby Hagar Delest » Sat Oct 06, 2012 9:34 pm

For the record, there are more screenshots in that one: [Troubleshooting] Spell check in OOo 3.x (link in previous tutorial at the beginning).

If it works in areas and not in others, select the text where it doesn't work and hit Ctrl+M.

Please add '[Solved]' at the beginning of your first post title (edit button) if your issue has been fixed.
AOO 4.0.1 on Windows 7 and Xubuntu 14.04 (Trusty Tahr)
User avatar
Hagar Delest
Moderator
 
Posts: 25105
Joined: Sun Oct 07, 2007 9:07 pm
Location: France

Re: Auto Spell Check Not Working Right

Postby gshatterhand » Sat Oct 06, 2012 9:35 pm

I thought it would be tough, but I've managed to create a short sample document in which the Auto Spell Checker is working in the top half of the document, but not in the bottom half.

You will see that the word Prsstsse is flagged as misspelled in one part of the document but not in another part of the document. I hope this is a sufficient example. Also hope I can upload it correctly. I'm going to try.
Attachments
example problem document.doc
(13 KiB) Downloaded 109 times
gshatterhand
 
Posts: 7
Joined: Sat Oct 06, 2012 4:28 pm

Re: Auto Spell Check Not Working Right

Postby Hagar Delest » Sat Oct 06, 2012 9:49 pm

Well, rather strange, the Ctrl+M doesn't seem to work. But select all and right click the status bar and select "Reset to default language".

Please add '[Solved]' at the beginning of your first post title (edit button) if your issue has been fixed.
AOO 4.0.1 on Windows 7 and Xubuntu 14.04 (Trusty Tahr)
User avatar
Hagar Delest
Moderator
 
Posts: 25105
Joined: Sun Oct 07, 2007 9:07 pm
Location: France

Re: Auto Spell Check Not Working Right

Postby gshatterhand » Sat Oct 06, 2012 9:55 pm

What would Ctrl-M normally do?
Open Office 3.4.1
Windows 7
gshatterhand
 
Posts: 7
Joined: Sat Oct 06, 2012 4:28 pm

Re: Auto Spell Check Not Working Right

Postby Hagar Delest » Sat Oct 06, 2012 9:57 pm

It resets the formatting. Usually, it includes the language too. But not in this case, not sure why. Perhaps there is a link with the fact that this is a .doc file.
AOO 4.0.1 on Windows 7 and Xubuntu 14.04 (Trusty Tahr)
User avatar
Hagar Delest
Moderator
 
Posts: 25105
Joined: Sun Oct 07, 2007 9:07 pm
Location: France

Re: Auto Spell Check Not Working Right

Postby gshatterhand » Sat Oct 06, 2012 10:01 pm

By SELECT ALL, do you mean Ctrl-A?

Even when I have all the text in the document highlighted, and I right-click on the Status Bar, nothing happens. I am given no option in response. No chance to "Reset to default language."
Open Office 3.4.1
Windows 7
gshatterhand
 
Posts: 7
Joined: Sat Oct 06, 2012 4:28 pm

Re: Auto Spell Check Not Working Right

Postby gshatterhand » Sat Oct 06, 2012 10:03 pm

OH, I found it. I was clicking in the wrong place. Sorry. Yes, when I reset to default language it seems to make the auto spell check function throughout the whole document.
Open Office 3.4.1
Windows 7
gshatterhand
 
Posts: 7
Joined: Sat Oct 06, 2012 4:28 pm


Return to Writer

Who is online

Users browsing this forum: No registered users and 35 guests